Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: How to set desktop color depth?

  1. #1

    Default How to set desktop color depth?

    I have this problem since I reinstalled my system (fresh install, keeping /home), formerly it worked well. It looks like my desktop displays only a reduced color depth. The transparency effects look dithered and when watching a movie with vlc, the colors look like reduced color depth. How can I check which color depth is used and how can I change it?
    TIA

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,448

    Default Re: How to set desktop color depth?

    You do not say which desktop you are using. In KDE you can adjust things in System settings>Colours. Other desktops may have similar options.

  3. #3

    Default Re: How to set desktop color depth?

    Ups, sorry. Yes, I am using KDE. But under Settings > Colors I only find the color schemes to select from. Actually I am using Breeze. But I didn't find anything to set the color depth.

  4. #4
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,631

    Default Re: How to set desktop color depth?

    Please install current inxi version and provide here using code tags output from:
    Code:
    inxi -GxxS
    An older inxi version is in standard TW repos.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  5. #5

    Default Re: How to set desktop color depth?

    inxi says:

    System: Host: linux-c55v Kernel: 5.2.3-1-default x86_64 bits: 64 compiler: gcc v: 9.1.1
    Desktop: KDE Plasma 5.16.3 tk: Qt 5.13.0 wm: kwin_x11 dm: SDDM
    Distro: openSUSE Tumbleweed 20190730
    Graphics: Device-1: AMD Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X]
    vendor: Sapphire Limited driver: amdgpu v: kernel bus ID: 01:00.0 chip ID: 1002:67ef
    Display: x11 server: X.org 1.20.5 driver: amdgpu FAILED: ati unloaded: fbdev,modesetting,vesa
    compositor: kwin_x11 resolution: <xdpyinfo missing>
    OpenGL: renderer: Radeon RX 560 Series (POLARIS11 DRM 3.32.0 5.2.3-1-default LLVM 8.0.1)
    v: 4.5 Mesa 19.1.3 direct render: Yes

  6. #6

    Default Re: How to set desktop color depth?

    inxi version is 3.0.35-00 (2019-07-15)

  7. #7
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,631

    Default Re: How to set desktop color depth?

    Both KInfoCenter and 'kcmshell5 xserver' will report the color depth in use, but may require xdpyinfo be installed first, as suggested by inxi output, as xdpyinfo is most likely where those utilities get that information:
    Code:
    ~> xdpyinfo | grep -A2 dimens
      dimensions:    1920x1200 pixels (406x254 millimeters)
      resolution:    120x120 dots per inch
      depths (7):    24, 1, 4, 8, 15, 16, 32
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  8. #8

    Default Re: How to set desktop color depth?

    OK, installed xdpyinfo, here is the output

    Code:
    arne@linux-c55v:~/bin> ./inxi -GxxS
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
            LANGUAGE = "",
            LC_ALL = (unset),
            LC_MONETARY = "en_DE.UTF-8",
            LC_MEASUREMENT = "en_DE.UTF-8",
            LC_TIME = "en_DE.UTF-8",
            LC_COLLATE = "en_DE.UTF-8",
            LC_NUMERIC = "en_DE.UTF-8",
            LANG = "en_DE.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    System:    Host: linux-c55v Kernel: 5.2.3-1-default x86_64 bits: 64 compiler: gcc v: 9.1.1 
               Desktop: KDE Plasma 5.16.3 tk: Qt 5.13.0 wm: kwin_x11 dm: SDDM 
               Distro: openSUSE Tumbleweed 20190730 
    Graphics:  Device-1: AMD Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X] 
               vendor: Sapphire Limited driver: amdgpu v: kernel bus ID: 01:00.0 chip ID: 1002:67ef 
               Display: x11 server: X.Org 1.20.5 driver: amdgpu FAILED: ati unloaded: fbdev,modesetting,vesa 
               compositor: kwin_x11 resolution: 1920x1080~60Hz 
               OpenGL: renderer: Radeon RX 560 Series (POLARIS11 DRM 3.32.0 5.2.3-1-default LLVM 8.0.1) 
               v: 4.5 Mesa 19.1.3 direct render: Yes 
    arne@linux-c55v:~/bin> xdpyinfo | grep -A2 dimens
      dimensions:    1920x1080 pixels (508x285 millimeters)
      resolution:    96x96 dots per inch
      depths (7):    24, 1, 4, 8, 15, 16, 32
    Does this mean, I do already have 24 bit color depth enabled?
    Thanks

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,646
    Blog Entries
    15

    Default Re: How to set desktop color depth?

    Quote Originally Posted by abruenin View Post
    OK, installed xdpyinfo, here is the output

    Code:
    arne@linux-c55v:~/bin> ./inxi -GxxS
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
            LANGUAGE = "",
            LC_ALL = (unset),
            LC_MONETARY = "en_DE.UTF-8",
            LC_MEASUREMENT = "en_DE.UTF-8",
            LC_TIME = "en_DE.UTF-8",
            LC_COLLATE = "en_DE.UTF-8",
            LC_NUMERIC = "en_DE.UTF-8",
            LANG = "en_DE.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    System:    Host: linux-c55v Kernel: 5.2.3-1-default x86_64 bits: 64 compiler: gcc v: 9.1.1 
               Desktop: KDE Plasma 5.16.3 tk: Qt 5.13.0 wm: kwin_x11 dm: SDDM 
               Distro: openSUSE Tumbleweed 20190730 
    Graphics:  Device-1: AMD Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X] 
               vendor: Sapphire Limited driver: amdgpu v: kernel bus ID: 01:00.0 chip ID: 1002:67ef 
               Display: x11 server: X.Org 1.20.5 driver: amdgpu FAILED: ati unloaded: fbdev,modesetting,vesa 
               compositor: kwin_x11 resolution: 1920x1080~60Hz 
               OpenGL: renderer: Radeon RX 560 Series (POLARIS11 DRM 3.32.0 5.2.3-1-default LLVM 8.0.1) 
               v: 4.5 Mesa 19.1.3 direct render: Yes 
    arne@linux-c55v:~/bin> xdpyinfo | grep -A2 dimens
      dimensions:    1920x1080 pixels (508x285 millimeters)
      resolution:    96x96 dots per inch
      depths (7):    24, 1, 4, 8, 15, 16, 32
    Does this mean, I do already have 24 bit color depth enabled?
    Thanks
    Hi
    If you check the output this is the likely error...

    Code:
    Display: x11 server: X.Org 1.20.5 driver: ==> amdgpu FAILED <==: ati unloaded: fbdev,modesetting,vesa
    Can you upload the Xorg log via susepaste (you may need to install);

    Code:
    cat .local/share/xorg/Xorg.0.log | susepaste -t "Xorg Log" -n "Anonymous" -e 0
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  10. #10
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,631

    Default Re: How to set desktop color depth?

    Quote Originally Posted by malcolmlewis View Post
    If you check the output this is the likely error...

    Code:
    Display: x11 server: X.Org 1.20.5 driver: ==> amdgpu FAILED <==: ati unloaded: fbdev,modesetting,vesa
    I believe that represents two inxi errors, and the meaning of the output is this:
    Code:
    Display:	x11
    server:		X.Org 1.20.5
    driver:		amdgpu
    (FAILED:	ati)
    unloaded:	fbdev,modesetting,vesa
    The ati DDX should "fail", as in not remain loaded, when the preferred amdgpu has succeeded. Output I would expect might be this:
    Code:
    Display:	x11
    server:		X.Org 1.20.5
    driver:		amdgpu
    unloaded:	ati,fbdev,modesetting,vesa
    The inxi devel version has had many revisions since the 3.0.2-1 version in TW, particularly since 3.0.5-0, and is now up to 3.0.5-11 as pinxi.

    "depths (7): 24, 1, 4, 8, 15, 16, 32" indeed means 24 bit is in current use.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •