Results 1 to 5 of 5

Thread: KDE Plasma - 23 July 2019 - IBus Panel suddenly English and login suddenly very slow

  1. #1
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,514

    Default KDE Plasma - 23 July 2019 - IBus Panel suddenly English and login suddenly very slow

    The IBus Panel Plasmoid used to be “DE” – now it's “EN” and, the login takes longer than expected.
    • Also, the right hand “Alt” key (“alt gr”) no longer works as expected.


    “ibus engine” indicates ‘xkb:us::eng’.
    Executing “ibus engine xkb:de::ger” puts everything back to where it should be – the right hand “Alt” key works as expected.

    The only patches which have been installed within the last 24 hours are some “ImageMagick” ones.
    The system language is “de_DE” – UTF-8.
    Changing anything dealing with the keyboard layout (Cherry CyMotion Master Linux) results in “X” and KDE configuration eating CPU for a minute or two.
    Any ideas?
    • Or, do I need to add “ibus engine xkb:de::ger” to a KDE login script?

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,514

    Question Re: KDE Plasma - 23 July 2019 - IBus Panel suddenly English and login suddenly very slow

    Executed a forced reinstallation of:
    • ibus, ibus-gtk, ibus-gtk3, ibus-lang, ibus-qt, libibus-1_0-5 and typelib-1_0-IBus-1_0;
    • dbus-1, dbus-1-glib, dbus-1-glib-tool, dbus-1-x11, kdbusaddons-tools, libKF5DBusAddons5, libQt5DBus5, libdbus-1-3, libdbus-1-3-32bit, libqt5-qdbus, perl-Net-DBus, python2-dbus-python, python3-dbus-python, python3-slip-dbus, ruby2.5-rubygem-ruby-dbus and system-config-printer-dbus-service.

    And, the spook is gone … ← the Right Hand “Alt” key is once again working as expected – and the KDE Plasma IBus Plasmoid is once again “DE” – and the KDE login is no longer slower than what it was before …

    Any ideas anyone?

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,977

    Default Re: KDE Plasma - 23 July 2019 - IBus Panel suddenly English and login suddenly very slow

    Nice you repaired it.

    I see no connection between the patches you mention in your first post and the forced re-installs you did (there is of course a relation between the re-installed packages and the problem). Thus I doubt we will ever uderstand what went wrong.
    Henk van Velden

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,514

    Default Re: KDE Plasma - 23 July 2019 - IBus Panel suddenly English and login suddenly very slow

    Thanks Henk!

    Going back through the Zypper history, I see that, on the 20th of July there were a couple of D-Bus patches:
    • libdbus-1-3-1.12.2-lp151.4.3.1; libdbus-1-3-32bit-1.12.2-lp151.4.3.1; dbus-1-x11-1.12.2-lp151.4.3.1; dbus-1-1.12.2-lp151.4.3.1.

    Whether or not something went wrong as a result of these patches hasn't been proven, one way or another …

    The only IBus changes were at the beginning of this month when I upgraded from Leap 15.0 to 15.1 …

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,977

    Default Re: KDE Plasma - 23 July 2019 - IBus Panel suddenly English and login suddenly very slow

    Difficult to base a bug report on this. The more because nobody reported the same until now.

    Yes, even in ICT there are riddles
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •