Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Unable to install some packages in R

  1. #1

    Default Unable to install some packages in R

    I cannot remember in which way I installed R. But my current version is:
    Code:
    platform       x86_64-suse-linux-gnu       
    arch           x86_64                      
    os             linux-gnu                   
    system         x86_64, linux-gnu           
    status                                     
    major          3                           
    minor          5.0                         
    year           2018                        
    month          04                          
    day            23                          
    svn rev        74626                       
    language       R                           
    version.string R version 3.5.0 (2018-04-23)
    nickname       Joy in Playing
    When I want to update it tells me:

    Code:
    (base) main@linux-7qur:~> sudo zypper update R-base
    [sudo] password for root: 
    Loading repository data...
    Reading installed packages...
    No update candidate for 'R-base-3.5.0-lp151.6.53.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    
    Nothing to do.
    Although it is not the most recent version. Working with it so far was fine. But now I really need the package "VGAM".
    Installing it gives me:

    Code:
    install.packages("VGAM")
    Installing package into ‘/home/main/R/x86_64-suse-linux-gnu-library/3.5’
    (as ‘lib’ is unspecified)
    trying URL 'https://cran.rstudio.com/src/contrib/VGAM_1.1-1.tar.gz'
    Content type 'application/x-gzip' length 2624046 bytes (2.5 MB)
    ==================================================
    downloaded 2.5 MB
    
    * installing *source* package ‘VGAM’ ...
    ** package ‘VGAM’ successfully unpacked and MD5 sums checked
    ** libs
    gcc -I"/usr/lib64/R/include" -DNDEBUG   -I/usr/local/include   -fpic  -fmessage-length=0 -grecord-gcc-switches -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection -g  -c VGAM_init.c -o VGAM_init.o
    /bin/sh: gcc: command not found
    make: *** [/usr/lib64/R/etc/Makeconf:159: VGAM_init.o] Error 127
    ERROR: compilation failed for package ‘VGAM’
    * removing ‘/home/main/R/x86_64-suse-linux-gnu-library/3.5/VGAM’
    * restoring previous ‘/home/main/R/x86_64-suse-linux-gnu-library/3.5/VGAM’
    Warning in install.packages :
      installation of package ‘VGAM’ had non-zero exit status
    
    The downloaded source packages are in
        ‘/tmp/RtmpkGtevI/downloaded_packages’
    So I downloaded the package on https://www.stat.auckland.ac.nz/~yee...download.shtmland put it in the folder of the other packages. Then using library gives me:
    Code:
    library(VGAM)
    Error in library(VGAM) : ‘VGAM’ is not a valid installed package
    What to do? I need the package ASAP. I hope anyone is familiar with that problem.

    regards

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,306
    Blog Entries
    2

    Default Re: Unable to install some packages in R

    Quote Originally Posted by LiBurner1 View Post
    I cannot remember in which way I installed R. But my current version is:
    Code:
    platform       x86_64-suse-linux-gnu       
    arch           x86_64                      
    os             linux-gnu                   
    system         x86_64, linux-gnu           
    status                                     
    major          3                           
    minor          5.0                         
    year           2018                        
    month          04                          
    day            23                          
    svn rev        74626                       
    language       R                           
    version.string R version 3.5.0 (2018-04-23)
    nickname       Joy in Playing
    When I want to update it tells me:

    Code:
    (base) main@linux-7qur:~> sudo zypper update R-base
    [sudo] password for root: 
    Loading repository data...
    Reading installed packages...
    No update candidate for 'R-base-3.5.0-lp151.6.53.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    
    Nothing to do.
    Although it is not the most recent version. Working with it so far was fine. But now I really need the package "VGAM".
    Installing it gives me:

    Code:
    install.packages("VGAM")
    Installing package into ‘/home/main/R/x86_64-suse-linux-gnu-library/3.5’
    (as ‘lib’ is unspecified)
    trying URL 'https://cran.rstudio.com/src/contrib/VGAM_1.1-1.tar.gz'
    Content type 'application/x-gzip' length 2624046 bytes (2.5 MB)
    ==================================================
    downloaded 2.5 MB
    
    * installing *source* package ‘VGAM’ ...
    ** package ‘VGAM’ successfully unpacked and MD5 sums checked
    ** libs
    gcc -I"/usr/lib64/R/include" -DNDEBUG   -I/usr/local/include   -fpic  -fmessage-length=0 -grecord-gcc-switches -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection -g  -c VGAM_init.c -o VGAM_init.o
    /bin/sh: gcc: command not found
    make: *** [/usr/lib64/R/etc/Makeconf:159: VGAM_init.o] Error 127
    ERROR: compilation failed for package ‘VGAM’
    * removing ‘/home/main/R/x86_64-suse-linux-gnu-library/3.5/VGAM’
    * restoring previous ‘/home/main/R/x86_64-suse-linux-gnu-library/3.5/VGAM’
    Warning in install.packages :
      installation of package ‘VGAM’ had non-zero exit status
    
    The downloaded source packages are in
        ‘/tmp/RtmpkGtevI/downloaded_packages’
    So I downloaded the package on https://www.stat.auckland.ac.nz/~yee...download.shtmland put it in the folder of the other packages. Then using library gives me:
    Code:
    library(VGAM)
    Error in library(VGAM) : ‘VGAM’ is not a valid installed package
    What to do? I need the package ASAP. I hope anyone is familiar with that problem.

    regards
    Install gcc, you'll also likely need to install make and possibly configure(not always required).
    Or, go into YaST > Software Manager and install the C Development pattern.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,878
    Blog Entries
    15

    Default Re: Unable to install some packages in R

    Quote Originally Posted by tsu2 View Post
    Install gcc, you'll also likely need to install make and possibly configure(not always required).
    Or, go into YaST > Software Manager and install the C Development pattern.

    TSU
    Hi
    The 'configure' command is found in a source tarball, or if not, normally requires the auto tools (automake, autoconf, libtool etc) to regenerate with autoconf -vif.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4

    Default Re: Unable to install some packages in R

    I installed GCC7, nothing has changed. I don't know what you mean by configure (especially not what it is about tarball). The command autoconf -vif does not exist.
    Best

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,306
    Blog Entries
    2

    Default Re: Unable to install some packages in R

    Quote Originally Posted by LiBurner1 View Post
    I installed GCC7, nothing has changed. I don't know what you mean by configure (especially not what it is about tarball). The command autoconf -vif does not exist.
    Best
    After installing gcc and prerequisites,
    Post the new output from your compile attempt.
    At the moment, don't know if you still have a gcc problem or something new.

    Compiling can be an iterative process... If you don't know what the prerequisites are, then you can only keep doing compile tries, and each time the error will tell you what needs to be addressed.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  6. #6

    Default Re: Unable to install some packages in R

    Quote Originally Posted by tsu2 View Post
    After installing gcc and prerequisites,
    Post the new output from your compile attempt.
    At the moment, don't know if you still have a gcc problem or something new.

    Compiling can be an iterative process... If you don't know what the prerequisites are, then you can only keep doing compile tries, and each time the error will tell you what needs to be addressed.

    TSU
    The new error is:

    Code:
    install.packages("VGAM")
    Installing package into ‘/home/main/R/x86_64-suse-linux-gnu-library/3.5’
    (as ‘lib’ is unspecified)
    trying URL 'https://cran.rstudio.com/src/contrib/VGAM_1.1-1.tar.gz'
    Content type 'application/x-gzip' length 2624046 bytes (2.5 MB)
    ==================================================
    downloaded 2.5 MB
    
    * installing *source* package ‘VGAM’ ...
    ** package ‘VGAM’ successfully unpacked and MD5 sums checked
    ** libs
    gcc -I"/usr/lib64/R/include" -DNDEBUG   -I/usr/local/include   -fpic  -fmessage-length=0 -grecord-gcc-switches -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection -g  -c VGAM_init.c -o VGAM_init.o
    /bin/sh: gcc: command not found
    make: *** [/usr/lib64/R/etc/Makeconf:159: VGAM_init.o] Error 127
    ERROR: compilation failed for package ‘VGAM’
    * removing ‘/home/main/R/x86_64-suse-linux-gnu-library/3.5/VGAM’
    Warning in install.packages :
      installation of package ‘VGAM’ had non-zero exit status
    
    The downloaded source packages are in
        ‘/tmp/Rtmpz1n5FC/downloaded_packages’

  7. #7

    Default Re: Unable to install some packages in R

    Sorry. I saw that it was the same. So I installed gcc from https://software.opensuse.org/package/gcc

    The new error is:
    Code:
    install.packages("VGAM")
    Installing package into ‘/home/main/R/x86_64-suse-linux-gnu-library/3.5’
    (as ‘lib’ is unspecified)
    trying URL 'https://cran.rstudio.com/src/contrib/VGAM_1.1-1.tar.gz'
    Content type 'application/x-gzip' length 2624046 bytes (2.5 MB)
    ==================================================
    downloaded 2.5 MB
    
    * installing *source* package ‘VGAM’ ...
    ** package ‘VGAM’ successfully unpacked and MD5 sums checked
    ** libs
    gcc -I"/usr/lib64/R/include" -DNDEBUG   -I/usr/local/include   -fpic  -fmessage-length=0 -grecord-gcc-switches -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection -g  -c VGAM_init.c -o VGAM_init.o
    gcc -I"/usr/lib64/R/include" -DNDEBUG   -I/usr/local/include   -fpic  -fmessage-length=0 -grecord-gcc-switches -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection -g  -c caqo3.c -o caqo3.o
    gfortran   -fpic  -fmessage-length=0 -grecord-gcc-switches -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection -g  -c cqof.f -o cqof.o
    make: gfortran: Command not found
    make: *** [/usr/lib64/R/etc/Makeconf:182: cqof.o] Error 127
    ERROR: compilation failed for package ‘VGAM’
    * removing ‘/home/main/R/x86_64-suse-linux-gnu-library/3.5/VGAM’
    Warning in install.packages :
      installation of package ‘VGAM’ had non-zero exit status
    
    The downloaded source packages are in
        ‘/tmp/Rtmpz1n5FC/downloaded_packages’

  8. #8

    Default Re: Unable to install some packages in R

    Ok. Thank you. I installed gcc-fortran and after many many warning during the installation process it works.
    I have got the VGAM package. But this is not the solution to all my problems.

    The next package is called lme4 and I get the following:

    Code:
    install.packages("lme4")
    Installing package into ‘/home/main/R/x86_64-suse-linux-gnu-library/3.5’
    (as ‘lib’ is unspecified)
    also installing the dependency ‘nloptr’
    
    trying URL 'https://cran.rstudio.com/src/contrib/nloptr_1.2.1.tar.gz'
    Content type 'application/x-gzip' length 2448313 bytes (2.3 MB)
    ==================================================
    downloaded 2.3 MB
    
    trying URL 'https://cran.rstudio.com/src/contrib/lme4_1.1-21.tar.gz'
    Content type 'application/x-gzip' length 4124154 bytes (3.9 MB)
    ==================================================
    downloaded 3.9 MB
    
    * installing *source* package ‘nloptr’ ...
    ** package ‘nloptr’ successfully unpacked and MD5 sums checked
    configure: loading site script /usr/share/site/x86_64-unknown-linux-gnu
    checking whether the C++ compiler works... no
    configure: error: in `/tmp/RtmpD8kgd9/R.INSTALL30296e4b9c4d/nloptr':
    configure: error: C++ compiler cannot create executables
    See `config.log' for more details
    ERROR: configuration failed for package ‘nloptr’
    * removing ‘/home/main/R/x86_64-suse-linux-gnu-library/3.5/nloptr’
    Warning in install.packages :
      installation of package ‘nloptr’ had non-zero exit status
    ERROR: dependency ‘nloptr’ is not available for package ‘lme4’
    * removing ‘/home/main/R/x86_64-suse-linux-gnu-library/3.5/lme4’
    Warning in install.packages :
      installation of package ‘lme4’ had non-zero exit status
    
    The downloaded source packages are in
        ‘/tmp/Rtmpz1n5FC/downloaded_packages’

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,559

    Cool Re: Unable to install some packages in R

    Quote Originally Posted by LiBurner1 View Post
    The next package is called lme4 and I get the following:
    “R-lme4” seems to be a NetBSD package …
    • But, it seems that someone has submitted “R-lme4” to the archlinux repositories …


    So, diving into the “R” world – as ever, a Bell Labs idea …
    You need:
    • R-core – which is in the openSUSE repositories, as is everything else listed here …
    • R-core-libs
    • R-core-packages: Compiler, Datasets, and so on and so on …
    • R-recommended-packages: Base, Matrix, MASS, and so on and so on …

    Included in the “recommended packages” is: “R-nlme” …

  10. #10

    Default Re: Unable to install some packages in R

    Quote Originally Posted by dcurtisfra View Post
    “R-lme4” seems to be a NetBSD package …
    • But, it seems that someone has submitted “R-lme4” to the archlinux repositories …


    So, diving into the “R” world – as ever, a Bell Labs idea …
    You need:
    • R-core – which is in the openSUSE repositories, as is everything else listed here …
    • R-core-libs
    • R-core-packages: Compiler, Datasets, and so on and so on …
    • R-recommended-packages: Base, Matrix, MASS, and so on and so on …

    Included in the “recommended packages” is: “R-nlme” …
    I see. The thing is that I need to use what my colleagues use. So I need to stick to "lme4".

    I have a general question. If we find the solution for "lme4" could it be that again there is another package making problems again? Is there no general solution? All those packages are easily to install on windows OS.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •