Page 3 of 3 FirstFirst 123
Results 21 to 22 of 22

Thread: Unable to install some packages in R

  1. #21
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,293
    Blog Entries
    2

    Default Re: Unable to install some packages in R

    Quote Originally Posted by LiBurner1 View Post
    I would like to get 3.6. But there is only 3.5 available for Leap 15.1
    See: https://software.opensuse.org/package/R-base

    I don't think this was the main problem as I could also get the old release of the "gh"-package and it also did not work. The only thing that changes is that the "in addition" error is not there anymore.

    I downloaded your repository although don't understand for what it is for.
    But it also does not seem to work:
    [sudo] password for root:
    Retrieving repository 'LEAP_15.1_R_repository' metadata .................[error]
    Repository 'LEAP_15.1_R_repository' is invalid.
    [LEAP_15.1_R_repository|http://download.opensuse.org/reposit...USE_Leap_15.1/] Valid metadata not found at specified URL
    The repository has 3.6 in it,
    And I can see what happened... This Forum software abbreviated the URL even though it was enclosed in CODE tags... I don't remember that happening before, is probably a newly introduced bug

    Don't copy the following URL,
    Copy the <link> of the URL... Typically you can Rt-click on the link and see the appropriate option, the exact wording would depend on the web browser you're using.

    http://download.opensuse.org/reposit...USE_Leap_15.1/

    So, you should build your URL string in 3 parts...
    First the zypper command
    Code:
    zypper ar -f
    Then paste the above URL,
    Then a space and then enter a name for your repository, I simply suggest
    Code:
    LEAP_15.1_R_repository
    Then you should refresh which should find the metadata and prompt you to accept the GPG key.
    After that, you should be able to install R, maybe simply doing a "zypper update" might be sufficient since you presumably already installed all the R packages for 3.5 but can't compile.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  2. #22

    Default Re: Unable to install some packages in R

    Quote Originally Posted by tsu2 View Post
    The repository has 3.6 in it,
    And I can see what happened... This Forum software abbreviated the URL even though it was enclosed in CODE tags... I don't remember that happening before, is probably a newly introduced bug

    Don't copy the following URL,
    Copy the <link> of the URL... Typically you can Rt-click on the link and see the appropriate option, the exact wording would depend on the web browser you're using.

    http://download.opensuse.org/reposit...USE_Leap_15.1/

    So, you should build your URL string in 3 parts...
    First the zypper command
    Code:
    zypper ar -f
    Then paste the above URL,
    Then a space and then enter a name for your repository, I simply suggest
    Code:
    LEAP_15.1_R_repository
    Then you should refresh which should find the metadata and prompt you to accept the GPG key.
    After that, you should be able to install R, maybe simply doing a "zypper update" might be sufficient since you presumably already installed all the R packages for 3.5 but can't compile.

    TSU
    Nice. Now I have got the most recent R version:

    Code:
    version             _                           
    platform       x86_64-suse-linux-gnu       
    arch           x86_64                      
    os             linux-gnu                   
    system         x86_64, linux-gnu           
    status                                     
    major          3                           
    minor          6.1                         
    year           2019                        
    month          07                          
    day            05                          
    svn rev        76782                       
    language       R                           
    version.string R version 3.6.1 (2019-07-05)
    With that it still did not work. I additionally installed libopenssl-devel and R-xml2 and the installation of "devtools" went through. I haven't started working with the package, but I guess the problem is solved now.
    Thanks for your help and sorry for late reply.

    Best

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •