Results 1 to 7 of 7

Thread: libqt5-qtwebengine broken after update to 20190718

  1. #1

    Default libqt5-qtwebengine broken after update to 20190718

    I just updated my Tumbleweed install after being away from home since the end of June, and various applications that rely on libqt5-qtwebengine (like kontact/kmail or ksysguard) are now broken in that they won't launch.

    Running any of these from a terminal, the only feedback given is
    Code:
    kontact: symbol lookup error: /usr/lib64/libQt5WebEngineCore.so.5: undefined symbol: FT_Palette_Select
    Due to other (now resolved) issues I had already installed, snapper rolled back and reinstalled the 20190718 updates three times, and this issue persisted, so probably not some freak installation issue. I haven't found any other mention of this issue, which makes me suspicious as that seems like it would be noticed fairly quickly.

    Anyone else run into this or have ideas on troubleshooting this further?

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,067

    Default AW: libqt5-qtwebengine broken after update to 20190718

    Post:
    Code:
    zypper lr -d
    And you use only!!
    Code:
    zypper dup
    to update your Tumbleweed?

  3. #3

    Default Re: libqt5-qtwebengine broken after update to 20190718

    Code:
    #  | Alias                               | Name              | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                       
    ---+-------------------------------------+-------------------+---------+-----------+---------+----------+--------+-------------------------------------------------------------------------------------------
    1  | NVidia                              | NVidia            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.nvidia.com/opensuse/tumbleweed/                                          
    2  | Packman                             | Packman           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed/                                         
    3  | openSUSE_Tumbleweed                 | Emulators         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/repositories/Emulators/openSUSE_Tumbleweed/                 
    4  | repo-debug                          | repo-debug        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/tumbleweed/repo/debug                                        
    5  | repo-non-oss                        | repo-non-oss      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/tumbleweed/repo/non-oss                                      
    6  | repo-oss                            | repo-oss          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/tumbleweed/repo/oss                                          
    7  | repo-update                         | repo-update       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/update/tumbleweed/                                           
    8  | smplayer-dev                        | smplayer-dev      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/repositories/home:/smplayerdev/openSUSE_Tumbleweed/
    And yes, I always update using zypper dup. From a text terminal usually, just in case X falls over and dies or something in the middle of an update.

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,484
    Blog Entries
    2

    Default Re: libqt5-qtwebengine broken after update to 20190718

    You can try adding the KDE Unstable repos to see if any of those packages might help...

    https://en.opensuse.org/SDB:KDE_repo...d_Applications

    Unfortunately,
    I can only speculate if the problem is likely that your KDE apps might need modification or different Qt libraries would be the proper solution... So i won't speculate...
    In the past I've found symbol lookup errors almost exclusively have been coding issues and not anything the User can do about without significant technical expertise and insight...

    If they don't work, I guess you can roll back again...

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  5. #5

    Default Re: libqt5-qtwebengine broken after update to 20190718

    Before I got to that, TW 20190721 just got pushed, which includes updates to libqt5-qtwebengine, but the issue persisted.

    Switching to the factory KDE packages does fix it, so it's definitely a problem with those particular package versions.

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,484
    Blog Entries
    2

    Default Re: libqt5-qtwebengine broken after update to 20190718

    Quote Originally Posted by trstbt View Post
    Before I got to that, TW 20190721 just got pushed, which includes updates to libqt5-qtwebengine, but the issue persisted.

    Switching to the factory KDE packages does fix it, so it's definitely a problem with those particular package versions.
    Be sure to submit a bug to https://bugzilla.opensuse.org with your findings so that someone can look at your issues, including
    - Specific affected applications
    - Your application versions if possible
    - That your resolution was packages from the Factory repos.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  7. #7

    Default Re: libqt5-qtwebengine broken after update to 20190718

    It's the freetype not libQt5WebEngineCore. Symbol FT_Palette_Select was introduced in version 2.10...
    Check the version of freetype2.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •