Results 1 to 3 of 3

Thread: NetworkManager with fortisslvpn unable to connect.

  1. #1

    Default NetworkManager with fortisslvpn unable to connect.

    Hello,

    I was unable to find information online, thus posting here.
    I am trying to connect via fortisslvpn with Network Manager but no success so far.
    I am getting following error in /var/log/NetworkManager

    Code:
    tail -f /var/log/NetworkManager
    2019-07-22T13:35:13.983256+04:00 lavagyan-lpt NetworkManager[18901]: <info>  [1563788113.9829] manager: startup complete
    2019-07-22T13:35:37.936071+04:00 lavagyan-lpt NetworkManager[18901]: <info>  [1563788137.9358] audit: op="connection-activate" uuid="b8aab714-27f5-4339-a817-bcf4fcfa2035" name="WFAM-vpn" pid=19169 uid=1000 resu
    lt="fail" reason="The VPN service 'org.freedesktop.NetworkManager.fortisslvpn' was not installed."
    
    For sure fortisslvpn is installed.

    Code:
    # zypper search forti
    Loading repository data...
    Reading installed packages...
    
    S  | Name                   | Summary                                  | Type
    ---+------------------------+------------------------------------------+--------
    i+ | openfortivpn           | Client for PPP+SSL VPN tunnel services   | package
    i+ | plasma-nm5-fortisslvpn | FortiGate SSL VPN support for plasma-nm5 | package
    
    # zypper info openfortivpn plasma-nm5-fortisslvpn
    Loading repository data...
    Reading installed packages...
    
    
    Information for package openfortivpn:
    -------------------------------------
    Repository     : openSUSE-Leap-15.1-Oss
    Name           : openfortivpn
    Version        : 1.9.0-lp151.1.1
    Arch           : x86_64
    Vendor         : openSUSE
    Installed Size : 133.1 KiB
    Installed      : Yes
    Status         : up-to-date
    Source package : openfortivpn-1.9.0-lp151.1.1.src
    Summary        : Client for PPP+SSL VPN tunnel services
    Description    :
        openfortivpn is a client for PPP+SSL VPN tunnel services. It spawns a pppd
        process and operates the communication between the gateway and this process.
    
        It is compatible with Fortinet VPNs.
    
    
    Information for package plasma-nm5-fortisslvpn:
    -----------------------------------------------
    Repository     : openSUSE-Leap-15.1-Oss
    Name           : plasma-nm5-fortisslvpn
    Version        : 5.12.8-lp151.1.1
    Arch           : x86_64
    Vendor         : openSUSE
    Installed Size : 134.8 KiB
    Installed      : Yes
    Status         : up-to-date
    Source package : plasma-nm5-5.12.8-lp151.1.1.src
    Summary        : FortiGate SSL VPN support for plasma-nm5
    Description    :
        FortiGate SSL VPN plugin for plasma-nm components.
    
    # zypper search plasma-nm5
    Loading repository data...
    Reading installed packages...
    
    S  | Name                   | Summary                                                       | Type
    ---+------------------------+---------------------------------------------------------------+--------
    i+ | plasma-nm5             | Plasma applet written in QML for managing network connections | package
    i+ | plasma-nm5-fortisslvpn | FortiGate SSL VPN support for plasma-nm5                      | package
    i+ | plasma-nm5-iodine      | VPN support for plasma-nm5                                    | package
    i+ | plasma-nm5-l2tp        | L2TP support for plasma-nm5                                   | package
    i+ | plasma-nm5-lang        | Translations for package plasma-nm5                           | package
    i+ | plasma-nm5-openconnect | OpenConnect support for plasma-nm5                            | package
       | plasma-nm5-openswan    | Openswan support for plasma-nm5                               | package
    i+ | plasma-nm5-openvpn     | OpenVPN support for plasma-nm5                                | package
    i+ | plasma-nm5-pptp        | PPTP support for plasma-nm5                                   | package
    i+ | plasma-nm5-ssh         | SSH support for plasma-nm5                                    | package
       | plasma-nm5-sstp        | SSTP support for plasma-nm5                                   | package
       | plasma-nm5-strongswan  | strongSwan support for plasma-nm5                             | package
    i+ | plasma-nm5-vpnc        | vpnc support for plasma-nm5                                   | package
    
    In fact i am able to connect to fortigate vpn from cli just fine with openfortivpn.

    Code:
    # openfortivpn -c /etc/openfortivpn/config
    INFO:   Connected to gateway.
    INFO:   Authenticated.
    INFO:   Remote gateway has allocated a VPN.
    INFO:   Got addresses: [10.212.14.52], ns [10.212.10.10, 10.212.10.11]
    INFO:   negotiation complete
    INFO:   negotiation complete
    INFO:   Interface ppp0 is UP.
    INFO:   Setting new routes...
    INFO:   Adding VPN nameservers...
    INFO:   Tunnel is up and running.
    ^CINFO:   Cancelling threads...
    INFO:   Setting ppp interface down.
    INFO:   Restoring routes...
    INFO:   Removing VPN nameservers...
    INFO:   pppd: The link was terminated by the modem hanging up.
    INFO:   Terminated pppd.
    INFO:   Closed connection to gateway.
    INFO:   Logged out.
    
    Any help is much appreciated!

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,935
    Blog Entries
    2

    Default Re: NetworkManager with fortisslvpn unable to connect.

    Have you installed your openvpn packages?

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Sep 2012
    Posts
    4,976

    Default Re: NetworkManager with fortisslvpn unable to connect.

    Quote Originally Posted by lllevonnn View Post
    For sure fortisslvpn is installed.
    You need NetworkManager-fortisslvpn plugin (https://github.com/GNOME/NetworkManager-fortisslvpn), but it is apparently not built for Leap. You may try contact maintainers asking to enable build for Leap (https://build.opensuse.org/package/s...er-fortisslvpn). You may also ask on opensuse-factory list. Package is part of TW so there are some chances it may be included in next Leap release.

    Finally you can build it yourself.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •