Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: 15.1 update error - /lib64/libacl.so.1: symbol getxattr

  1. #1

    Default 15.1 update error - /lib64/libacl.so.1: symbol getxattr

    Hi
    I am updating via YAST and get the following error :

    Subprocess failed. Error: RPM failed: rpm: relocation error: /lib64/libacl.so.1: symbol getxattr, version ATTR_1.0 not defined in file libattr.so.1 with link time reference

    Any suggestions on how to resolve
    Thanks

  2. #2

    Default Re: 15.1 update error - /lib64/libacl.so.1: symbol getxattr

    Looks as if something is borked, I have opened a x-terminal to look at journalctl and getting the same error message

  3. #3
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,882

    Default AW: 15.1 update error - /lib64/libacl.so.1: symbol getxattr

    Post:
    Code:
    zypper lr -d

  4. #4

    Default Re: 15.1 update error - /lib64/libacl.so.1: symbol getxattr

    Hi
    I am unable to post the output, normal boot does not boot up.
    I have been able to boot up with one of the read-only snapshots, but I am away during the week and will only be able to pick up on the weekend.
    Thanks

  5. #5

    Default Re: 15.1 update error - /lib64/libacl.so.1: symbol getxattr

    Same trouble.

    Code:
    sudo zypper lr -d
    also return
    Code:
    zypper: relocation error: /lib64/libacl.so.1: symbol getxattr, version ATTR_1.0 not defined in file libattr.so.1 with link time reference

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,882

    Default AW: 15.1 update error - /lib64/libacl.so.1: symbol getxattr

    Post as root executed:
    Code:
    rpm -q --whatprovides /lib64/libacl.so.1

  7. #7

    Default Re: 15.1 update error - /lib64/libacl.so.1: symbol getxattr

    I've got the same problem, the OS is completely broken and doesn't boot (kernel panic while encrypted volume mount - "Unexpected reschedule of offline CPU#0").
    Managed to chroot the partition from the LiveCD.
    Code:
    # rpm -q --whatprovides /lib64/libacl.so.1
    rpm: relocation error: /lib64/libacl.so.1: symbol getxattr, version ATTR_1.0 not defined in file libattr.so.1 with link time reference

  8. #8
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,882

    Default AW: 15.1 update error - /lib64/libacl.so.1: symbol getxattr

    Revert it from a snapshot.

  9. #9

    Default Re: AW: 15.1 update error - /lib64/libacl.so.1: symbol getxattr

    Quote Originally Posted by Sauerland View Post
    Revert it from a snapshot.
    Is there another way to solve the problem? It is strange that you have to go to such measures simply because of the update.

  10. #10
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,646

    Default Re: 15.1 update error - /lib64/libacl.so.1: symbol getxattr

    Well reverting is what you do for a broken update, unless you know exactly what is broken and can force update that package

    .

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •