Results 1 to 5 of 5

Thread: boot during long time

  1. #1
    Join Date
    Apr 2015
    Location
    The Earth
    Posts
    498

    Default boot during long time

    HiFor me long time, boot timesystemd-analyze
    Code:
    Startup finished in 17.763s (firmware) + 3.768s (loader) + 6.707s (kernel) + 16.503s (initrd) + 2min 7.064s (userspace) = 2min 51.806s graphical.target reached after 2min 7.054s in userspace
    systemd-analyze blame
    Code:
    systemd-analyze  blame    1min 43.454s mlocate.service    1min 30.057s nmb.service         26.777s mandb.service         14.702s firewalld.service         13.898s lvm2-monitor.service         13.328s dracut-initqueue.service         12.626s apparmor.service         11.762s systemd-cryptsetup@cr_ata\x2dST1000LM024_HN\x2dM101MBB_S31LJ9EDC04>          9.282s upower.service          8.095s ModemManager.service          6.832s btrfsmaintenance-refresh.service          5.922s udisks2.service          5.237s initrd-switch-root.service          5.073s systemd-rfkill.service          4.669s nscd.service          4.657s avahi-daemon.service          4.616s kbdsettings.service          4.586s logrotate.service          4.570s sound-extra.service          4.570s display-manager.service          4.447s postfix.service          3.736s plymouth-quit-wait.service          3.612s systemd-udevd.service          3.489s lvm2-pvscan@254:0.service          3.140s systemd-journal-flush.service          2.530s wpa_supplicant.service
    how to disable "mlocate.service"?how to optimizer "nmb.service"?how to optimizer time boot and disable unnecessary services?Thanks
    Dual-boot openSUSE and win10
    OpenSUSE Tumbleweed ; Plasma 5.15.x:" LVM encrypted"
    My Partition: GPT and UEFI system
    Hp ProBook 450 G1

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,347
    Blog Entries
    3

    Default Re: boot during long time

    Quote Originally Posted by 123thinksuse View Post
    how to disable "mlocate.service"?how to optimizer "nmb.service"?how to optimizer time boot and disable unnecessary services?Thanks
    I doubt that those services are a particular problem.

    You can use the services manager (from Yast) to disable services (or set them to manual start instead of automatic start). But use caution -- try to avoid disabling essential services.
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3
    Join Date
    Apr 2015
    Location
    The Earth
    Posts
    498

    Default Re: boot during long time

    Quote Originally Posted by nrickert View Post
    I doubt that those services are a particular problem.

    You can use the services manager (from Yast) to disable services (or set them to manual start instead of automatic start). But use caution -- try to avoid disabling essential services.
    Thank you
    can i disable nbm service?
    If I disable the nmb service, Having trouble when booting?
    Dual-boot openSUSE and win10
    OpenSUSE Tumbleweed ; Plasma 5.15.x:" LVM encrypted"
    My Partition: GPT and UEFI system
    Hp ProBook 450 G1

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,853

    Default Re: boot during long time

    I see it is Samba related. So if you use Samba............
    Henk van Velden

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,347
    Blog Entries
    3

    Default Re: boot during long time

    Quote Originally Posted by 123thinksuse View Post
    If I disable the nmb service, Having trouble when booting?
    I don't think that would affect booting -- unless you are automatically mounting a samba share.
    openSUSE Leap 15.1; KDE Plasma 5;

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •