Results 1 to 8 of 8

Thread: Qgis from Application:Geo repo not working

  1. #1

    Default Qgis from Application:Geo repo not working

    Hi,

    I am trying to install Qgis on OPenSUSE 15.0.

    I use the repo Application:Geo (https://download.opensuse.org/reposi...USE_Leap_15.0/)

    After adding the repo i have an error when i try to install it :

    Adding the repo (works well):
    zypper ar https://download.opensuse.org/reposi...SUSE_Leap_15.0 Application:Geo

    zypper --gpg-auto-import-keys refresh

    Installation :
    zypper in qgis

    Code:
    Loading repository data...
    
    Reading installed packages...
    Resolving package dependencies...
    
    
    
    Problem: nothing provides libm.so.6(GLIBC_2.29)(64bit) needed by qgis-3.8.0-5.6.x86_64
     Solution 1: do not install qgis-3.8.0-5.6.x86_64
    
     Solution 2: break qgis-3.8.0-5.6.x86_64 by ignoring some of its dependencies
    
    
    
    Choose from above solutions by number or cancel [1/2/c] (c):

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,669
    Blog Entries
    15

    Default Re: Qgis from Application:Geo repo not working

    Quote Originally Posted by jfarcy View Post
    Hi,

    I am trying to install Qgis on OPenSUSE 15.0.

    I use the repo Application:Geo (https://download.opensuse.org/reposi...USE_Leap_15.0/)

    After adding the repo i have an error when i try to install it :

    Adding the repo (works well):
    zypper ar https://download.opensuse.org/reposi...SUSE_Leap_15.0 Application:Geo

    zypper --gpg-auto-import-keys refresh

    Installation :
    zypper in qgis

    Code:
    Loading repository data...
    
    Reading installed packages...
    Resolving package dependencies...
    
    
    
    Problem: nothing provides libm.so.6(GLIBC_2.29)(64bit) needed by qgis-3.8.0-5.6.x86_64
     Solution 1: do not install qgis-3.8.0-5.6.x86_64
    
     Solution 2: break qgis-3.8.0-5.6.x86_64 by ignoring some of its dependencies
    
    
    
    Choose from above solutions by number or cancel [1/2/c] (c):
    Hi
    Likely you have other non standard repositories active (I suspect you have Tumbleweed repositories active, not a good idea) and have pulled in a later version of glibc at some point?

    The version from the Geo repository was built with libm.so.6(GLIBC_2.2.5)(64bit) 2.29 is Tumbleweed.

    Can you show the output from;

    Code:
    zypper lr -d
    zypper se -si glibc
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Qgis from Application:Geo repo not working

    Code:
    zypper lr -d
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    #  | Alias                                | Name                                         | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                         | Service
    ---+--------------------------------------+----------------------------------------------+---------+-----------+---------+----------+--------+---------------------------------------------------------------------------------------------+--------
     1 | Application:Geo                      | Application:Geo                              | Yes     | (r ) Yes  | No      |   99     | rpm-md | https://download.opensuse.org/reposi...SUSE_Leap_15.0              |
     2 | R-base                               | R-base                                       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...USE_Leap_15.0/ |
     3 | Vlc                                  | Vlc                                          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.videolan.org/pub/vlc/SuSE/Leap_15.0/                                        |
     4 | devel:languages:perl                 | devel:languages:perl                         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...USE_Leap_15.0/        |
     5 | flash                                | flash                                        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...USE_Leap_15.0/                  |
     6 | https-download.opensuse.org-74d84c65 | Non OSS Updates                              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/update/leap/15.0/non-oss/                                     |
     7 | https-download.opensuse.org-9c37690f | OSS Updates                                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/update/leap/15.0/oss/                                         |
     8 | non-oss-addon-15.0-0                 | Depot officiel logiciels non libre (Non-OSS) | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/distri.../repo/non-oss/                          |
     9 | openSUSE-Leap-15.0-1                 | openSUSE-Leap-15.0-1                         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://148.60.128.26/15.0/inst-source                                                       |
    10 | openSUSE-Leap-15.0-1_0               | Depot officiel principal (OSS)               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/distri...15.0/repo/oss/                              |
    11 | science                              | science

  4. #4

    Default Re: Qgis from Application:Geo repo not working

    Code:
    zypper se -si glibc
    Loading repository data...
    Reading installed packages...
    
    S  | Name              | Type    | Version            | Arch   | Repository
    ---+-------------------+---------+--------------------+--------+-------------------------------
    i+ | glibc             | package | 2.26-lp150.11.17.1 | x86_64 | OSS Updates
    i  | glibc-32bit       | package | 2.26-lp150.11.17.1 | x86_64 | OSS Updates
    i  | glibc-devel       | package | 2.26-lp150.11.17.1 | x86_64 | OSS Updates
    i  | glibc-devel-32bit | package | 2.26-lp150.11.17.1 | x86_64 | OSS Updates
    i  | glibc-extra       | package | 2.26-lp150.11.17.1 | x86_64 | OSS Updates
    i  | glibc-info        | package | 2.26-lp150.11.17.1 | noarch | OSS Updates
    i  | glibc-locale      | package | 2.26-lp150.11.17.1 | x86_64 | OSS Updates
    i  | glibc-locale-base | package | 2.26-lp150.11.17.1 | x86_64 | OSS Updates
    i  | linux-glibc-devel | package | 4.15-lp150.1.23    | noarch | Depot officiel principal (OSS)

  5. #5

    Talking Re: Qgis from Application:Geo repo not working

    I did a fresh install before these last command.

    and zypper in qgis worked but ....



    Code:
    Terminate called after throwing an instance of 'H5:ataSpaceIException'
    Abandon (core dumped)

  6. #6

    Default Re: Qgis from Application:Geo repo not working

    I guess the hdf5 library is making trouble ...

    For information :
    Code:
    zypper se -si hdf5
    Loading repository data...
    Reading installed packages...
    
    S  | Name                         | Type    | Version            | Arch   | Repository
    ---+------------------------------+---------+--------------------+--------+-------------------------------
    i  | hdf5                         | package | 1.10.4-lp150.134.1 | x86_64 | science
    i+ | hdf5-devel                   | package | 1.10.4-lp150.134.1 | x86_64 | science
    i  | hdf5-devel-data              | package | 1.10.4-lp150.134.1 | x86_64 | science
    i  | hdf5-openmpi                 | package | 1.10.4-lp150.134.1 | x86_64 | science
    i+ | hdf5-openmpi-devel           | package | 1.10.4-lp150.134.1 | x86_64 | science
    i+ | libhdf5-101                  | package | 1.10.1-lp150.6.4   | x86_64 | openSUSE-Leap-15.0-1
    i+ | libhdf5-101                  | package | 1.10.1-lp150.6.4   | x86_64 | Depot officiel principal (OSS)
    i+ | libhdf5-101-openmpi          | package | 1.10.1-lp150.6.5   | x86_64 | Depot officiel principal (OSS)
    i  | libhdf5-103                  | package | 1.10.4-lp150.134.1 | x86_64 | science
    i  | libhdf5-103-openmpi          | package | 1.10.4-lp150.134.1 | x86_64 | science
    i  | libhdf5_cpp101               | package | 1.10.1-lp150.6.4   | x86_64 | Depot officiel principal (OSS)
    i  | libhdf5_cpp103               | package | 1.10.4-lp150.134.1 | x86_64 | science
    i  | libhdf5_cpp103-openmpi       | package | 1.10.4-lp150.134.1 | x86_64 | science
    i  | libhdf5_fortran100           | package | 1.10.4-lp150.134.1 | x86_64 | science
    i  | libhdf5_fortran100-openmpi   | package | 1.10.4-lp150.134.1 | x86_64 | science
    i  | libhdf5_hl100                | package | 1.10.4-lp150.134.1 | x86_64 | science
    i+ | libhdf5_hl100-openmpi        | package | 1.10.4-lp150.134.1 | x86_64 | science
    i  | libhdf5_hl_cpp100            | package | 1.10.4-lp150.134.1 | x86_64 | science
    i  | libhdf5_hl_cpp100-openmpi    | package | 1.10.4-lp150.134.1 | x86_64 | science
    i  | libhdf5hl_fortran100         | package | 1.10.4-lp150.134.1 | x86_64 | science
    i  | libhdf5hl_fortran100-openmpi | package | 1.10.4-lp150.134.1 | x86_64 | science

  7. #7

    Default Re: Qgis from Application:Geo repo not working

    I also opened an issue int the github of Qgis :
    https://github.com/qgis/QGIS/issues/30821

  8. #8
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,133
    Blog Entries
    2

    Default Re: Qgis from Application:Geo repo not working

    Quote Originally Posted by jfarcy View Post
    I did a fresh install before these last command.

    and zypper in qgis worked but ....



    Code:
    Terminate called after throwing an instance of 'H5:ataSpaceIException'
    Abandon (core dumped)
    First, an Internet search on ataSpaceIException turned up nothing but some hits when the "i" was replaced with a space...

    I'd expect this kind of error wouldn't be thrown until you actually tried to read some data...
    You might try another dataset on the chance the one that threw the exception might be corrupted.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •