Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: DNScrypt-proxy service not found

  1. #1

    Question DNScrypt-proxy service not found

    ok so i have read many guides on setting up dnscrypt-proxy in linux its very easy and straightforward. So to my understanding i download and install dnscrypt-proxy which i have done via yaST install package center that went fine and i added Add 127.0.0.1 as my dns servers in the network settings. BUT when i reboot i noticed i cant find the service in the list of services to start in yaST>system>service manager. and when i try to start the service i get this

    Code:
     sudo systemctl start dnscrypt-proxy
    [sudo] password for root: 
    Failed to start dnscrypt-proxy.service: Unit dnscrypt-proxy.service not found
    so why isent the service in yaST and how can i fix this thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,666
    Blog Entries
    14

    Default Re: DNScrypt-proxy service not found

    You may have to 'enable' it first.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: DNScrypt-proxy service not found

    how do i "enable" it just wondering thanks.

  4. #4

    Default Re: DNScrypt-proxy service not found

    i tried

    Code:
    sudo systemctl enable dnscrypt-proxy
    [sudo] password for root: 
    Failed to enable unit: Unit file dnscrypt-proxy.service does not exist.

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,895

    Default AW: DNScrypt-proxy service not found

    Code:
    rpm -ql dnscrypt-proxy | grep systemd
    /usr/lib/systemd/system/dnscrypt-proxy@.service
    So enable:
    Code:
    systemctl enable dnscrypt-proxy@.service
    start:
    Code:
    systemctl start dnscrypt-proxy@default.service
    Status:
    Code:
    systemctl status dnscrypt-proxy@default.service
    Last edited by Sauerland; 16-Jul-2019 at 12:05.

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,954
    Blog Entries
    2

    Default Re: DNScrypt-proxy service not found

    Just took a look at it.
    Looks like the package doesn't complete the installation, it only installs the components and a template Unit file, but doesn't set up so it works.

    Assuming you installed the RPM from the openSUSE repos, first verify that "127.0.0.1" is the first listed address in the following
    Code:
    cat /etc/resolv.conf
    With the above, your system is set to look for a locally running DNS proxy before looking elsewhere.
    Now, let's make that dnscrypt-proxy Unit file work...
    Change the template file to a working Unit file with the following command
    Code:
    mv /usr/lib/systemd/system/dnscrypt-proxy@.service /usr/lib/systemd/system/dnscrypt-proxy.service
    Now, you can immediately manage the dnscrypt-proxy.service like any other systemd service...
    Start it, enable it and you should be working fine.

    If the default dnscrypt configuration doesn't suit you (It should do a round robin between found resolvers), modify
    Code:
    /etc/dnscrypt-proxy.conf.d/default.conf
    You can read available documentation on how to modify the configuration file either with the documentation included in the package or online... You have the list of available and supported resolvers in a file and from that can pick and choose if you wish which ones to use and which encrypted protocol you wish to use.

    Don't forget to submit a bug at https://bugzilla.opensuse.org about what you have to do to complete your installation.

    HTH,
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  7. #7
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,954
    Blog Entries
    2

    Default Re: AW: DNScrypt-proxy service not found

    Quote Originally Posted by Sauerland View Post
    Code:
    rpm -ql dnscrypt-proxy | grep systemd
    /usr/lib/systemd/system/dnscrypt-proxy@.service
    So enable:
    Code:
    systemctl enable dnscrypt-proxy@.service
    start:
    Code:
    systemctl start dnscrypt-proxy@default.service
    Status:
    Code:
    systemctl status dnscrypt-proxy@default.service
    That ampersand in the Unit file name will prevent it from being used, remove it to make the Unit file functional.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  8. #8
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,954
    Blog Entries
    2

    Default Re: DNScrypt-proxy service not found

    Additional,
    But mainly to (not) tidy up loose ends...

    Supposedly that ampersand at the end of the Unif file name (but before and not part of the appended Unit file type)
    is supposed to make the systemd service "parametized."
    But, I cannot think of how any kind of "parameterizedon" can be useful, or how it would be used.
    From what I understand about how dnscript-proxy works, it's a standalone proxy that is not called by anything else or calls anything else.

    If someone has any idea why the ampersand should be left, I'd be open to being enlightened.
    I took a few extra minutes skimming installation and configuration documentation looking specifically for possible related info, but didn't find anything.

    So, removing the ampersand as I described is likely necessary and makes things work.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,895

    Default AW: DNScrypt-proxy service not found

    You have seen, that after enable there is a @default.service.......

    And here service was started, but I have not edited the .conf.....

    mv /usr/lib/systemd/system/dnscrypt-proxy@.service /usr/lib/systemd/system/dnscrypt-proxy.service
    Own service-files belongs to /etc/systemd.......
    Last edited by Sauerland; 16-Jul-2019 at 12:52.

  10. #10

    Default Re: AW: DNScrypt-proxy service not found

    Quote Originally Posted by Sauerland View Post
    Code:
    rpm -ql dnscrypt-proxy | grep systemd
    /usr/lib/systemd/system/dnscrypt-proxy@.service
    So enable:
    Code:
    systemctl enable dnscrypt-proxy@.service
    start:
    Code:
    systemctl start dnscrypt-proxy@default.service
    Status:
    Code:
    systemctl status dnscrypt-proxy@default.service
    thank you this worked great the service is started and now shows up in yast and all i did was reboot thank you very much

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •