Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: snd_hda_intel alsa have to modprobe remove install each restart. Why?

  1. #11
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    911

    Default Re: snd_hda_intel alsa have to modprobe remove install each restart. Why?

    Quote Originally Posted by motiv8d View Post
    That is my point karlmistelberger.
    I DON'T WANT to be using yast for sound. Yast has caused too many problems with sound for me.
    So I would like to determine the processes required for sound set up and control on OpenSuse without Yast.

    If I was going to use Yast, thus I would like to know how to blacklist by PCI etc rather than module, because of course blacklisting by module is going to stop all sound.
    Yes I read that you don't want to use YaST. However I suggest that you use YaST for the single purpose of testing your hypothesis:

    Yast seems to have been confused by multiple cards that use the same snd_hda_intel module.
    Use YaST to turn off all but one sound card and tel the result.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  2. #12

    Default Re: snd_hda_intel alsa have to modprobe remove install each restart. Why?

    Quote Originally Posted by karlmistelberger View Post
    Yes I read that you don't want to use YaST. However I suggest that you use YaST for the single purpose of testing your hypothesis:

    Use YaST to turn off all but one sound card and tel the result.
    The Radeon is already "off" in the sense it has not been configured.
    It is Yast that seems to get it confused.
    I currently have sound working.
    It breaks periodically when Yast becomes involved, but I cannot isolate exactly why yast breaks it and how.
    The inclusion of snd_hda_intel in yast.conf file by yast seems certainly to be a likely part of it though as per comments above.
    Your test suggestion serves no purpose I can see as the 2nd card is detected but not configured.

  3. #13
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    911

    Default Re: snd_hda_intel alsa have to modprobe remove install each restart. Why?

    Quote Originally Posted by motiv8d View Post
    The Radeon is already "off" in the sense it has not been configured.
    It is Yast that seems to get it confused.
    I currently have sound working.
    It breaks periodically when Yast becomes involved, but I cannot isolate exactly why yast breaks it and how.
    The inclusion of snd_hda_intel in yast.conf file by yast seems certainly to be a likely part of it though as per comments above.
    Your test suggestion serves no purpose I can see as the 2nd card is detected but not configured.
    I simply doubt the claims made above.

    Try the following (it works perfectly on my machine):

    Code:
    erlangen:~ # cat /etc/modprobe.d/50-sound.conf
    options snd slots=snd-hda-intel
    alias snd-card-0 snd-hda-intel
    erlangen:~ #
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  4. #14

    Default Re: snd_hda_intel alsa have to modprobe remove install each restart. Why?

    Quote Originally Posted by karlmistelberger View Post
    I simply doubt the claims made above.

    Try the following (it works perfectly on my machine):

    Code:
    erlangen:~ # cat /etc/modprobe.d/50-sound.conf
    options snd slots=snd-hda-intel
    alias snd-card-0 snd-hda-intel
    erlangen:~ #
    I have already provided the file /etc/modprobe.d/50-sound.conf in the thread above.
    What SPECIFIC claims made above do you "doubt"?

  5. #15
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    911

    Default Re: snd_hda_intel alsa have to modprobe remove install each restart. Why?

    Quote Originally Posted by motiv8d View Post
    I have already provided the file /etc/modprobe.d/50-sound.conf in the thread above.
    What SPECIFIC claims made above do you "doubt"?
    Sure, but your version of /etc/modprobe.d/50-sound.conf diifers.

    I doubt the claims regarding YaST. One of my machines easily deals with two sound cards. I managed them with YaST.

    What is yours?

    Code:
    erlangen:~ # journalctl -b -o short-monotonic |grep snd
    [    3.717640] erlangen kernel: snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
    [    3.717813] erlangen kernel: snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
    [    3.742517] erlangen kernel: snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC892: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:line
    [    3.742519] erlangen kernel: snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
    [    3.742520] erlangen kernel: snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
    [    3.742521] erlangen kernel: snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
    [    3.742522] erlangen kernel: snd_hda_codec_realtek hdaudioC0D0:    inputs:
    [    3.742523] erlangen kernel: snd_hda_codec_realtek hdaudioC0D0:      Front Mic=0x19
    [    3.742524] erlangen kernel: snd_hda_codec_realtek hdaudioC0D0:      Rear Mic=0x18
    [    3.742525] erlangen kernel: snd_hda_codec_realtek hdaudioC0D0:      Line=0x1a
    erlangen:~ #
    Code:
    erlangen:~ # lsmod|grep snd
    snd_hda_codec_hdmi     65536  1
    snd_hda_codec_realtek   126976  1
    snd_hda_codec_generic    90112  1 snd_hda_codec_realtek
    ledtrig_audio          16384  2 snd_hda_codec_generic,snd_hda_codec_realtek
    snd_hda_intel          53248  7
    snd_hda_codec         151552  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
    snd_hda_core          102400  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
    snd_hwdep              16384  1 snd_hda_codec
    snd_pcm               143360  5 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
    snd_timer              40960  1 snd_pcm
    snd                   102400  21 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm
    soundcore              16384  1 snd
    erlangen:~ #
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  6. #16
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,527
    Blog Entries
    37

    Default Re: snd_hda_intel alsa have to modprobe remove install each restart. Why?

    Quote Originally Posted by motiv8d View Post
    Yast seems to have been confused by multiple cards that use the same snd_hda_intel module.
    I have not kept up to date on this, but I do recall in earlier openSUSE versions (pre-LEAP) that YaST did not handle 2 sound cards well if BOTH used the snd_hda_intel sound module.

    But if that is all one's issue is, then that was easy to fix with an appropriately edited /etc/modprobe.d/50-sound.conf file. I suspect the same may be true with LEAP.

    Take a look at post#9 here: https://forums.opensuse.org/showthre...he-same-module

    or take a look at post#7 here: https://forums.opensuse.org/showthre...he-same-module

    I suspect thou, your issue could be more than just having multiple sound devices that use the snd_hda_intel sound.

    But if reading the above two links does not sufficiently explain to you how to create a file (outside of yast) to ensure sound devices appropriately assigned, then post here, and I can walk you though this. Its 4.5+ years since I last helped someone do this, but I am confident I can do so again.
    .

  7. #17

    Default Re: snd_hda_intel alsa have to modprobe remove install each restart. Why?

    Quote Originally Posted by oldcpu View Post
    I have not kept up to date on this, but I do recall in earlier openSUSE versions (pre-LEAP) that YaST did not handle 2 sound cards well if BOTH used the snd_hda_intel sound module.

    But if that is all one's issue is, then that was easy to fix with an appropriately edited /etc/modprobe.d/50-sound.conf file. I suspect the same may be true with LEAP.

    Take a look at post#9 here: https://forums.opensuse.org/showthre...he-same-module

    or take a look at post#7 here: https://forums.opensuse.org/showthre...he-same-module

    I suspect thou, your issue could be more than just having multiple sound devices that use the snd_hda_intel sound.

    But if reading the above two links does not sufficiently explain to you how to create a file (outside of yast) to ensure sound devices appropriately assigned, then post here, and I can walk you though this. Its 4.5+ years since I last helped someone do this, but I am confident I can do so again.
    .
    Thanks for confirming it a problem, and your earlier advice which helped resolve the restart problem. It is working subsequent to removing snd_hda_intel from yast.conf file as you directed in the link you provided earlier, and subsequent to new kernel / initrd.
    When yast created the yast.conf file, the 50-sound.conf file was correct, and still is.

    But overall, affter negative experiences with Yast sound with this setup and a previous setup which used an Xonar DG card, my preference is to do sound without yast.

  8. #18
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,527
    Blog Entries
    37

    Default Re: snd_hda_intel alsa have to modprobe remove install each restart. Why?

    Quote Originally Posted by motiv8d View Post
    When yast created the yast.conf file, the 50-sound.conf file was correct, and still is.
    Indeed back in the year 2012 (?) timeframe, when I had a PC with two devices that used snd_hda_intel module, sometimes when I rebooted the PC, the device that was sound card-0 would switch to be sound card-1 and the device that was sound card-1 would switch to be sound-card-0. Now I had no speakers connected to one of these two devices so on occasion I would lose sound.

    This would mean that an application that was setup with a saved configuration to send sound to sound card-0, would suddenly stop working ... until I went to YaST to restart the sound.

    The solution was to manually modify the 50-sound.conf file created by YaST, specifying the 'vid' and 'pid'. After the modification, the sound cards never swapped upon a reboot. I used that knowledge to help others.

    Note that once one custom edits the 50-sound.conf file with a text editor, one should NOT go to YaST sound as YaST will over write that file with its own settings, and one will lose their custom "vid" and "pid" settings.

    Have you tried setting the "vid" and "pid" in your 50-sound.conf file? or do you believe that is not necessary for the problem with sound that you still have (?).

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •