Results 1 to 6 of 6

Thread: first start stop on loading initial mamdisk ...

  1. #1

    Default first start stop on loading initial mamdisk ...

    suse is instaled on ssd side to windows 10.

    any idea?

    laptop akoya i3 8g ram

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,002

    Default Re: first start stop on loading initial mamdisk ...

    Hello and welcome here.

    I assume you mean that on boot, you choose openSUSE from the Grub screen and that then the system halts after the text "loading initial ramdisk" is displayed?
    Henk van Velden

  3. #3

    Default Re: first start stop on loading initial mamdisk ...

    Quote Originally Posted by hcvv View Post
    Hello and welcome here.

    I assume you mean that on boot, you choose openSUSE from the Grub screen and that then the system halts after the text "loading initial ramdisk" is displayed?
    yes that is the peblem.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,497
    Blog Entries
    3

    Default Re: first start stop on loading initial mamdisk ...

    On the grub screen, hit the 'e' key. That should allow you to edit the grub menu.

    Scroll down until you find a line that begins "linux" (or maybe "linuxefi").

    Scroll to the right until you reach "splash=silent".
    Delete that string (delete "splash=silent").
    Use CTRL-X to continue booting.

    Watch the screen closely. See if there are any relevant messages that show up, and might be hints as what is going wrong.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5
    Join Date
    Mar 2019
    Location
    mtl.qc.ca
    Posts
    127

    Default Loading Initial Ramdisk Stalls

    Our laptop stops at the same place or we get a black screen in Ubuntu's or the same with a wrong tweak. We must add a kernel parameter at boot time to proceed with the fresh install. The one we use and there are many may not fit the need of your Intel motherboard: iommu=soft

    It would be nice to give the exact model of your laptop to see if other users have reported the issue you have. Did not find anything relevant with Akoya i3.


    This is the linuxefi line discuss in the previous post by @nickert in UEFI mode:

    Code:
    menuentry 'Installation' --class opensuse --class gnu-linux --class gnu --class os {
      set gfxpayload=keep
      echo 'Loading kernel ...'
      linuxefi /boot/x86_64/loader/linux splash=silent iommu=soft
      echo 'Loading initial ramdisk ...'
      initrdefi /boot/x86_64/loader/initrd
    CTRL+X To Save & Exit. This is how we boot into Linux ISO's.

    Final result:

    Code:
    cat /proc/cmdline
    BOOT_IMAGE=/boot/vmlinuz-5.2.1-2.gbf5c01b-default root=UUID=2dd7fb7c-6e8f-40c4-ba4a-af9f842dc1f8 splash=silent iommu=soft resume=/dev/disk/by-id/ata-SanDisk_SDSSDH3256G_183756420226-part6 quiet mitigations=off
    Removing splash=silent should give a clue about the issue you have.
    Ryzen 2700U FHD Lenovo ThinkPad E585

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,703

    Default Re: first start stop on loading initial mamdisk ...

    iommu settings may be available in some BIOS/UEFI . Was in mine. I needed to get USB keyboard/mouse to work. Set to software not hardware

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •