@Trmpt8va:

Yet another thought: please check “rfkill” …
Code:
 # rfkill 
ID TYPE      DEVICE                 SOFT      HARD
 0 wlan      ideapad_wlan      unblocked unblocked
 1 bluetooth ideapad_bluetooth unblocked unblocked
 2 wlan      phy0              unblocked unblocked
 3 bluetooth hci0                blocked unblocked
 # systemctl list-unit-files | grep -i 'kill'
systemd-rfkill.service                                                 static   
systemd-rfkill.socket                                                  static   
 # systemctl status systemd-rfkill.service  systemd-rfkill.socket
● systemd-rfkill.service - Load/Save RF Kill Switch Status
   Loaded: loaded (/usr/lib/systemd/system/systemd-rfkill.service; static; vendor preset: disabled)
   Active: inactive (dead) since Sat 2019-07-20 17:06:53 CEST; 19min ago
     Docs: man:systemd-rfkill.service(8)
  Process: 1815 ExecStart=/usr/lib/systemd/systemd-rfkill (code=exited, status=0/SUCCESS)
 Main PID: 1815 (code=exited, status=0/SUCCESS)

Jul 20 17:06:48 eck005 systemd[1]: Starting Load/Save RF Kill Switch Status...
Jul 20 17:06:48 eck005 systemd[1]: Started Load/Save RF Kill Switch Status.

● systemd-rfkill.socket - Load/Save RF Kill Switch Status /dev/rfkill Watch
   Loaded: loaded (/usr/lib/systemd/system/systemd-rfkill.socket; static; vendor preset: disabled)
   Active: active (listening) since Sat 2019-07-20 17:06:37 CEST; 19min ago
     Docs: man:systemd-rfkill.socket(8)
   Listen: /dev/rfkill (Special)

Jul 20 17:06:37 eck005 systemd[1]: Listening on Load/Save RF Kill Switch Status /dev/rfkill Watch.
 #
You may have to use “rfkill unblock wlan” to get your WLAN/WiFi device up and running …