Results 1 to 4 of 4

Thread: Slow Response / Connection Time-Out

  1. #1

    Default Slow Response / Connection Time-Out

    Hi,

    I'm running a LAMP server along with FTP and Samba on OpenSuse 13.2. Servers been running for over a year now with no issues. It's sole purpose is for business use, with the Samba server being absolutely critical to our everyday business function. The samba shared drives are only accessible locally via LAN.

    We've recently replaced our BT home hub 5 with a BT smart hub 6.

    Ever since the change, the server has been dropping connections / timing out / slow initial response etc. For example:

    1. When first accessing a samba shared drive it takes 6-7 seconds to show folder contents or connect. Once in, its as fast as lightening. But if left idle for more than 1-2 minutes the 6-7 second response time will re-appear.

    2. Logging in via an SSH terminal (locally) is again slow. Once logged in, commands are sent and received instantly. But again, if left dormant for 1-2 minutes, the connection times out and I have to reconnect.

    No settings have changed on the router. The server has a static public IP and port forwarding is enabled for some of it's applications.

    I can ping the server instantly from any windows machine within the LAN. The FTP side doesn't seem to be effected.

    In honesty, I'm not really to sure where to start in terms of troubleshooting this. The server doesn't have a GUI, just the command prompt, in which I know basic commands. Is anyone able to offer some advice on where to start in terms of troubleshooting this?

    Many thanks,
    Jim

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,650
    Blog Entries
    14

    Default Re: Slow Response / Connection Time-Out

    Hi, welcome to these forums

    To start with: openSUSE ( that's how it's writen :-) ) 13.2 has been past it's end-of-life for years now. Result can very well be that it's kernel-version, samba-version are too outdated to communicate with the newer smart hub. My advice would be to upgrade the server to Leap 15.1 to make sure you're not fighting with outdated stuff. From a security perspective keeping a 13.2 server in a business environment would be a no go. Another thing to mention is that it will be harder to find the needed support, since none of us still runs 13.2, so we have no means to properly mimic your situation and test stuff.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Slow Response / Connection Time-Out

    Thanks for the reply Knurpht.

    Wow, I didn't realise just how old OpenSUSE 13.2 is. To be honest, once I had it up and running, its been maintenance free. Previously I said it had been running for roughly a year. That is since it was last turned off. In total, its been running around 4 years. From a business point of view..... Yes I agree, security is an issue along with compatibility with newer formats / languages / protocols etc. We are in the engineering industry, and the servers main job is to act as central business hub for files and information.

    I'm guessing I'll need to thoroughly backup and reformat to install LEAP 15.1? Basically, start a fresh?

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,650

    Default Re: Slow Response / Connection Time-Out

    In theory you can upgrade but 13.1 is relatively old and it is always recommended to upgrade one version at a time, several of which are also now end of life. Since you will need to backup any way and assuming the data lives on it's own partition(s) not on root then you could try a new install and simply mount the partitions that have the data without formatting. Note that the new versions will want to use BTRFS file system for root which should have at least 40 gig available. Since 13.1 only needed about 20 gig root IMO it is best to select ext4 as the file system. A lot of ifs and these things do depend on need and available space etc. Without more info none can provide more detail. So if you need more detail post fdisk -l and we can see what is what and tell us the usage for the partitions and I'm sure someone will provide more detail

    Since this is a server you may want to consider the JeOS (Just Enough OS) install It may be most of what you need. Note it does not include a GUI but that can be added if you need.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •