Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: virt-manager NAT networks inactive on system boot

  1. #11

    Default Re: virt-manager NAT networks inactive on system boot

    Hello Tsu2

    Got it on the quotes, sorry about that.

    And yes my only issue with virt-manager virtual networks is they fail at startup, per my logs attached. Once I restart the service after login, everything works fine.
    But it still fails every time I reboot my desktop and laptop. Do you think I should open a bug in openSUSE bugzilla?

    Thanks
    Mauro

  2. #12
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,927
    Blog Entries
    2

    Default Re: virt-manager NAT networks inactive on system boot

    Quote Originally Posted by ilvipero View Post
    Hello Tsu2

    Got it on the quotes, sorry about that.

    And yes my only issue with virt-manager virtual networks is they fail at startup, per my logs attached. Once I restart the service after login, everything works fine.
    But it still fails every time I reboot my desktop and laptop. Do you think I should open a bug in openSUSE bugzilla?

    Thanks
    Mauro
    No,
    Sounds like you need to disable your auto reboot so that your error can happen,
    Then start the service to see if the error is displayed.

    If the error doesn't display,
    Then you'll have no choice but to inspect your boot log, you can try the following filters

    The following didn't return anything useful for me, but you should try it anyway
    Code:
    journalctl -p err -b
    Should display useful info
    Code:
    journalctl -u libvirtd.service -b
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #13
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,650
    Blog Entries
    14

    Default Re: virt-manager NAT networks inactive on system boot

    Quote Originally Posted by ilvipero View Post
    Hello Tsu2

    Got it on the quotes, sorry about that.

    And yes my only issue with virt-manager virtual networks is they fail at startup, per my logs attached. Once I restart the service after login, everything works fine.
    But it still fails every time I reboot my desktop and laptop. Do you think I should open a bug in openSUSE bugzilla?

    Thanks
    Mauro
    Yes, please do so. Looks like it's NM related, it probably tries to start before NM establishes a connection. That would have to be fixed in the systemd units, AFAIK.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #14
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,927
    Blog Entries
    2

    Default Re: virt-manager NAT networks inactive on system boot

    Quote Originally Posted by Knurpht View Post
    Yes, please do so. Looks like it's NM related, it probably tries to start before NM establishes a connection. That would have to be fixed in the systemd units, AFAIK.
    That's only one possibility, and if that is the cause you would see a timeout error.
    There are other possible causes like what I found which means you have to actually see what the journal says.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  5. #15

    Default Re: virt-manager NAT networks inactive on system boot

    Hello, Thanks for your help and sorry for delayed response, I have been away.

    I did some more testing per your recommendations. Before doing all those tests, I disabled apparmor, to eliminate one extra variable. I also disabled my crontab script that restarts libvirtd.service after 45 seconds @reboot.

    1. Disabled libvirtd.service from auto start on boot. Rebooted the system. Logged in. started libvirtd.service manually. No problem. Virtual networks are available.
    Code:
    ● libvirtd.service - Virtualization daemon
       Loaded: loaded (/usr/lib/systemd/system/libvirtd.service; disabled; vendor preset: disabled)
       Active: active (running) since Sat 2019-07-20 11:11:55 CST; 16s ago
         Docs: man:libvirtd(8)
               https://libvirt.org
     Main PID: 2993 (libvirtd)
        Tasks: 19 (limit: 32768)
       Memory: 81.5M
       CGroup: /system.slice/libvirtd.service
               ├─2993 /usr/sbin/libvirtd --listen
               ├─3091 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf --leasefile-ro --dhcp-script=/usr/lib64/libvirt/libvirt_leaseshelper
               └─3092 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf --leasefile-ro --dhcp-script=/usr/lib64/libvirt/libvirt_leaseshelper
    
    Jul 20 11:11:56 MGDT-ROG dnsmasq[3091]: started, version 2.80 cachesize 2000
    Jul 20 11:11:56 MGDT-ROG dnsmasq[3091]: compile time options: IPv6 GNU-getopt DBus i18n IDN2 DHCP DHCPv6 Lua TFTP conntrack ipset auth DNSSEC loop-detect inotify dumpfile
    Jul 20 11:11:56 MGDT-ROG dnsmasq-dhcp[3091]: DHCP, IP range 192.168.122.2 -- 192.168.122.254, lease time 1h
    Jul 20 11:11:56 MGDT-ROG dnsmasq-dhcp[3091]: DHCP, sockets bound exclusively to interface virbr0
    Jul 20 11:11:56 MGDT-ROG dnsmasq[3091]: reading /etc/resolv.conf
    Jul 20 11:11:56 MGDT-ROG dnsmasq[3091]: using nameserver 192.168.250.5#53
    Jul 20 11:11:56 MGDT-ROG dnsmasq[3091]: using nameserver 168.95.1.1#53
    Jul 20 11:11:56 MGDT-ROG dnsmasq[3091]: read /etc/hosts - 7 addresses
    Jul 20 11:11:56 MGDT-ROG dnsmasq[3091]: read /var/lib/libvirt/dnsmasq/default.addnhosts - 0 addresses
    Jul 20 11:11:56 MGDT-ROG dnsmasq-dhcp[3091]: read /var/lib/libvirt/dnsmasq/default.hostsfile
    2. Re enabled libvirtd.service to start automatically at boot. Rebooted the system. Virtual networks are not enabled. I see errors in libvirtd.service, regarding resolv.conf and dnsmasq

    Code:
    ● libvirtd.service - Virtualization daemon
       Loaded: loaded (/usr/lib/systemd/system/libvirtd.service; enabled; vendor preset: disabled)
       Active: active (running) since Sat 2019-07-20 12:06:55 CST; 7min ago
         Docs: man:libvirtd(8)
               https://libvirt.org
     Main PID: 1852 (libvirtd)
        Tasks: 17 (limit: 32768)
       Memory: 83.5M
       CGroup: /system.slice/libvirtd.service
               └─1852 /usr/sbin/libvirtd --listen
    
    Jul 20 12:06:55 MGDT-ROG libvirtd[1852]: 2019-07-20 04:06:55.213+0000: 1852: info : hostname: MGDT-ROG
    Jul 20 12:06:55 MGDT-ROG libvirtd[1852]: 2019-07-20 04:06:55.213+0000: 1852: warning : virGetHostnameImpl:540 : getaddrinfo failed for 'MGDT-ROG': Name or service not known
    Jul 20 12:06:55 MGDT-ROG libvirtd[1852]: libvirt version: 5.4.0
    Jul 20 12:06:55 MGDT-ROG libvirtd[1852]: hostname: MGDT-ROG
    Jul 20 12:06:55 MGDT-ROG libvirtd[1852]: Failed to intialize libnetcontrol.  Management of interface devices is disabled
    Jul 20 12:06:55 MGDT-ROG systemd[1]: Started Virtualization daemon.
    Jul 20 12:06:55 MGDT-ROG dnsmasq[1960]: directory /etc/resolv.conf for resolv-file is missing, cannot poll
    Jul 20 12:06:55 MGDT-ROG dnsmasq[1960]: FAILED to start up
    Jul 20 12:06:55 MGDT-ROG libvirtd[1852]: internal error: Child process (VIR_BRIDGE_NAME=virbr0 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf --leasefile-ro --dhcp-script=/usr/lib64/libvirt/libvirt_leaseshelper) unexpected exit status 5: 
                                             dnsmasq: directory /etc/resolv.conf for resolv-file is missing, cannot poll
    Jul 20 12:08:27 MGDT-ROG libvirtd[1852]: this function is not supported by the connection driver: virConnectNumOfInterfaces
    3. After this, I manually restarted libvirtd.service and errors are gone. virtual networks start correctly.

    Code:
    ● libvirtd.service - Virtualization daemon
       Loaded: loaded (/usr/lib/systemd/system/libvirtd.service; enabled; vendor preset: disabled)
       Active: active (running) since Sat 2019-07-20 12:16:37 CST; 1s ago
         Docs: man:libvirtd(8)
               https://libvirt.org
     Main PID: 3735 (libvirtd)
        Tasks: 19 (limit: 32768)
       Memory: 17.2M
       CGroup: /system.slice/libvirtd.service
               ├─3735 /usr/sbin/libvirtd --listen
               ├─3798 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf --leasefile-ro --dhcp-script=/usr/lib64/libvirt/libvirt_leaseshelper
               └─3799 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf --leasefile-ro --dhcp-script=/usr/lib64/libvirt/libvirt_leaseshelper
    
    Jul 20 12:16:37 MGDT-ROG dnsmasq[3798]: started, version 2.80 cachesize 2000
    Jul 20 12:16:37 MGDT-ROG dnsmasq[3798]: compile time options: IPv6 GNU-getopt DBus i18n IDN2 DHCP DHCPv6 Lua TFTP conntrack ipset auth DNSSEC loop-detect inotify dumpfile
    Jul 20 12:16:37 MGDT-ROG dnsmasq-dhcp[3798]: DHCP, IP range 192.168.122.2 -- 192.168.122.254, lease time 1h
    Jul 20 12:16:37 MGDT-ROG dnsmasq-dhcp[3798]: DHCP, sockets bound exclusively to interface virbr0
    Jul 20 12:16:37 MGDT-ROG dnsmasq[3798]: reading /etc/resolv.conf
    Jul 20 12:16:37 MGDT-ROG dnsmasq[3798]: using nameserver 192.168.250.5#53
    Jul 20 12:16:37 MGDT-ROG dnsmasq[3798]: using nameserver 168.95.1.1#53
    Jul 20 12:16:37 MGDT-ROG dnsmasq[3798]: read /etc/hosts - 7 addresses
    Jul 20 12:16:37 MGDT-ROG dnsmasq[3798]: read /var/lib/libvirt/dnsmasq/default.addnhosts - 0 addresses
    Jul 20 12:16:37 MGDT-ROG dnsmasq-dhcp[3798]: read /var/lib/libvirt/dnsmasq/default.hostsfile

  6. #16
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,927
    Blog Entries
    2

    Default Re: virt-manager NAT networks inactive on system boot

    Looks like your problem has been resolved.
    Whatever the problem was before,
    It seems to be resolved finally by re-generating your /etc/resolv.conf which can be done on reboot or by running the command
    Code:
    netconfig
    Note that this does not appear to be related to the frequently seen dns configuration issue that requires a forced regeneration (with -f flag).

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •