Results 1 to 6 of 6

Thread: Conky stopped running

  1. #1
    Join Date
    Feb 2017
    Location
    Very Far Away
    Posts
    56

    Default Conky stopped running

    Hi!
    For about a week now it seems I cannot run conky any more. Initially I thought it was a lua problem, and I tried running a new .conkyrc that doesn't need lua, but I still get the same error:
    Code:
    conky: [string "..."]:159: attempt to call a nil value (global 'loadstring')
    I've tried several different scripts, but none of them runs.
    What I find puzzling is that no matter what script I run, I always get the same error message, which points to the same line.
    I've restarted, logged out and back in, but to no avail.
    I tried running the default conky from root, and it does run, but when I copied any of the .conkyrc files to the root folder, I got the same error message that I've been getting when running them as a regular user.
    I am using the Gnome on X (I wasn't terribly fond of Wayland), and I noticed a new conky icon in the applications view, which might imply a new instance of conky, could it be connected? If so, I haven't been able to find a reference for new syntax.
    Thanks in advance for reading, and for any kind help you might want to provide.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,815
    Blog Entries
    15

    Default Re: Conky stopped running

    Quote Originally Posted by Icearchery View Post
    Hi!
    For about a week now it seems I cannot run conky any more. Initially I thought it was a lua problem, and I tried running a new .conkyrc that doesn't need lua, but I still get the same error:
    Code:
    conky: [string "..."]:159: attempt to call a nil value (global 'loadstring')
    I've tried several different scripts, but none of them runs.
    What I find puzzling is that no matter what script I run, I always get the same error message, which points to the same line.
    I've restarted, logged out and back in, but to no avail.
    I tried running the default conky from root, and it does run, but when I copied any of the .conkyrc files to the root folder, I got the same error message that I've been getting when running them as a regular user.
    I am using the Gnome on X (I wasn't terribly fond of Wayland), and I noticed a new conky icon in the applications view, which might imply a new instance of conky, could it be connected? If so, I haven't been able to find a reference for new syntax.
    Thanks in advance for reading, and for any kind help you might want to provide.
    Hi
    No issues seen here with conky. What conky types are you running, pure lua?

    If you move the current ~./conkyrc (and any other configs) and just run the conky command, do you get the default conky appear?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Feb 2017
    Location
    Very Far Away
    Posts
    56

    Default Re: Conky stopped running

    Hi! Thank you malcolmlewis for your kind reply.
    I've tried running conkyrc scripts with and without lua, and I always get the same error message.
    When I remove all .conkyrc files from the home folder the default conky runs fine. (This is why I thought maybe there has been some change in syntax, but if I'm the only one experiencing this problem, then that's unlikely.)
    Since the error I mentioned above is the only clue I have, I was wondering where else I should look. Thanks in advance!

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,815
    Blog Entries
    15

    Default Re: Conky stopped running

    Quote Originally Posted by Icearchery View Post
    Hi! Thank you malcolmlewis for your kind reply.
    I've tried running conkyrc scripts with and without lua, and I always get the same error message.
    When I remove all .conkyrc files from the home folder the default conky runs fine. (This is why I thought maybe there has been some change in syntax, but if I'm the only one experiencing this problem, then that's unlikely.)
    Since the error I mentioned above is the only clue I have, I was wondering where else I should look. Thanks in advance!
    Hi
    Are these recent configs downloaded of are the ones that are self created? I'm also guessing that the configs have been converted to the new format (starting from version 1.10)?

    If they are downloaded ones, perhaps recheck the site for an updated version....

    The only lua I'm running is for the background, rest is just text based (See https://forums.opensuse.org/showthre...34#post2907534)
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Feb 2017
    Location
    Very Far Away
    Posts
    56

    Default Re: Conky stopped running

    Hi, Malcolmlewis! Thanks again for your kind reply.
    The scripts are old, yes, and I tweaked them to match my needs, so I don't think they are exactly like the uploaded versions. I've been using them for years, and they were running perfectly until about a week ago; but I will check whether there are newer versions. I checked whether it was something I installed, but other than gcc-c++ and cmus I don't think I installed anything new, and that was before the last update too. I'll keep you updated if I find any clue. Thank you!
    BTW, that's some beautiful use of conky, useful and tidy: Perfect!

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,815
    Blog Entries
    15

    Default Re: Conky stopped running

    Quote Originally Posted by Icearchery View Post
    Hi, Malcolmlewis! Thanks again for your kind reply.
    The scripts are old, yes, and I tweaked them to match my needs, so I don't think they are exactly like the uploaded versions. I've been using them for years, and they were running perfectly until about a week ago; but I will check whether there are newer versions. I checked whether it was something I installed, but other than gcc-c++ and cmus I don't think I installed anything new, and that was before the last update too. I'll keep you updated if I find any clue. Thank you!
    BTW, that's some beautiful use of conky, useful and tidy: Perfect!
    Hi
    So your configs should start like this....

    Code:
    conky.config = {
       own_window = true,
    ....
    ....
    }
    
    conky.text = [[
    ${color2}ENVIRONMENT ${voffset -3}${hr 1}${color}
    ....
    ....
    ]]
    Last edited by malcolmlewis; 06-Jul-2019 at 10:01.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •