It can be done by running `repoquery --tree-requires pkg` in centos. However, the yum-utils pkg on opensuse, which contains the repoquery script, delivers a version of repoquery without tree-requires ability.
I've searched for a while. One way is to use an outdated ruby script depgrapher. Cause I'm not familar with ruby, and the script won't run after some simple fixes. I gave up on it. Another is to use zypper --debug-solver and add <graphic/> node. Unfortunately <graphic/> was deprecated, and no substitution was provided.
So I went here to ask if there's a program for it, wheter GUI or CLI.