Results 1 to 2 of 2

Thread: Application requires a library older than the one installed in the system

  1. #1
    Join Date
    Jun 2019
    Posts
    3

    Default Application requires a library older than the one installed in the system

    Hi,

    I need some help just to understand if this is something that is only fixed by an Application update.

    The application Cartao Cidadao distributted by Portuguese public sector (https://www.autenticacao.gov.pt/docu...a-1521456ba90d) was available for Opensuse Leap 15.0 and everything was working fine until I decided to upgrade Leap 15.0 -> Leap 15.1.

    As soon I have upgraded to Leap 15.1 then the application now requires libQt5Gui5-5.9.4 while in the system I have installed libQt5Gui5-5.9.7

    linux:/home/mkk # rpm -ivh Autenticacao.gov-OpenSUSE_3.0.16_x64.rpm
    error: Failed dependencies:
    libQt5Gui.so.5(Qt_5.9.4_PRIVATE_API)(64bit) is needed by pteid-mw-3.0.16.5840-1.x86_64


    I have installed in my system the 5.9.7 version of the library:

    linux:/home/mkk # rpm -qa | grep -i libQt5Gui
    libQt5Gui5-5.9.7-lp151.3.1.x86_64
    libQt5Gui5-32bit-5.9.7-lp151.3.1.x86_64


    If I try to install the 5.9.4 version it will start requiring all other package dependencies for that version which I don't want to install (to keep the Leap upgrade clean):

    linux:/home/mkk # rpm -ivh libQt5Gui5-5.9.4-lp150.4.8.x86_64.rpm
    error: Failed dependencies:
    libQt5Core.so.5(Qt_5.9.4_PRIVATE_API)(64bit) is needed by libQt5Gui5-5.9.4-lp150.4.8.x86_64
    libQt5Core5 = 5.9.4 is needed by libQt5Gui5-5.9.4-lp150.4.8.x86_64
    libQt5DBus5 = 5.9.4 is needed by libQt5Gui5-5.9.4-lp150.4.8.x86_64
    linux:/home/mkk #


    Is there any way/workaround to avoid install all these old libraries to get this application able to install?

    Was this requirement on old library something hardcoded inside the application itself and now the only option is to wait an update of it?

    Thanks,
    MKK

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,296
    Blog Entries
    2

    Default Re: Application requires a library older than the one installed in the system

    IMO you have several reasonable choices...

    You should try the following first...
    Try installing ignoring the dependency if you already have the newer package installed. (Usually option 2)
    if the problem isn't a coding issue, then your app should work just fine.

    If the above doesn't work but fails due to a file description problem,
    Try creating a symlink that points from the missing file name to the newer version file installed in your system.

    If the above doesn't work, then
    You can try downloading the version of your file by installing from the LEAP 15.0 repostitory at the following link

    https://software.opensuse.org/package/libQt5Gui5

    WARNING!
    If you install a package from a repository that doesn't match your openSUSE version, you must uncheck all the checkboxes on the first page of the YaST Installer which would normally subscribe your system to the repository. If you leave your system subscribed to the repository, then your system may end up downloading other files from the repository, making your system a "Frankenstein system" with numerous possible problems.

    If none of the above works,
    Then you can install LEAP 15.0 into a virtual machine to run this app.

    Regardless what may work for you,
    Please submit a bug report to the application's authors to fix the problem.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •