Hi,

I need some help just to understand if this is something that is only fixed by an Application update.

The application Cartao Cidadao distributted by Portuguese public sector (https://www.autenticacao.gov.pt/docu...a-1521456ba90d) was available for Opensuse Leap 15.0 and everything was working fine until I decided to upgrade Leap 15.0 -> Leap 15.1.

As soon I have upgraded to Leap 15.1 then the application now requires libQt5Gui5-5.9.4 while in the system I have installed libQt5Gui5-5.9.7

linux:/home/mkk # rpm -ivh Autenticacao.gov-OpenSUSE_3.0.16_x64.rpm
error: Failed dependencies:
libQt5Gui.so.5(Qt_5.9.4_PRIVATE_API)(64bit) is needed by pteid-mw-3.0.16.5840-1.x86_64


I have installed in my system the 5.9.7 version of the library:

linux:/home/mkk # rpm -qa | grep -i libQt5Gui
libQt5Gui5-5.9.7-lp151.3.1.x86_64
libQt5Gui5-32bit-5.9.7-lp151.3.1.x86_64


If I try to install the 5.9.4 version it will start requiring all other package dependencies for that version which I don't want to install (to keep the Leap upgrade clean):

linux:/home/mkk # rpm -ivh libQt5Gui5-5.9.4-lp150.4.8.x86_64.rpm
error: Failed dependencies:
libQt5Core.so.5(Qt_5.9.4_PRIVATE_API)(64bit) is needed by libQt5Gui5-5.9.4-lp150.4.8.x86_64
libQt5Core5 = 5.9.4 is needed by libQt5Gui5-5.9.4-lp150.4.8.x86_64
libQt5DBus5 = 5.9.4 is needed by libQt5Gui5-5.9.4-lp150.4.8.x86_64
linux:/home/mkk #


Is there any way/workaround to avoid install all these old libraries to get this application able to install?

Was this requirement on old library something hardcoded inside the application itself and now the only option is to wait an update of it?

Thanks,
MKK