Results 1 to 8 of 8

Thread: After upgrade from Leap 15.0 KMyMoney will run as ROOT but not as a USER?

  1. #1

    Default After upgrade from Leap 15.0 KMyMoney will run as ROOT but not as a USER?

    I have seen the post re: XFS/KDE but this is just KDE 5.12.18.

    Regards, Martin
    openSUSE Leap 15.1; KDE Plasma 5.12.8;

  2. #2

    Default Re: After upgrade from Leap 15.0 KMyMoney will run as ROOT but not as a USER?

    Some more information:
    the output of running from terminal as a USER:

    ~> kmymoney 2> kmymoney.log

    Contents of kmymoney.log below...

    Code:
    WebConnect: Try to connect to WebConnect server
    WebConnect: Connect to server failed
    WebConnect: Starting server failed. Try to remove stale socket.
    WebConnect: Running in server mode
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/budgetview.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/checkprinting.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/csvexporter.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/csvimporter.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/forecastview.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/gncimporter.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/icalendarexporter.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/kbanking.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/kcm_checkprinting.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/kcm_csvimporter.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/kcm_forecastview.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/kcm_icalendarexporter.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/kcm_qif.so" Validity false
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/kcm_reportsview.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/kcm_xmlstorage.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/konlinetasks_sepa.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/ofximporter.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/onlinejoboutboxview.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/qifexporter.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/qifimporter.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/reconciliationreport.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/reportsview.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/sqlstorage.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/xmlstorage.so" Validity true
    Loading "/usr/lib64/qt5/plugins/kmymoney/budgetview.so"
    Plugins: budgetview loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/checkprinting.so"
    Plugins: checkprinting loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/csvexporter.so"
    Plugins: csvexporter loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/csvimporter.so"
    Plugins: csvimporter loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/forecastview.so"
    Plugins: forecastview loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/gncimporter.so"
    Plugins: gncimporter loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/icalendarexporter.so"
    Plugins: icalendarexporter loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/kbanking.so"
    Plugins: kbanking loaded
    KBankingPlugin: No AqB4 config found.
    KBankingPlugin: No AqB3 config found.
    Loading "/usr/lib64/qt5/plugins/kmymoney/ofximporter.so"
    Plugins: ofximporter loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/onlinejoboutboxview.so"
    Plugins: onlinejoboutboxview loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/qifexporter.so"
    Plugins: qifexporter loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/qifimporter.so"
    Plugins: qifimporter loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/reconciliationreport.so"
    Plugins: reconciliation report loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/reportsview.so"
    Plugins: reportsview loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/sqlstorage.so"
    Plugins: sqlstorage loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/xmlstorage.so"
    Plugins: xmlstorage loaded
    reading file
    start parsing file
    startDocument
    reading securities
    endDocument
    testing fileFixVersion 4 < 5
    Cost center model created with items 0
    Payees model created with items 0
    KCrash: Application 'kmymoney' crashing...
    KCrash: Attempting to start /usr/lib64/libexec/drkonqi from kdeinit
    QSocketNotifier: Invalid socket 8 and type 'Read', disabling...
    [warn] epoll_wait: Bad file descriptor
    [warn] epoll_wait: Bad file descriptor
    {
        ... repeated many, many times & removed for brevity.
    }
    [warn] epoll_wait: Bad file descriptor
    [warn] epoll_wait: Bad file descriptor
    Unable to start Dr. Konqi
    Re-raising signal for core dump handling.
    Regards,

    PS - How do I attach a text/Log file? Or is it deliberate design to contain code within the posting?
    openSUSE Leap 15.1; KDE Plasma 5.12.8;

  3. #3
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,454

    Default Re: After upgrade from Leap 15.0 KMyMoney will run as ROOT but not as a USER?

    Is kmymoney installed in /usr/bin/? I do not have the same problem.

  4. #4
    Join Date
    Sep 2014
    Location
    Germany
    Posts
    373

    Default Re: After upgrade from Leap 15.0 KMyMoney will run as ROOT but not as a USER?

    Quote Originally Posted by martinprowe View Post
    I have seen the post re: XFS/KDE but this is just KDE 5.12.18.

    Regards, Martin
    I just did a fresh install (no OS-update, no old /home) of openSUSE Leap 15.1 with KDE as DE and can confirm this problem:

    Kmymoney will only start when run as root but not as user.

    I have not investigated the problem any further yet.

    Regards

    susejunky

  5. #5
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,454

    Default Re: After upgrade from Leap 15.0 KMyMoney will run as ROOT but not as a USER?

    I have a computer on which Leap 15.1 has been installed from scratch and user can use KMyMoney in KDE fine. Try opening a console and entering kmymoney and see what messages you get.

  6. #6
    Join Date
    Sep 2014
    Location
    Germany
    Posts
    373

    Default Re: After upgrade from Leap 15.0 KMyMoney will run as ROOT but not as a USER?

    Quote Originally Posted by john_hudson View Post
    I have a computer on which Leap 15.1 has been installed from scratch and user can use KMyMoney in KDE fine. Try opening a console and entering kmymoney and see what messages you get.
    The console shows
    Code:
    USER@HOST:~> kmymoney
    WebConnect: Try to connect to WebConnect server
    WebConnect: Connect to server failed
    WebConnect: Running in server mode
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/kcm_csvimporter.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/kcm_reportsview.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/konlinetasks_sepa.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/kcm_qif.so" Validity false
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/reconciliationreport.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/csvexporter.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/kbanking.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/sqlstorage.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/xmlstorage.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/kcm_xmlstorage.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/forecastview.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/reportsview.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/kcm_icalendarexporter.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/checkprinting.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/gncimporter.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/csvimporter.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/budgetview.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/ofximporter.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/qifexporter.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/icalendarexporter.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/kcm_forecastview.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/kcm_checkprinting.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/onlinejoboutboxview.so" Validity true
    Located plugin "/usr/lib64/qt5/plugins/kmymoney/qifimporter.so" Validity true
    Loading "/usr/lib64/qt5/plugins/kmymoney/budgetview.so"
    Plugins: budgetview loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/checkprinting.so"
    Plugins: checkprinting loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/csvexporter.so"
    Plugins: csvexporter loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/csvimporter.so"
    Plugins: csvimporter loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/forecastview.so"
    Plugins: forecastview loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/gncimporter.so"
    Plugins: gncimporter loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/icalendarexporter.so"
    Plugins: icalendarexporter loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/kbanking.so"
    Plugins: kbanking loaded
    3:2019/07/08 10-42-17:gwen(2762):plugin.c:  379: Plugin "dir" not found.
    3:2019/07/08 10-42-17:(null)(2762):banking_cfg.c:   77: Could not create ConfigMgr[dir:///home/USER/.aqbanking/settings]. Maybe the gwenhywfar plugins are not installed?
    3:2019/07/08 10-42-17:(null)(2762):banking_cfg.c:  100: No config manager. Maybe the gwenhywfar plugins are not installed correctly?
    KBankingPlugin: No AqB4 config found.
    KBankingPlugin: No AqB3 config found.
    3:2019/07/08 10-42-17:aqbanking(2762):banking_cfg.c:  712: No config manager. Maybe the gwenhywfar plugins are not installed correctly?
    Error on online init (-1).
    Could not initialize KBanking online banking interface
    Loading "/usr/lib64/qt5/plugins/kmymoney/ofximporter.so"
    Plugins: ofximporter loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/onlinejoboutboxview.so"
    Plugins: onlinejoboutboxview loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/qifexporter.so"
    Plugins: qifexporter loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/qifimporter.so"
    Plugins: qifimporter loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/reconciliationreport.so"
    Plugins: reconciliation report loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/reportsview.so"
    Plugins: reportsview loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/sqlstorage.so"
    Plugins: sqlstorage loaded
    Loading "/usr/lib64/qt5/plugins/kmymoney/xmlstorage.so"
    Plugins: xmlstorage loaded
    reading file
    start parsing file
    startDocument
    reading securities
    endDocument
    Cost center model created with items 0
    Payees model created with items 0
    [1:1:0100/000000.076039:ERROR:broker_posix.cc(41)] Invalid node channel message
    KCrash: Application 'kmymoney' crashing...
    KCrash: Attempting to start /usr/lib64/libexec/drkonqi from kdeinit
    sock_file=/run/user/1000/kdeinit5__0
    
    [1]+  Angehalten              kmymoney
    USER@HOST:~>
    As i said in my last post: up to now i have not looked into this. But maybe someone did already ...

    Regards

    susejunky

  7. #7
    Join Date
    Sep 2014
    Location
    Germany
    Posts
    373

    Default Re: After upgrade from Leap 15.0 KMyMoney will run as ROOT but not as a USER?

    In the meantime i searched bugzilla and found this

    https://bugzilla.opensuse.org/show_bug.cgi?id=1136300

    The bug is confirmed (even upstream https://bugs.kde.org/show_bug.cgi?id=407902) and here is a fix (https://bugzilla.opensuse.org/show_b...id=1136300#c20) provided.

    Regards

    susejunky

  8. #8
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,454

    Default Re: After upgrade from Leap 15.0 KMyMoney will run as ROOT but not as a USER?

    Having successfully installed KMyMoney on one Leap 15.1 computer without problems, I hit the problem on another computer but the solution was to install 5.05 from KDE/Extra which works fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •