Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: yast shows only 7 packages installed in @system tab

  1. #1

    Default yast shows only 7 packages installed in @system tab

    yast software management shows only 7 packages installed in @system tab a no other packages to install.
    one week ago there was all the list of packages.
    how can I get all the packages listed?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,634
    Blog Entries
    3

    Default Re: yast shows only 7 packages installed in @system tab

    I'm not sure where you are looking.

    If I use the "Repositories" view, then "@System" is one possible choice in that view.

    I'm not sure where you are seeing an "@System" tab.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3

    Default Re: yast shows only 7 packages installed in @system tab

    Quote Originally Posted by nrickert View Post
    I'm not sure where you are looking.

    If I use the "Repositories" view, then "@System" is one possible choice in that view.

    I'm not sure where you are seeing an "@System" tab.
    yes, that one,
    the "Repositories" view choosing "@System"

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,864
    Blog Entries
    15

    Default Re: yast shows only 7 packages installed in @system tab

    Quote Originally Posted by pier_andreit View Post
    yes, that one,
    the "Repositories" view choosing "@System"
    Hi
    Perhaps it's your perception at what @System packages are... orphans from no fixed abode they are ones that have normally been installed manually, or the repository they came from has been removed... so yes, normally there are only a few...
    Code:
    zypper se -si --sort-by-repo |grep "System Packages" | wc -l
    
    zypper se -si --sort-by-repo |grep "System Packages"
    
    eg
    zypper if tizonia
    
    Information for package tizonia:
    --------------------------------
    Repository     : @System <==
    Name           : tizonia                                           
    Version        : 0.18.0-1.1                                        
    Arch           : x86_64                                            
    Vendor         : obs://build.opensuse.org/home:malcolmlewis:TESTING
    If I added my tesing repo, then the above would not be an @System file anymore.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,158

    Default Re: yast shows only 7 packages installed in @system tab

    Hm, from the Repositories View choosing @System, I see all packages that are installed on the system.
    Henk van Velden

  6. #6
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    1,003

    Default Re: yast shows only 7 packages installed in @system tab

    Quote Originally Posted by pier_andreit View Post
    yast software management shows only 7 packages installed in @system tab a no other packages to install.
    one week ago there was all the list of packages.
    how can I get all the packages listed?
    Actually you want to have no package in @system. They are orphaned and unmaintainable through repos. If deleted you can't install them again easily. The following is perfect:

    Code:
    erlangen:~ # zypper se -si |grep "System Packages" 
    i+ | kernel-default                               | package | 5.1.7-1.2                             | x86_64 | (System Packages)
    erlangen:~ #
    With kernel-default being a multiversion package the older of the two versions available is labelled "(System Packages)". Downloaded rpms go here:

    Code:
    erlangen:~ # zypper lr -uEP MyRepo
    Alias          : MyRepo                         
    Name           : MyRepo                         
    URI            : dir:/home/karl/Downloads/myrepo
    Enabled        : Yes                            
    GPG Check      : (  ) No                        
    Priority       : 100 (lowered priority)         
    Autorefresh    : On                             
    Keep Packages  : Off                            
    Type           : rpm-md                         
    GPG Key URI    :                                
    Path Prefix    :                                
    Parent Service :                                
    Keywords       : ---                            
    Repo Info Path : /etc/zypp/repos.d/MyRepo.repo  
    MD Cache Path  : /var/cache/zypp/raw/MyRepo     
    erlangen:~ #
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,634
    Blog Entries
    3

    Default Re: yast shows only 7 packages installed in @system tab

    Quote Originally Posted by karlmistelberger View Post
    Actually you want to have no package in @system. They are orphaned and unmaintainable through repos.
    It depends on where you are looking. In some places, everything installed shows as @system.

    Code:
    erlangen:~ # zypper se -si |grep "System Packages" 
    i+ | kernel-default                               | package | 5.1.7-1.2                             | x86_64 | (System Packages)
    erlangen:~ #
    With kernel-default being a multiversion package the older of the two versions available is labelled "(System Packages)".
    That's Tumbleweed. But for Leap 15.x, the older kernels should still show a repo.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  8. #8

    Default Re: yast shows only 7 packages installed in @system tab

    well, at the relaunch of yast software management it gives me this error:
    cannot read the list of installed packages
    then retrying yast asked me to confirm the trust key of all the repositories
    ant then this is the result:

    https://paste.opensuse.org/view//32127812
    as previous only 7 packages shown
    the other repositories shows only a list of not installed packages

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,158

    Default Re: yast shows only 7 packages installed in @system tab

    Maybe something wrong with the RPM database?
    Code:
    sudo rpm --rebuilddb
    Henk van Velden

  10. #10
    Join Date
    Jun 2008
    Location
    Belleville, Ontario, Canada
    Posts
    445

    Default Re: yast shows only 7 packages installed in @system tab

    Quote Originally Posted by hcvv View Post
    Hm, from the Repositories View choosing @System, I see all packages that are installed on the system.
    I, too, see it exactly as hcvv sees it. It's always been that way for me (since 2006 (or 2007??)).
    "Making rich people richer doesn't make the rest of us richer." Ha-Joon Chang
    openSUSE 15.1 4.12.14-lp151.28.16-default x64

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •