Results 1 to 5 of 5

Thread: Conky closes after 5 sec

  1. #1

    Default Conky closes after 5 sec

    Since last week i have a problem with conky. From console it starts without problems and all looks good. All values are there and the conky insert looks good.
    But after 5 sec it simply closes, means the process in htop get grayed out and disappears a second later. No errors, nothing on the console.
    This only happens on my desktop with amdgpu kernel driver, not on my laptop with intel driver. Before it was running well for years.
    Both machines running full updated Leap 15.0.
    What to do?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,859
    Blog Entries
    15

    Default Re: Conky closes after 5 sec

    Quote Originally Posted by testi55 View Post
    Since last week i have a problem with conky. From console it starts without problems and all looks good. All values are there and the conky insert looks good.
    But after 5 sec it simply closes, means the process in htop get grayed out and disappears a second later. No errors, nothing on the console.
    This only happens on my desktop with amdgpu kernel driver, not on my laptop with intel driver. Before it was running well for years.
    Both machines running full updated Leap 15.0.
    What to do?
    Hi
    What 'own_window' options do you have set in your conky configuration?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Conky closes after 5 sec

    From conkyrc:
    Code:
    -- Use Xft?    use_xft = true,
        font = 'Bitstream Vera Sans Mono:size=9',
        xftalpha = 0.8,
        override_utf8_locale = true,
        short_units = true,
    
    
        update_interval = 5,
        total_run_times = 0,
    
    
        own_window = true,
        own_window_type = 'normal',
        own_window_transparent = true,
        own_window_class = 'Conky',
        own_window_argb_visual = true,
        own_window_colour = '#082103',
        own_window_hints = 'undecorated,below,sticky,skip_taskbar,skip_pager',
    
    
        double_buffer = true,
        minimum_width = 320, minimum_height = 5,
        maximum_width = 320,
        max_text_width = 0,
    No changes were made to the system before the issue appeared, only the suse updates.
    With the older kernel, the problem is the same.

    Console with starting conky:
    Code:
    vos@linux-t0qs:~> conky
    conky: desktop window (2200012) is subwindow of root window (647)
    conky: window type - normal
    conky: drawing to created window (0x3600002)
    conky: drawing to double buffer
    conky: forked to background, pid is 2988
    vos@linux-t0qs:~> 
    
    

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,859
    Blog Entries
    15

    Default Re: Conky closes after 5 sec

    Hi
    Likely some graphics update... I use the following (your issue sounds similar to one I had a number of years back...);
    Code:
    conky.config = {
       own_window = true,
       own_window_type = 'normal',
       own_window_transparent = false,
       own_window_hints = 'undecorated,sticky,below,skip_taskbar,skip_pager',
       own_window_colour = 'black',
       own_window_class = 'Conky',
       own_window_title = 'Environment',
       own_window_argb_visual = true,
       own_window_argb_value = 0,
       double_buffer = true,
       background = true,
       draw_borders = false,
       draw_outline = false,
       minimum_width = 320, minimum_height = 5,
       maximum_width = 320,
       gap_x = 1470,
       gap_y = 20,
       font = 'Cantarell:size=10',
       default_color = '#DCDCDC',
       color0 = '#1793d0',
       color2 = 'green',
       color3 = '#FFFF00',
       color4 = '#FF6400',
       color5 = '#FF0000',
       use_xft = true,
       xftalpha = 0.8,
       override_utf8_locale = true,
       draw_shades = false,
       default_shade_color = 'black',
       draw_outline = false,
       uppercase = false
    }
    This is working fine with Leap 15.0 and amdgpu driver... I would suggest adding the hints and argb bits to start with and see how that goes.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: Conky closes after 5 sec

    Thanks for your hint. I replaced the part from my conkyrc with yours. No difference. Still closing.

    Then i copied conkyrc to my root account and starting there as root. Same game. So no permission problem.
    Tried all renderer in KDE as user. You guess it, nothing. Already tried older kernel, so no amdgpu problem.

    Gotcha *****! Sorry.

    The culprit is that line:
    Code:
    ${color9}${cpugraph 3dba19 aecf4c -t -l}
    I comment it out ..SUCCESS. It's working again.

    No idea what has changed 1-2 weeks ago. It was working well for years...AND..it is still working with laptop Intel driver and ubuntu.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •