Results 1 to 7 of 7

Thread: Mounting Samba drive in fstab

  1. #1
    Join Date
    Jun 2008
    Location
    Elliott Heads, Qld, Aus
    Posts
    195

    Default Mounting Samba drive in fstab

    New version of Opensuse, new issues with accessing a samba share on the network....
    Have got a number of Samba shares, on a Fritz!Box router, which I am loading like:
    //192.168.0.1/FRITZ.NAS/Seagate_Expansion_Drive/data/ /home/External/data cifs noauto,username=john,password=xxxxxxx,vers=1.0,iocharset=utf8,sec=ntlm 0 0
    Worked fine with Leap15.
    Have also tried with vers=2.0 and also removing any ref to vers.
    Can anyone recommend how I now access this using Leap15.1?

    Thanks.
    i5/8GB
    openSuse Leap15.1
    KDE Plasma 5.12.8 (and Gnome - In training!)
    Linux Counter 130995

  2. #2
    Join Date
    Jun 2008
    Location
    Elliott Heads, Qld, Aus
    Posts
    195

    Default Re: Mounting Samba drive in fstab

    More info:
    If I: sudo mount -v /home/External/data/
    I get:
    mount.cifs kernel mount options: ip=192.168.0.1,unc=\\192.168.0.1\FRITZ.NAS,vers=1.0,iocharset=utf8,sec=ntlm,user=john,prefixpath=Seagate_Expansion_Drive/data/,pass=********
    mount error(13): Permission denied
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)
    Very little (understandable) info in any of the logs...

    Thanks.
    i5/8GB
    openSuse Leap15.1
    KDE Plasma 5.12.8 (and Gnome - In training!)
    Linux Counter 130995

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,942
    Blog Entries
    2

    Default Re: Mounting Samba drive in fstab

    Permission denied
    Usually means you're trying to access something that doesn't exist or has permissions you haven't provided.
    There can be many causes for not providing credentials to address permissions...
    Bad username/password.
    Incompatible ciphers (encryption algorithm) used. Perhaps 15.1 is using a newer version than your server by default, so you need to specify accurately in your configuration file.

    You can look for more specific information in your server (Fritzbox) logs.
    You can also try displaying your system log events on your client machine in real time as you try to connect by opening a console/terminal window (like konsole or xterm) and running the following command-
    Code:
    journalctl -f
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,193
    Blog Entries
    1

    Default Re: Mounting Samba drive in fstab

    Anything significant reported via the following?
    Code:
    sudo  journalctl | grep CIFS
    openSUSE Leap 15.0; KDE Plasma 5

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,942
    Blog Entries
    2

    Default Re: Mounting Samba drive in fstab

    Forgot to mention...
    Since my post describes User mounted and not mounted on boot,

    I recommend you follow my procedure first to make sure your mount command works,
    Then after you've verified it works insert into your fstab.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  6. #6
    Join Date
    Jun 2008
    Location
    Elliott Heads, Qld, Aus
    Posts
    195

    Default Re: Mounting Samba drive in fstab

    Sorry peoples.....
    How many times can you read a "wrong password" message and ignore it....
    All my fault from being stupid!
    My apologies to Samba!!

    All working as expected.
    i5/8GB
    openSuse Leap15.1
    KDE Plasma 5.12.8 (and Gnome - In training!)
    Linux Counter 130995

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,193
    Blog Entries
    1

    Default Re: Mounting Samba drive in fstab

    At least you've identified the mistake with credentials! Thanks for the update.
    openSUSE Leap 15.0; KDE Plasma 5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •