Results 1 to 8 of 8

Thread: DisplayCal don´t start under KDE OpenSuse Leap 15.0 and 15.1

  1. #1

    Default DisplayCal don´t start under KDE OpenSuse Leap 15.0 and 15.1

    Hello!

    The newest DisplayCal doesn't start under Leap 15.0 (which I use) and 15.1 (which live I have tested). It's supposed, that the Python 2.7 Install is broken; I have tried to reinstall libpython2_7 and the same 32-bit, but that didn't help either.

    Please see the Link

    https://hub.displaycal.net/forums/to...arsers-expat/?

    for more information.

    Thanks in advance,
    Vadim.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,739
    Blog Entries
    3

    Default Re: DisplayCal don´t start under KDE OpenSuse Leap 15.0 and 15.1

    I tried installing "displaycal-3.5.3.0-lp151.2.3" on a Leap 15.1 system.

    It installs without a problem.

    I started it from the KDE menu. It seemed to run without problems.

    However -- it did want me to upgrade to a later version (3.8.2, I think). I declined, because I prefer to install from the standard repos rather than over the web. It also wanted to upgrade another component (I also declined).

    I'm not familiar with the software, so I'm not sure whether it works properly. But it starts up without problems, other than the need to skip the update offers. And it looks as if it would work.

    Maybe if I had upgraded to that suggested version, it might have failed. I'm not about to test that. I'm inclined to think it a misfeature, that the software even asks me to upgrade outside of the standard openSUSE repos.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3

    Default Re: DisplayCal don´t start under KDE OpenSuse Leap 15.0 and 15.1

    Quote Originally Posted by duessd View Post
    It's supposed, that the Python 2.7 Install is broken
    In your case there's no question about that. The error you were getting:
    Code:
    import xml.parsers.expat
    ImportError: No module named xml.parsers.expat
    The XML module is part of the Python standard library.

    Note that I cannot reproduce the problem (Tumbleweed).

  4. #4

    Default Re: DisplayCal don´t start under KDE OpenSuse Leap 15.0 and 15.1

    I have attached a Konsole output, maybe it will help to debug this problem.

    A newbee question: How can I repair my broken Python installation? Which files do I need to replace/update? I have tried python, python-base, python-xml already.

    The next interesting thing is that I was able to successfully launch 3.8.2 in other Leap 15.0 install/other computer, where everything works as expected.

    Thanks in advance,

    Vadim.




    ~> displaycal
    XDG: [Errno 2] No translation file found for domain: xdg-user-dirs
    displaycal 3.8.2.0 2019-06-09T15:21:39.523195Z
    x86_64
    Python 2.7.14 (default, Oct 12 2017, 15:50:02) [GCC]
    ImportError: No module named faulthandler
    ImportError: /usr/lib64/libgio-2.0.so.0: undefined symbol: g_utf8_validate_len

    Traceback (most recent call last):
    File "/usr/bin/displaycal", line 6, in <module>
    main()
    File "/usr/lib64/python2.7/site-packages/DisplayCAL/main.py", line 92, in main
    from wxaddons import wx
    File "/usr/lib64/python2.7/site-packages/DisplayCAL/wxaddons.py", line 10, in <module>
    from wxfixes import wx, GenButton, PlateButton, get_dialogs
    File "/usr/lib64/python2.7/site-packages/DisplayCAL/wxfixes.py", line 24, in <module>
    import wx
    File "/usr/lib64/python2.7/site-packages/wx-3.0-gtk2/wx/__init__.py", line 45, in <module>
    from wx._core import *
    File "/usr/lib64/python2.7/site-packages/wx-3.0-gtk2/wx/_core.py", line 4, in <module>
    import _core_
    ImportError: /usr/lib64/libgio-2.0.so.0: undefined symbol: g_utf8_validate_len
    /usr/lib64/python2.7/site-packages/wx-3.0-gtk2/wx/_core.py:16629: UserWarning: wxPython/wxWidgets release number mismatch
    Segmentation fault (core dumped)

  5. #5

    Default Re: DisplayCal don´t start under KDE OpenSuse Leap 15.0 and 15.1

    That's a different error now. Seems there are other things awry on your system. Maybe check your LD_LIBRARY_PATH for conflicting versions of glib.

  6. #6

    Default Re: DisplayCal don´t start under KDE OpenSuse Leap 15.0 and 15.1

    Quote Originally Posted by fhoech View Post
    a.)That's a different error now.


    b.)Maybe check your LD_LIBRARY_PATH for conflicting versions of glib.
    The first error was in Leap 15.1 live, the second, that in recent post, was from my Leap 15.0.

    Newbee question: how can I do that? I have issued the commando "printenv", but there was no LD... Also, it seems, that today was the update for glib2, that didn't help.

    Thanks in advance,
    Vadim.

  7. #7

    Default Re: DisplayCal don´t start under KDE OpenSuse Leap 15.0 and 15.1

    Quote Originally Posted by duessd View Post
    I have issued the commando "printenv", but there was no LD...
    Code:
    $ echo $LD_LIBRARY_PATH
    But to be honest, since you already have a working 15.0 install, it'll probably be easiest to just do a clean re-install of the other system(s).

  8. #8

    Default Re: DisplayCal don´t start under KDE OpenSuse Leap 15.0 and 15.1

    Quote Originally Posted by fhoech View Post
    Code:
    $ echo $LD_LIBRARY_PATH
    But to be honest, since you already have a working 15.0 install, it'll probably be easiest to just do a clean re-install of the other system(s).
    That´s why I've taken live Leap 15.1 for experiments... Will wait for the next image, the image from 04.06 was the last available.

    BTW, the echo command returned nothing, just the empty line.

    Thanks,
    Vadim.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •