Results 1 to 6 of 6

Thread: Leap 15.0 and 15.1 ssh -X, OpenGL

  1. #1

    Default Leap 15.0 and 15.1 ssh -X, OpenGL

    Hello,

    I have one problem, i used KDE. In new version opensuse 15.0 and 15.1 (in opensuse 42.3 working) not working ssh -X. I sign up through ssh -X user@i.p. and run the program using nvidia and opengl. But I get a buzz in the terminal:

    Server On Display localhost:10.0 Has Not Loaded OpenGL Extension.

    What with this?

    Thanks

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,559

    Default Re: Leap 15.0 and 15.1 ssh -X, OpenGL

    @czczc:

    Maybe this StackExchange entry can help with the NVidia / OpenGL issue: <https://unix.stackexchange.com/quest...ard-to-a#76017>.

    In addition, due to the system security changes which happened with Leap 15.0 and 15.1, the following points may need attention:
    1. Firewalld – check the Zone currently assigned to the network interface – you may have to use the “Trusted” zone …
    2. ssh – consider using the ‘-Y’ option in addition to the ‘-X’ option.
    3. You may, also, have to wade through the PolicyKit settings …

  3. #3

    Default Re: Leap 15.0 and 15.1 ssh -X, OpenGL

    Quote Originally Posted by dcurtisfra View Post
    @czczc:

    Maybe this StackExchange entry can help with the NVidia / OpenGL issue: <https://unix.stackexchange.com/quest...ard-to-a#76017>.

    In addition, due to the system security changes which happened with Leap 15.0 and 15.1, the following points may need attention:
    1. Firewalld – check the Zone currently assigned to the network interface – you may have to use the “Trusted” zone …
    2. ssh – consider using the ‘-Y’ option in addition to the ‘-X’ option.
    3. You may, also, have to wade through the PolicyKit settings …
    Thanks for answer.
    I tried ssh -Y but this is not working to.
    Firewalld is off
    How change PolicyKit?

    Thank you

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,559

    Default Re: Leap 15.0 and 15.1 ssh -X, OpenGL

    Quote Originally Posted by czczc View Post
    How change PolicyKit?
    The documentation is in the openSUSE Security Guide: <https://doc.opensuse.org/documentati...policykit.html>.

  5. #5

    Default Re: Leap 15.0 and 15.1 ssh -X, OpenGL

    Quote Originally Posted by dcurtisfra View Post
    The documentation is in the openSUSE Security Guide: <https://doc.opensuse.org/documentati...policykit.html>.
    Thx I solved my problem. Just install mesa libraries like opensuse 42.3.

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,559

    Question Re: Leap 15.0 and 15.1 ssh -X, OpenGL

    Quote Originally Posted by czczc View Post
    Just install mesa libraries like opensuse 42.3.
    You didn't have the Mesa libraries installed?
    Code:
     > zypper search --installed-only mesa
    Loading repository data...
    Reading installed packages...
    
    S  | Name               | Summary                                            | Type
    ---+--------------------+----------------------------------------------------+--------
    i+ | Mesa               | System for rendering 3-D graphics                  | package
    i+ | Mesa-demo-x        | GLX-based demos                                    | package
    i+ | Mesa-dri           | DRI plug-ins for 3D acceleration                   | package
    i+ | Mesa-dri-nouveau   | Mesa DRI plug-in for 3D acceleration via Nouveau   | package
    i+ | Mesa-gallium       | Mesa Gallium GPU drivers                           | package
    i+ | Mesa-libEGL-devel  | Development files for the EGL API                  | package
    i+ | Mesa-libEGL1       | EGL API implementation                             | package
    i+ | Mesa-libGL-devel   | GL/GLX development files of the OpenGL API         | package
    i+ | Mesa-libGL1        | The GL/GLX runtime of the Mesa 3D graphics library | package
    i+ | Mesa-libGLESv1_CM1 | OpenGL|ES 1.x Common Profile API implementation    | package
    i+ | Mesa-libGLESv2-2   | OpenGL|ES 2.x API implementation                   | package
    i+ | Mesa-libglapi0     | Free implementation of the GL API                  | package
    i+ | Mesa-libva         | Mesa VA-API implementation                         | package
     >

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •