Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Unicode Key (Ctrl-Shift-U) Feature Not Working in KDE Environment

  1. #1
    Join Date
    Feb 2010
    Location
    South Dakota, USA
    Posts
    171

    Question Unicode Key (Ctrl-Shift-U) Feature Not Working in KDE Environment

    The long avaiable feature of pressing Ctrl-Shift-U to key in Unicode Characters is no longer working, on the Web Browser, and LibreOffice (of course, it never worked in KATE/KWRITE). So far, I've been in the icewm desktop, and it didn't work, and now I'm in the Plasma desktop, and it doesn't work. This happened to me in the past after I upgraded from openSUSE 42.3 to 15.0, and I posted about it, but somehow (perhaps from some help from else, don't remember), I got it to working, but I don't remember how I got it working again.

    To enter the RIGHTWARDS WHITE ARROW, "⇨", Kcharselect reads "U+21E8". So I would press CTRL-SHIFT+U simultaneously, and hold those keys down, while entering 21E8, then the "⇨" symbol would enter in the text area / text box, like Facebook or here. (none of these of course, has ever worked in KWRITE or KATE, but in another distro, I worked for those 2 programs).

    It works in the Gnome Desktop Environment, but the issue the Middle Mouse Click for COPY & PASTE doesn't work from LIbreOffice bugs me, albeit, the extra steps needed are not all the troublesome. I was just accustomed to it.

    Thanks in advance!

  2. #2
    Join Date
    Feb 2010
    Location
    South Dakota, USA
    Posts
    171

    Default Re: Unicode Key (Ctrl-Shift-U) Feature Not Working in KDE Environment

    Internet Searches are not helping. :-(

  3. #3
    Join Date
    Feb 2010
    Location
    South Dakota, USA
    Posts
    171

    Default Re: Unicode Key (Ctrl-Shift-U) Feature Not Working in KDE Environment

    Anybody know how to fix this?

  4. #4

    Default Re: Unicode Key (Ctrl-Shift-U) Feature Not Working in KDE Environment

    For KDE: System Settings→Input hardware (or method)→Keyboard→[Advanced] - «Compose key position» - check «Right Alt» or what you need.

    Then hit newly defined «Compose key» then o then r (without holding them): ®
    «Compose key» then - then >: →
    «Compose key» then > then =: ≥
    «Compose key» then = then >: ⇒

    Not exactly what you wrote but very similar.
    It works in Kate too.
    See keys and signs in /usr/share/X11/locale/en_US.UTF-8/Compose or https://www.x.org/releases/X11R7.7/d..._US.UTF-8.html
    More in https://habr.com/ru/post/80091/ in russian.

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,476

    Default Re: Unicode Key (Ctrl-Shift-U) Feature Not Working in KDE Environment

    @Star_Gazer:

    Take a look in KDE “System Settings” –> sub-section Hardware “Input Devices” –> “Keyboard” –> “Layouts” tab –> “Configure Layouts”:
    • Select (click on it) the keyboard layout and then click the “Preview” button.

    A keyboard map will be displayed which may, for your country and your keyboard layout, indicate which “alternative alt” (the right hand Alt key) combination possibly satisfies your needs.

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,855

    Default Re: Unicode Key (Ctrl-Shift-U) Feature Not Working in KDE Environment

    Quote Originally Posted by Star_Gazer View Post
    Anybody know how to fix this?
    Please don not shout. People are looking to your thread. They are all over the world and need sleep also. When they have no idea, they won't answer. Shouting does only shy away people from answering. Do you go and try to help someone who is shouting at you?

    Be glad that nobody shouts at you because you forgot/did not take notes about the solution you found.

    BTW, like in your earlier thread I realy wonder how one can do like you "I would press CTRL-SHIFT+U simultaneously, and hold those keys down, while entering 21E8". How many hands/fingers do you have?
    Last edited by hcvv; 26-Jun-2019 at 02:22.
    Henk van Velden

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,354
    Blog Entries
    3

    Default Re: Unicode Key (Ctrl-Shift-U) Feature Not Working in KDE Environment

    Quote Originally Posted by hcvv View Post
    BTW, like in your earlier thread I realy wonder how one can do like you "I would press CTRL-SHIFT+U simultaneously, and hold those keys down, while entering 21E8". How many hands/fingers do you have?
    I did wonder about that.
    openSUSE Leap 15.1; KDE Plasma 5;

  8. #8
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,165

    Default Re: Unicode Key (Ctrl-Shift-U) Feature Not Working in KDE Environment

    Quote Originally Posted by nrickert View Post
    I did wonder about that.
    After pressing CTRL-SHIFT-U an underlined u appears, at that point you can release those keys and then enter the Unicode symbol's hex code followed by a space.

    Doesn't work in KDE though.

    Works in firefox, indeed that's how I entered the following character ‱ (hex code 2031)
    Regards, Paul

    Tumbleweed (Snapshot: 20190814) KDE Plasma 5 ~~~
    Non-Tumbling Tumblweed (20150508) KDE 4 - Resurrected
    Leap 15.0 KDE Plasma 5 ~~~ Leap 15.1 KDE Plasma 5 (Work in progress...)

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,855

    Default Re: Unicode Key (Ctrl-Shift-U) Feature Not Working in KDE Environment

    Quote Originally Posted by tannington View Post
    After pressing CTRL-SHIFT-U an underlined u appears, at that point you can release those keys and then enter the Unicode symbol's hex code followed by a space.

    Doesn't work in KDE though.

    Works in firefox, indeed that's how I entered the following character ‱ (hex code 2031)
    And this is the OPs example: ⇨

    Indeed, that is managable (fingerable?)

    Nice, but basicaly I do not love those different applications (including desktops) that claim key combinations. Lately I had to find in KDE/Plasma a combination and to re-configure it because in conflicted with a web application (through FF). I am glad it wasn't one I use in KDE (did not even know it exists).
    Henk van Velden

  10. #10
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,476

    Exclamation Re: Unicode Key (Ctrl-Shift-U) Feature Not Working in KDE Environment

    There's a rather ancient KDE Bug Report which has been closed as «Resolved Upstream»: <https://bugs.kde.org/show_bug.cgi?id=103788> – “input of arbitrary unicode characters as defined in ISO 14755”.

    There's a StackExchange thread <https://superuser.com/questions/7476...racters-in-kde> with the following comment:
    Although in most common desktop environments Unicode symbols can be typed by holding the Alt key and pressing the numeric keypad plus sign then the Unicode value in hex, KDE users cannot use this method as KDE relegates responsibility for implementing this feature to Xorg, and Xorg relegates to Qt, and Qt relegates back to Xorg.
    In other words, a KDE Plasma user can only insert Unicode characters by either:
    1. Using KCharSelect.
    2. Setting up a Compose Key sequence …

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •