Results 1 to 5 of 5

Thread: Loss of ability to connect to Wireless after Software update and reboot

  1. #1

    Default Loss of ability to connect to Wireless after Software update and reboot

    After a recent software update 3 days ago, the connection routine to the wireless router is failing during the authentication of the WPA2 password. The router is fine, other systems can still connect using the WPA2 key. However the wpa supplicant log shows the following:

    1560974114.070337: wlan2: SME: Trying to authenticate with 01:23:45:67:89:ab (SSID='Growly_Badger' freq=2417 MHz)
    1560974114.097852: wlan2: Trying to associate with 01:23:45:67:89:ab (SSID='Growly_Badger' freq=2417 MHz)
    1560974114.105401: wlan2: Associated with 01:23:45:67:89:ab
    1560974114.105426: wlan2: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
    1560974114.153187: wlan2: WPA: Failed to set GTK to the driver (alg=2 keylen=32 keyidx=1)
    1560974114.153204: wlan2: RSN: Failed to configure GTK
    1560974114.163499: wlan2: CTRL-EVENT-DISCONNECTED bssid=01:23:45:67:89:ab reason=1 locally_generated=1
    1560974114.163529: wlan2: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="Growly_Badger" auth_failures=1 duration=10 reason=CONN_FAILED
    1560974114.175207: wlan2: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
    1560974125.550043: wlan2: CTRL-EVENT-SSID-REENABLED id=0 ssid="Growly_Badger"
    1560974125.550214: wlan2: SME: Trying to authenticate with 01:23:45:67:89:ab (SSID='Growly_Badger' freq=2417 MHz)
    1560974125.576074: wlan2: Trying to associate with 01:23:45:67:89:ab (SSID='Growly_Badger' freq=2417 MHz)
    1560974125.581516: wlan2: Associated with 01:23:45:67:89:ab
    1560974125.581541: wlan2: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
    1560974125.610731: wlan2: WPA: Failed to set GTK to the driver (alg=2 keylen=32 keyidx=1)
    1560974125.610748: wlan2: RSN: Failed to configure GTK
    1560974125.621047: wlan2: CTRL-EVENT-DISCONNECTED bssid=01:23:45:67:89:ab reason=1 locally_generated=1
    1560974125.621076: wlan2: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="Growly_Badger" auth_failures=2 duration=20 reason=CONN_FAILED
    1560974125.631411: wlan2: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
    1560974138.371062: wlan2: Reject scan trigger since one is already pending
    1560974337.504917: rfkill: WLAN soft blocked
    1560974337.605744: nl80211: deinit ifname=wlan2 disabled_11b_rates=0

    The problem appears to be WPA failing to set GTK to the driver and RSN failing to configure GTK. I checked inside the wpa_supplicant source code, there is only 1 place that this message occurs, but since I didn't write that code, I am not sure why the failure has occurred.

    Any ideas where to go next? The system connects just fine to any unsecured wireless router, but I would like to regain use under WPA2 encryption.

    P.S. MAC code and SSID changed above, because someone used the real one to locate me to within 1 ft location on the earth's surface...
    Last edited by randallrathbun; 20-Jun-2019 at 15:12. Reason: fxied SSID

  2. #2
    Join Date
    Sep 2012
    Posts
    5,034

    Default Re: Loss of ability to connect to Wireless after Software update and reboot

    Does previous kernel version (before update) work?

  3. #3
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,952

    Default AW: Loss of ability to connect to Wireless after Software update and reboot

    1560974337.504917: rfkill: WLAN soft blocked
    Maybe as root:
    Code:
    rfkill unblock all

  4. #4

    Default Re: Loss of ability to connect to Wireless after Software update and reboot

    Quote Originally Posted by arvidjaar View Post
    Does previous kernel version (before update) work?
    I suspect it probably does, but I leap-frogged the problem by upgrading to Leap 15.1 instead, and things started working again.

  5. #5

    Default Re: AW: Loss of ability to connect to Wireless after Software update and reboot

    Quote Originally Posted by Sauerland View Post
    Maybe as root:
    Code:
    rfkill unblock all
    That command has to be run to enable the Wifi to listen for RF connections, as you suggested. I cured my problem by upgrading to Leap 15.1 (but had to update 5,269 packages, which broke the auto update script, since it can only handle 5200 updates at once)

    Thanks for the comment.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •