Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Probleem: kan PySolFC wel installeren, maar niet opstarten.

  1. #1
    Join Date
    Nov 2009
    Location
    Groningen, NL
    Posts
    234

    Default Probleem: kan PySolFC wel installeren, maar niet opstarten.

    Op de tweede pc hier in huis draait Leap-42.3. Een van de veel gebruikte programma's daarop is PySolFC, een veelzijdig patience programma. Dit werkt probleemloos, net als op eerdere versies van Leap.
    Dus heb ik ,als voorbereiding op het upgraden van 42.3 naar 15.1, geprobeerd het op mijn eigen pc - met Leap-15.1 - aan de praat te krijgen. Daarvoor heb ik de openSuSE "games" repo opgehaald:
    Code:
    hws@koos151:~> zypper lr games
    Alias                  : http-download.opensuse.org-7aba1e92                                
    Naam                   : games                                                              
    URI                    : http://download.opensuse.org/repositories/games/openSUSE_Leap_15.1/
    Ingeschakeld           : Nee                                                                
    GPG-controle           : ----                                                               
    Prioriteit             : 99 (standaard prioriteit)                                          
    Automatisch vernieuwen : Aan                                                                
    Pakketten behouden     : Uit                                                                
    Type                   : rpm-md                                                             
    URI van GPG-sleutel    :                                                                    
    Padvoorvoegsel         :                                                                    
    Hoofdservice           :                                                                    
    Trefwoorden            : ---                                                                
    Info-pad van inst.bron : /etc/zypp/repos.d/http-download.opensuse.org-7aba1e92.repo         
    MD Cache-pad           : /var/cache/zypp/raw/http-download.opensuse.org-7aba1e92            
    hws@koos151:~>
    (Opmerking: ik heb, na het installeren, uit voorzorg de games repo uitgeschakeld.)

    Uit deze repo heb ik via Yast/Softwarebeheer het programma geïnstalleerd. Dit gaat snel en probleemloos.
    Maar bij het opstarten, bijv. via Alt-F2 of via het Plasma keuzemenu zie ik heeel kort iets op het scherm langsflitsen. Dus geen programmavenster.
    Vraag: hoe kan ik er achter komen wat er aan de hand is? Zou het misschien een Python gerelateerd probleem kunnen zijn?
    Hans Schreuder

  2. #2

    Default Re: Probleem: kan PySolFC wel installeren, maar niet opstarten.

    Ken het programma niet, en weet dus ook niet wat het probleem kan zijn...
    Maar als ik een probleem heb met een programma, start ik het altijd vanuit een terminal.
    Dat geeft meestal al wel de informatie over wat er mis gaat.

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,642
    Blog Entries
    14

    Default Re: Probleem: kan PySolFC wel installeren, maar niet opstarten.

    Quote Originally Posted by jansteen View Post
    Ken het programma niet, en weet dus ook niet wat het probleem kan zijn...
    Maar als ik een probleem heb met een programma, start ik het altijd vanuit een terminal.
    Dat geeft meestal al wel de informatie over wat er mis gaat.
    Da's de manier. En om te kunnen helpen zou 't fijn zijn als we de output die dat geeft te zien krijgen.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Nov 2009
    Location
    Groningen, NL
    Posts
    234

    Default Re: Probleem: kan PySolFC wel installeren, maar niet opstarten.

    Quote Originally Posted by Knurpht View Post
    Da's de manier. En om te kunnen helpen zou 't fijn zijn als we de output die dat geeft te zien krijgen.
    Dank voor de suggesties.
    Om verder te komen heb ik een desktop entry gemaakt (dwz. laten maken door Plasma5). Daarin staat:
    Code:
    [Desktop Entry]
    GenericName=PySolFC
    Name=PySol Fan Club Edition
    Exec=pysol.py
    Terminal=false
    Type=Application
    Categories=Game;CardGame;Game;
    Icon=PySolFC
    Hierna in de terminal "pysol.py" ingegeven en zie:
    Code:
    hws@koos151:~> pysol.py
    Traceback (most recent call last):
      File "/usr/bin/pysol.py", line 28, in <module>
        init()
      File "/usr/lib/python2.7/site-packages/pysollib/init.py", line 91, in init
        from six.moves import tkinter
    ImportError: No module named six.moves
    hws@koos151:~>
    Na wat zoeken heb ik de indruk gekregen dat six.moves nodig is om applicaties zowel onder Python2 als Python3 te kunnen uitvoeren. Maar ik weet niets van Python...
    Zijn er nog tips om verder te komen?

    Alvast dank!
    Hans Schreuder

  5. #5
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    147

    Default Re: Probleem: kan PySolFC wel installeren, maar niet opstarten.

    Ik dacht laat ik eens PySolFC installeren onder Tumbleweed:
    Code:
    > sudo zypper in PySolFC
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following 13 NEW packages are going to be installed:
      fluid-soundfont-gm fluid-soundfont-gs libportmidi0 libSDL_mixer-1_2-0 libSDL_ttf-2_0-0 PySolFC PySolFC-lang python2-olefile python2-Pillow python2-pygame
      python2-random2 python-tk timidity
    
    The following 3 recommended packages were automatically selected:
      fluid-soundfont-gm fluid-soundfont-gs timidity
    
    13 new packages to install.
    Daarna gestart:
    Code:
    > pysol
    pygame 1.9.6
    Hello from the pygame community. https://www.pygame.org/contribute.html
    Dus op één of andere manier is six.moves geïnstalleerd.
    Kan jij eens nakijken of je dezelfde packages hebt?

    Starten geeft wel:


  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,642
    Blog Entries
    14

    Default Re: Probleem: kan PySolFC wel installeren, maar niet opstarten.

    Eh, ik wil niet vervelend doen, maar PySol wordt niet echt onderhouden. 't Is python2 gebaseerd, en aangezien upstream python2 dood verklaard heeft, houdt de ondersteuning in TW ook binnenkort op. Je zult dus moeten uitvinden of PySol er oook al is in een python3 versie.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7
    Join Date
    Nov 2009
    Location
    Groningen, NL
    Posts
    234

    Default Re: Probleem: kan PySolFC wel installeren, maar niet opstarten.

    Quote Originally Posted by Knurpht View Post
    Eh, ik wil niet vervelend doen, maar PySol wordt niet echt onderhouden. 't Is python2 gebaseerd, en aangezien upstream python2 dood verklaard heeft, houdt de ondersteuning in TW ook binnenkort op. Je zult dus moeten uitvinden of PySol er oook al is in een python3 versie.
    Ja, ik vermoedde al dat python2 het probleem was.
    Ik vind het wel vreemd dat ik een pakket uit de openSuse games repo voor Leap-15.1 heb geïnstalleerd dat niet compleet blijkt te zijn.
    Inderdaad, nu maar op zoek naar een python3 versie.
    Het is wel opmerkelijk dat uit de reply van Marel bijkt dat het onder Tumbleweed wel goed gaat. (Afgezien van het ontbreken van de cardsets.)
    Dank voor je hulp.
    Hans Schreuder

  8. #8
    Join Date
    Nov 2009
    Location
    Groningen, NL
    Posts
    234

    Default Re: Probleem: kan PySolFC wel installeren, maar niet opstarten.

    Quote Originally Posted by marel View Post
    Ik dacht laat ik eens PySolFC installeren onder Tumbleweed:
    Code:
    > sudo zypper in PySolFC
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following 13 NEW packages are going to be installed:
      fluid-soundfont-gm fluid-soundfont-gs libportmidi0 libSDL_mixer-1_2-0 libSDL_ttf-2_0-0 PySolFC PySolFC-lang python2-olefile python2-Pillow python2-pygame
      python2-random2 python-tk timidity
    
    The following 3 recommended packages were automatically selected:
      fluid-soundfont-gm fluid-soundfont-gs timidity
    
    13 new packages to install.
    Daarna gestart:
    Code:
    > pysol
    pygame 1.9.6
    Hello from the pygame community. https://www.pygame.org/contribute.html
    Dus op één of andere manier is six.moves geïnstalleerd.
    Kan jij eens nakijken of je dezelfde packages hebt?

    Starten geeft wel:

    Het is wel verrassend dat het onder Tumbleweed wèl lijkt te lukken.
    (Het ontbreken van cardsets was ook al een probleem onder Leap-42.3 en dat heb ik toen opgelost door ze op te halen bij sourceforge: het zijn "maar" databestanden.)
    Maar om nou bij mijn huisgenoot Tumbleweed te installeren om PySolFC te kunnen gebruiken lijkt mij geen goed idee.

    Ik heb via YaST het volgende lijstje met "afhankelijkheden" gevonden.
    Vereist:
    /bin/sh
    python-base
    python-Pillow
    python-pygame
    /usr/bin/python
    python-random2
    python-tk
    rpmlib(CompressedFileNames) <= 3.0.4-1
    rpmlib(FileDigests) <= 4.6.0-1
    rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    rpmlib(PayloadIsXz) <= 5.2-1
    python(abi) = 2.7
    /bin/sh
    /bin/sh
    Ik mis hier het in jouw lijstje voorkomende "timidity". Daar ga ik nu maar eens naar op zoek.

    Dank voor je hulp!
    Hans Schreuder

  9. #9
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    147

    Default Re: Probleem: kan PySolFC wel installeren, maar niet opstarten.

    Quote Originally Posted by Knurpht View Post
    Eh, ik wil niet vervelend doen, maar PySol wordt niet echt onderhouden.
    Wat wel onderhouden lijkt te worden is PySolFC (PySol Fan Club edition) en die heb ik ook onder Tumbleweed geïnstalleerd. PySolFC lijkt wel nog actief onderhouden te worden, de laatste update was 4 maart dit jaar. Zag dat er ook pysol was maar die de eerste keer blijkbaar over het hoofd gezien.

    Is PySolFC ook beschikbaar onder Leap?

    Het probleem van ontbrekende cardsets is trouwens makkelijk op te lossen aan de hand van https://github.com/shlomif/PySolFC:

    Download "Big.rar" van https://sourceforge.net/projects/pys...atest/download
    Code:
    > unrar x ~/Downloads/Big.rar ~/.PySolFC/cardsets

  10. #10
    Join Date
    Nov 2009
    Location
    Groningen, NL
    Posts
    234

    Default Re: Probleem: kan PySolFC wel installeren, maar niet opstarten.

    Quote Originally Posted by marel View Post
    Wat wel onderhouden lijkt te worden is PySolFC (PySol Fan Club edition) en die heb ik ook onder Tumbleweed geïnstalleerd. PySolFC lijkt wel nog actief onderhouden te worden, de laatste update was 4 maart dit jaar. Zag dat er ook pysol was maar die de eerste keer blijkbaar over het hoofd gezien.

    Is PySolFC ook beschikbaar onder Leap?

    Het probleem van ontbrekende cardsets is trouwens makkelijk op te lossen aan de hand van https://github.com/shlomif/PySolFC:

    Download "Big.rar" van https://sourceforge.net/projects/pys...atest/download
    Code:
    > unrar x ~/Downloads/Big.rar ~/.PySolFC/cardsets
    Dank voor de suggestie. Maar het is nou net de PySolFC uit de games repo voor Leap15.5 waar ik mijn probleem mee heb.
    Wat de cardsets betreft: die heb ik al sinds een aantal jaren op de betreffende pc staan.

    Mijn conclusies van deze draad zijn:
    a) Dit gaat (voorlopig?) onder Leap niet lukken.
    b) Ik ga een vervanging/surrogaat zoeken.

    Dank aan de reageerders voor het meedenken!
    Hans Schreuder

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •