Results 1 to 10 of 10

Thread: Tumbleweed SSH "packet_write_wait: Connection to xx.xx.xx.30 port 22: Broken pipe"

  1. #1

    Default Tumbleweed SSH "packet_write_wait: Connection to xx.xx.xx.30 port 22: Broken pipe"

    Hi all,

    As the title suggest I am trying to connect to another target machine from terminal in tumbleweed using "ssh root@xx.xx.xx.30" with the broken pipe message after I enter the password. I am able to ping the device and even the system asked me to allow key fingerprint.

    Action taken:
    I made sure to enable ssh and open the firewall at installation time, I re-enable ssh services (shows active) and disable firewall for port 22 via terminal with the same result.

    I have no problem reaching the device with Leap 15 using "ssh root@xx", however, I need to use tumbleweed 32bit in order to use some personal software tools.

    Any ideas??? I have applied every related and applicable solution that I have found online with no luck.

    This is what I have in terminal
    Code:
    linux-wonp:~ # ping xx.xx.xx.30
    PING xx.xx.x.30 (xx.xx.x.30) 56(84) bytes of data.
    64 bytes from xx.xx.x.30: icmp_seq=1 ttl=128 time=41.3 ms
    64 bytes from xx.xx.x.30: icmp_seq=2 ttl=128 time=40.8 ms
    64 bytes from xx.xx.x.30: icmp_seq=3 ttl=128 time=43.2 ms
    64 bytes from xx.xx.x.30: icmp_seq=4 ttl=128 time=40.5 ms
    ^C
    --- xx.xx.x.30 ping statistics ---
    4 packets transmitted, 4 received, 0% packet loss, time 5011ms
    rtt min/avg/max/mdev = 40.515/41.745/43.165/0.970 ms
    
    linux-wonp:~ # ssh root@xx.xx.x.30
    The authenticity of host 'xx.xx.x.30 (xx.xx.x.30)' can't be established.
    ECDSA key fingerprint is SHA256:a2IyJUzPnlri0SUxlL4W81zlYrih5j2i8Q+wywUcWNY.
    Are you sure you want to continue connecting (yes/no)? yes
    Warning: Permanently added 'xx.xx.x.30' (ECDSA) to the list of known hosts.
    root@xx.xx.x.30's password: 
    packet_write_wait: Connection to xx.xx.x.30 port 22: Broken pipe
    When I enter "ssh -vvv root@xx.xx.xx.30" I do not see any apparent errors in the debug.

    I would really appreciate your help
    Best regards,
    Fred

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,583
    Blog Entries
    14

    Default Re: Tumbleweed SSH "packet_write_wait: Connection to xx.xx.xx.30 port 22: Broken pipe"

    Are either of the systems completely up to date? With 'zypper dup' ?

    FWIW, I always set
    Code:
    PermitRootLogin no
    in /etc/ssh/sshd_config, for security reasons.

    Did you try setting up a user and then access that user's account over ssh ?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Tumbleweed SSH "packet_write_wait: Connection to xx.xx.xx.30 port 22: Broken pipe"

    Quote Originally Posted by Knurpht View Post
    Are either of the systems completely up to date? With 'zypper dup' ?

    FWIW, I always set
    Code:
    PermitRootLogin no
    in /etc/ssh/sshd_config, for security reasons.

    Did you try setting up a user and then access that user's account over ssh ?
    Thank you for the reply.
    The target device I am trying to access it has root user enable and that is how I always access the device. In fact I am able to access the target device from Kubuntu 16.04 using terminal as well as using PuTTY in windows. Based on this I can conclude that the target device is not the problem but my tumbleweed.

    Do you think that the problem is because I am trying to login as root in the target device? and Tumbleweed does not like that as an ssh command? in Kubuntu I use
    Code:
    ssh root@xx.xx.xx.30
    and in PuTTy use the normal login procedure.

    Thanks

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,797

    Default AW: Tumbleweed SSH "packet_write_wait: Connection to xx.xx.xx.30 port 22: Broken pipe"

    Does this work:
    Code:
    ssh -o IPQoS="lowdelay throughput" user@host
    Then add it to the host section of the /etc/ssh/ssh_config:
    Code:
    Host *
        IPQoS lowdelay throughput
    https://bugzilla.opensuse.org/show_bug.cgi?id=1136402
    Last edited by Sauerland; 19-Jun-2019 at 12:05.

  5. #5

    Thumbs up Re: AW: Tumbleweed SSH "packet_write_wait: Connection to xx.xx.xx.30 port 22: Broken pipe"

    Quote Originally Posted by Sauerland View Post
    Does this work:
    Code:
    ssh -o IPQoS="lowdelay throughput" user@host
    Then add it to the host section of the /etc/ssh/ssh_config:
    Code:
    Host *
        IPQoS lowdelay throughput
    https://bugzilla.opensuse.org/show_bug.cgi?id=1136402
    WOW.... Thank you very much, this worked like charm.
    I forgot to mentioned that I am using VMware, in any case it seem that the problem is connected to VMware as well or am I interpreting the articles wrong? Anyway I really appreciate your time.

    Best regards,

    SOLVED!!!

  6. #6

    Default Re: AW: Tumbleweed SSH "packet_write_wait: Connection to xx.xx.xx.30 port 22: Broken pipe"

    But what is the reason to include that option? Why running from under VMware is so special?

    I experienced the same problem for a very long time. It started after an update about half-year ago. The only remedy at that time was to install Leap 15.0 under VMware. And that's what puzzled me since then - identical sshd_config, but ssh works only in Leap setup. If both Leap and Tumbleweed installed on real hardware (no VM) - no problem. It would be good to know what's causing this. In all mentioned cases the target machine where I was connecting to was on LAN and ping was the same for all setups (that is no problems with connection).

  7. #7
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,806
    Blog Entries
    1

    Default Re: AW: Tumbleweed SSH "packet_write_wait: Connection to xx.xx.xx.30 port 22: Broken pipe"

    Quote Originally Posted by bryga View Post
    But what is the reason to include that option? Why running from under VMware is so special?

    I experienced the same problem for a very long time. It started after an update about half-year ago. The only remedy at that time was to install Leap 15.0 under VMware. And that's what puzzled me since then - identical sshd_config, but ssh works only in Leap setup. If both Leap and Tumbleweed installed on real hardware (no VM) - no problem. It would be good to know what's causing this. In all mentioned cases the target machine where I was connecting to was on LAN and ping was the same for all setups (that is no problems with connection).
    I just added a comment to the bugzilla reference above describing the posted likely cause. Don't know if it's a problem specific to VMware products up until Dec 2018. VMware Workstation 15 was launched first months of 2019 which <might> have resolved the problem (uncertain).

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  8. #8

    Default Re: AW: Tumbleweed SSH "packet_write_wait: Connection to xx.xx.xx.30 port 22: Broken pipe"

    Quote Originally Posted by tsu2 View Post
    I just added a comment to the bugzilla reference above describing the posted likely cause. Don't know if it's a problem specific to VMware products up until Dec 2018. VMware Workstation 15 was launched first months of 2019 which <might> have resolved the problem (uncertain).

    TSU
    The whole VMware thing kept me wondering as well. Using Leap15 I had no problem with ssh services, however, I could not use this one as it only comes in 64bit and there are some tools that I use that work only in 32bit. In any case I have not upgraded my VMware, perhaps the fix is there as you suggested. Since my company paid for the full version license I will upgrade and try again the install with tumbleweed and report back.

  9. #9

    Default Re: AW: Tumbleweed SSH "packet_write_wait: Connection to xx.xx.xx.30 port 22: Broken pipe"

    I upgraded my VMware from Workstation 14 Pro to Workstation 15 Pro. And the problem with ssh is gone, no more "Broken pipe" messages in Tumbleweed.

  10. #10

    Thumbs up Re: AW: Tumbleweed SSH "packet_write_wait: Connection to xx.xx.xx.30 port 22: Broken pipe"

    Quote Originally Posted by bryga View Post
    I upgraded my VMware from Workstation 14 Pro to Workstation 15 Pro. And the problem with ssh is gone, no more "Broken pipe" messages in Tumbleweed.
    Thank you @Bryga, I will work on that upgrade

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •