Results 1 to 6 of 6

Thread: sudo stopped working | "Sorry, try again."

  1. #1

    Question sudo stopped working | "Sorry, try again."

    Hi,

    Somehow some weeks ago the sudo command stopped working for me, more specifically stopped to accept the correct root password

    Code:
    :~> sudo leafpad
    [sudo] password for root: 
    Sorry, try again.
    [sudo] password for root: 
    Sorry, try again.
    [sudo] password for root: 
    sudo: unable to send audit message: Operation not permitted
    sudo: PERM_ROOT: setresuid(0, -1, -1): Operation not permitted
    sudo: 3 incorrect password attempts


    Code:
    :~> sudo -V
    Sudo version 1.8.27
    Sudoers policy plugin version 1.8.27
    Sudoers file grammar version 46
    Sudoers I/O plugin version 1.8.27

    Does anyone have any idea what could be the issue and how could be fixed?

    Thank you in advance,

    atskler

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,038
    Blog Entries
    14

    Default Re: sudo stopped working | "Sorry, try again."

    Eh, this should have been fixed in the latest snapshots AFAIK. Please do
    Code:
    su -
    zypper dup
    reboot and see if the issue persists.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,874
    Blog Entries
    3

    Default Re: sudo stopped working | "Sorry, try again."

    Quote Originally Posted by atskler View Post
    Somehow some weeks ago the sudo command stopped working for me, more specifically stopped to accept the correct root password
    There's an open bug report on this (but 1133808). It appears to be due to changes in libgcrypt. Uninstalling pam_kwallet will probably fix the problem for you. (If you are then prompted for kwallet password, it should be the same as your login password).
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    May 2015
    Location
    Michigan/Florida
    Posts
    65

    Default Re: sudo stopped working | "Sorry, try again."

    what worked for me was using yast as root and restarting sudo. had to sign into the root login acct.

  5. #5

    Default Re: sudo stopped working | "Sorry, try again."

    Quote Originally Posted by Knurpht View Post
    Eh, this should have been fixed in the latest snapshots AFAIK. Please do
    Code:
    su -
    zypper dup
    reboot and see if the issue persists.
    Unfortunately it is not fixed, at least not for me in 20190614-0.

  6. #6

    Default Re: sudo stopped working | "Sorry, try again."

    Quote Originally Posted by nrickert View Post
    There's an open bug report on this (but 1133808). It appears to be due to changes in libgcrypt. Uninstalling pam_kwallet will probably fix the problem for you. (If you are then prompted for kwallet password, it should be the same as your login password).
    Thank you. This workaround works for me.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •