Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Missing Wayland Display Server

  1. #11
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,009
    Blog Entries
    1

    Default Re: Missing Wayland Display Server

    That checks out as expected. I'm running Leap, but my findings match Neil's findings. In short, it's not clear to me why you can't launch a Gnome Wayland session.
    openSUSE Leap 15.0; KDE Plasma 5

  2. #12
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,308
    Blog Entries
    15

    Default Re: Missing Wayland Display Server

    Hi
    I'm assuming the OP is running an nvidia gpu...?

    I pulled mine here (even running it with no opengl files) so only the intel gpu running and wayland is back...

    Code:
    loginctl 
    SESSION  UID USER     SEAT  TTY 
          1 1000 usernamel seat0 tty2
    
    1 sessions listed.
    loginctl show-session 1 -p Type
    Type=wayland
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #13
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,308
    Blog Entries
    15

    Default Re: Missing Wayland Display Server

    Quote Originally Posted by malcolmlewis View Post
    Hi
    I'm assuming the OP is running an nvidia gpu...?

    I pulled mine here (even running it with no opengl files) so only the intel gpu running and wayland is back...

    Code:
    loginctl 
    SESSION  UID USER     SEAT  TTY 
          1 1000 usernamel seat0 tty2
    
    1 sessions listed.
    loginctl show-session 1 -p Type
    Type=wayland
    Hi
    And I see this little snippet here: https://devtalk.nvidia.com/default/t...wayland-usage/

    Also add to the kernel boot options;
    Code:
    nvidia-drm.modeset=1
    Edit/usr/lib/udev/rules.d/61-gdm.rules and rem out the nvidia blacklist.
    Code:
    cat /usr/lib/udev/rules.d/61-gdm.rules
    
    # disable Wayland on Cirrus chipsets
    ATTR{vendor}=="0x1013", ATTR{device}=="0x00b8", ATTR{subsystem_vendor}=="0x1af4", ATTR{subsystem_device}=="0x1100", RUN+="/usr/lib/gdm/gdm-disable-wayland"
    # disable Wayland on Hi1710 chipsets
    ATTR{vendor}=="0x19e5", ATTR{device}=="0x1711", RUN+="/usr/lib/gdm/gdm-disable-wayland"
    # disable Wayland when using the proprietary nvidia driver
    DRIVER=="nvidia", RUN+="/usr/lib/gdm/gdm-disable-wayland"
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #14
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,308
    Blog Entries
    15

    Default Re: Missing Wayland Display Server

    Quote Originally Posted by malcolmlewis View Post
    Hi
    And I see this little snippet here: https://devtalk.nvidia.com/default/t...wayland-usage/

    Also add to the kernel boot options;
    Code:
    nvidia-drm.modeset=1
    Edit/usr/lib/udev/rules.d/61-gdm.rules and rem out the nvidia blacklist.
    Code:
    cat /usr/lib/udev/rules.d/61-gdm.rules
    
    # disable Wayland on Cirrus chipsets
    ATTR{vendor}=="0x1013", ATTR{device}=="0x00b8", ATTR{subsystem_vendor}=="0x1af4", ATTR{subsystem_device}=="0x1100", RUN+="/usr/lib/gdm/gdm-disable-wayland"
    # disable Wayland on Hi1710 chipsets
    ATTR{vendor}=="0x19e5", ATTR{device}=="0x1711", RUN+="/usr/lib/gdm/gdm-disable-wayland"
    # disable Wayland when using the proprietary nvidia driver
    DRIVER=="nvidia", RUN+="/usr/lib/gdm/gdm-disable-wayland"
    Hi
    So tested above and now have GNOME, GNOME Classic and GNOME on Xorg back in the gdm menu and can switch between both with the nvidia card running....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #15

    Exclamation Re: Missing Wayland Display Server

    I am using Bumblebee. What should I do to receive the login menu as usual.

  6. #16
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,308
    Blog Entries
    15

    Default Re: Missing Wayland Display Server

    Quote Originally Posted by john_neo View Post
    I am using Bumblebee. What should I do to receive the login menu as usual.
    Hi
    I would try the same.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •