Results 1 to 4 of 4

Thread: Clamav is not working on my system

  1. #1

    Default Clamav is not working on my system

    Dear All, Clamav is not working on my system (Leap 15.1 in text mode). Freshclam is working but clamav not. I have tried many things, reinstalled the software, but no success. It says:
    clamd.service - Clamav antivirus Deamon
    Loaded: loaded (/usr/lib/systemd/system/clamd.service; enabled; vendor preset: disabled)
    Active: failed (Result: timeout) since Sun 2019-06-16 20:58:45 CEST; 17h ago
    Process: 7351 ExecStart=/usr/sbin/clamd (code=killed, signal=TERM)
    srv1 clamd[7351]: clamd daemon 0.100.3 (OS: linux-gnu, ARCH: x86_64, CPU: x86_64)
    srv1 clamd[7351]: Running as user vscan (UID 65, GID 470)
    srv1 clamd[7351]: Log file size limited to 1048576 bytes.
    srv1 clamd[7351]: Reading databases from /var/lib/clamav
    srv1 clamd[7351]: Not loading PUA signatures.
    srv1 clamd[7351]: Bytecode: Security mode set to "TrustSigned".
    srv1 systemd[1]: clamd.service: Start operation timed out. Terminating.
    srv1 systemd[1]: Failed to start Clamav antivirus Deamon.
    srv1 systemd[1]: clamd.service: Unit entered failed state.
    srv1 systemd[1]: clamd.service: Failed with result 'timeout'.
    basic settings: /var/run/clamav 755 vsan.vscan
    Please advise, thanks.
    F.A.

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,130
    Blog Entries
    2

    Default Re: Clamav is not working on my system

    Looks like your clamav daemon didn't start on time for unknown reasons.
    Try starting manually with the following command
    Code:
    systemctl start clamd.service
    Also,
    So that your console output is more legible and separated from the normal text in your post, it's recommended to enclose your console output in CODE tags which are created automatically with the hash button in your Forums text editor.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: Clamav is not working on my system

    It does not working, the syslog reply:
    clamd.service: Unit entered failed state … failed with result ‘timeout’

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,130
    Blog Entries
    2

    Default Re: Clamav is not working on my system

    Quote Originally Posted by andras_ferenc View Post
    It does not working, the syslog reply:
    Maybe the timeout is too short, but maybe your system is still busy.

    Open a separate terminal console and run the following to display what is happening on your system in real time
    Code:
    journalctl -f
    Also, try to see whether your disk drive is thrashing (highly active), you can look at your drive indicator light (is it on all the time? flashing?), maybe you'll see something if you own another console window and run iotop.

    After the above console windows have been set up and running for a bit and your system is relatively inactive, then try starting your clamd service again.

    Also,
    it's preferred to post your complete console command and result in CODE tags (the button with the hash sign on it)

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •