Results 1 to 6 of 6

Thread: ASUS XG-C100C does not work on 15.1

  1. #1
    Join Date
    Jun 2019
    Posts
    2

    Default ASUS XG-C100C does not work on 15.1

    It seems, there are two versions of that card on the market.
    The older ones works without driver on 15.1.
    Under 15.0 I compiled the atlantic.ko without problems.

    But I am not able to get the newer ones to run under 15.1.
    15.1 recognizes that card, but no way to edit something, or get a link.

    When I try to compile the ASUS driver XG-C100C_v.5.0.1.6, I get errors:
    aq_compat.h:30:20: error: redefinition of ‘timer_setup’
    /usr/src/linux-4.12.14-lp151.28.4/include/linux/timer.h:175:20: note: previous definition of ‘timer_setup’ was here
    static inline void timer_setup(struct timer_list *timer,

    The same error happens, if I try to use the source of aquantia.

    Any ideas?

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,580
    Blog Entries
    14

    Default Re: ASUS XG-C100C does not work on 15.1

    Quote Originally Posted by bfk View Post
    It seems, there are two versions of that card on the market.
    The older ones works without driver on 15.1.
    Under 15.0 I compiled the atlantic.ko without problems.

    But I am not able to get the newer ones to run under 15.1.
    15.1 recognizes that card, but no way to edit something, or get a link.

    When I try to compile the ASUS driver XG-C100C_v.5.0.1.6, I get errors:
    aq_compat.h:30:20: error: redefinition of ‘timer_setup’
    /usr/src/linux-4.12.14-lp151.28.4/include/linux/timer.h:175:20: note: previous definition of ‘timer_setup’ was here
    static inline void timer_setup(struct timer_list *timer,

    The same error happens, if I try to use the source of aquantia.

    Any ideas?
    Hi, welcome !!!!

    What you could try is booting from a Tumbleweed live USB, and check whether TW's kernel supports the device ( IMO it should ). Once you've found that it indeed does, you can add the kernel repo and install the latest kernel.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,794

    Default AW: ASUS XG-C100C does not work on 15.1

    Please post:
    Code:
    /sbin/lspci -nnk | grep -iA3 net
    and
    Code:
    lsusb
    aq_compat.h:30:20: error: redefinition of ‘timer_setup’
    I think the driver has to patch to get them working with Leap 15.1.......

  4. #4
    Join Date
    Jun 2019
    Posts
    2

    Default Re: ASUS XG-C100C does not work on 15.1

    I tested with: openSUSE-Tumbleweed-KDE-Live-x86_64-Snapshot20190617-Media.iso
    Network with ASUS XG-C100C works perfect. No driver needed.
    Here are the outputs:

    Code:
    /sbin/lspci -nnk | grep -iA3 net
    01:00.0 Ethernet controller [0200]: Aquantia Corp. AQC107 NBase-T/IEEE 802.3bz Ethernet Controller [AQtion] [1d6a:07b1] (rev 02)
        Subsystem: ASUSTeK Computer Inc. Device [1043:8741]
        Kernel driver in use: atlantic
        Kernel modules: atlantic
    Code:
    lsusb
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 004: ID 0557:2213 ATEN International Co., Ltd CS682 2-Port USB 2.0 DVI KVM Switch
    Bus 001 Device 002: ID 0557:8021 ATEN International Co., Ltd Hub
    Bus 001 Device 005: ID 1516:8628 CompUSA Pen Drive
    Bus 001 Device 003: ID 0781:5151 SanDisk Corp. Cruzer Micro Flash Drive
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    How to get that driver on Tumbleweed to 15.1?
    Last edited by Sauerland; 20-Jun-2019 at 08:44.

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,794

    Default AW: ASUS XG-C100C does not work on 15.1

    Please use Code-Tags for the Terminal Output, it is the small # in the Editor.

    Your Ethernet Card is not inside the Leap 15.1 Kernel:
    Code:
    modprobeid 1d6a:07b1
    Kernelmodulname
    modinfo: ERROR: Module  not found.
    So you can add the kernel:stable Repo but:
    No extra drivers build for Leap 15.1 (f.e. broadcom-wl or nvidia from the Repo) will not work anymore.

    The driver you want to build has to patch to get them building on Leap 15.1.....

    PS:
    modprobeid is a script and not in any distribution.....

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,794

    Default AW: ASUS XG-C100C does not work on 15.1

    Download the driver from:
    https://www.aquantia.com/support/driver-download/
    Its the AQC107

    Unpack it.
    Unpack atlantic.tar.gz
    Goto the Linux directory.
    Change line 25 in aq_compat.h from:
    Code:
    #if LINUX_VERSION_CODE < KERNEL_VERSION(4, 14, 0)
    to
    Code:
    #if LINUX_VERSION_CODE < KERNEL_VERSION(4, 12, 0)
    Run in this directory as User:
    Code:
    make
    and than Point 5 and more in the README.txt of the driver.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •