Results 1 to 4 of 4

Thread: Tumbleweed # VERSION="20190607" appears to damage Skype video

  1. #1

    Default Tumbleweed # VERSION="20190607" appears to damage Skype video

    Greetings:

    I did a zypper dup this morning (12June2019) with 331 updates I think, and Skype video is now reminiscent of "Max Headroom" ... bizarre choppy video that goes back & forth in time in the frames.

    This effect occurs with my local camera, Logitech C910, whether I am connected to others or not, as well as the feed from the people I'm communicating with. When the video stream of any source starts, the image is filled with wild colors like a psychedelic test pattern, then the choppy video begins.

    I reverted to the previous version of Skype which worked fine this morning before the updates, and it made no difference.

    I ran guvcview, and the video was perfect on there. I tried a different USB camera and it behaved exactly the same way.

    From hwinfo --gfx: Device: pci 0x94c1 "RV610 [Radeon HD 2400 PRO/XT]

    glxgears runs smoothly. Youtubes are fine. Locally run videos are fine.

    Ideas for resolution or learning the cause of the problem very much appreciated. Thank you!

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,173
    Blog Entries
    3

    Default Re: Tumbleweed # VERSION="20190607" appears to damage Skype video

    You should also try booting with the previous kernel (should be a grub menu option), to see whether that makes a difference.
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3

    Default Re: Tumbleweed # VERSION="20190607" appears to damage Skype video

    Quote Originally Posted by nrickert View Post
    You should also try booting with the previous kernel (should be a grub menu option), to see whether that makes a difference.
    Thank you ... that was an excellent suggestion. My current kernel is 5.1.7-1, then I tried both 5.1.4-1 and 5.0.13-1, and have the same results.

    My depth of knowledge of the inner data flow for the USB webcams is quite limited but I'll try to do some research on this ... haven't been aware of any other posts about this ... a google search revealed this thread!

    I have started down the uvc troubleshooting path, but qv4l2 and guvcview show perfect results with both cameras, and Skype messes up with both cameras ... Skype identifies the cameras as uvc devices, so I thought Skype might use that technology for their system, but I don't know ... could just be a USB label for the capabilities of the cameras. I'll report as I get information and welcome troubleshooting advice *;O)

  4. #4

    Default Re: Tumbleweed # VERSION="20190607" appears to damage Skype video

    Quote Originally Posted by kingofthebears View Post
    Thank you ... that was an excellent suggestion. My current kernel is 5.1.7-1, then I tried both 5.1.4-1 and 5.0.13-1, and have the same results.

    My depth of knowledge of the inner data flow for the USB webcams is quite limited but I'll try to do some research on this ... haven't been aware of any other posts about this ... a google search revealed this thread!

    I have started down the uvc troubleshooting path, but qv4l2 and guvcview show perfect results with both cameras, and Skype messes up with both cameras ... Skype identifies the cameras as uvc devices, so I thought Skype might use that technology for their system, but I don't know ... could just be a USB label for the capabilities of the cameras. I'll report as I get information and welcome troubleshooting advice *;O)
    This problem was resolved with Tumbleweed VERSION="20190627" with the 5.1.10-1-default kernel, which was updated 6/29/19 late in the evening with other updates, of course. I did come up with a way to isolate the errant package but in the fast paced Tumbleweed world, it was fixed before I could find the cause! Thank you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •