I will first let you know that I have been documenting and writing some offline packages to make my computers to work on OpenSUSE, I make these available for some of my colleagues and students. I am an unofficial developer for my community.

Recently, my current institute subscribed to some software provided through EUROPRACTICE. This thread is about supporting the software Synopsys Sentarus TCAD. This software is officially not supported on OpenSUSE, but it is supported on some older versions RHEL and SLES, and with minor modifications I was able to get it to work.

As long as I will be using this software, I will be supporting it unofficially. I am starting the thread here for personal reference as well as for others.

0.As far as installation of TCAD. Microelectronics at EUROPRACTICE provides an easy installation package as well as instructions to use the installation script provided by Synopsys. Following these instructions, you can install the package without much problem. OpenSUSE is based on Red Hat, I use the RHEL package.

Now onto issues on OpenSUSE LEAP 15.0 KDE (tested on LEAP 42.3 KDE and LEAP 15.1 KDE as well). Starting with a problem and then the solution.

1. OpenSUSE does not have libcrypto.so.10
When you try to start Synopsys visual/process executables, you will get something like this

error while loading shared libraries: libcrypto.so.10: cannot open shared object file: No such file or directory
Upon a little bit of research, libcrypto.so.10 is actually identical to libcrypto.so.1.0.0 provided with libssl.so.1.0.0 unfortunately just following a symbolic link below doesn't work.

sudo ln -s /usr/lib64/libcrypto.so.1.0.0 /usr/lib64/libcrypto.so.10
and it will yield the following error messages:

/usr/lib64/libcrypto.so.10: version `libcrypto.so.10' not found (required by

version `ZLIB_1.2.9' not found (required by /usr/lib64/libpng16.so.16)
It seems that relabeling is inadequate, it really does need this specific package. In my case, since I have access to a server with RHEL6 and 7 installed I borrowed a compiled library.

This solved 1.

2. I was able to eliminate libz issue by providing a symbollic link to my system's libz.so.1 to the TCAD library packages.

mv /eda/synopsys/2018-19/RHELx86/SENTAURUS_2018.06-SP2/tcad/O-2018.06-SP2/linux64/lib/libz.so.1 /eda/synopsys/2018-19/RHELx86/SENTAURUS_2018.06-SP2/tcad/O-2018.06-SP2/linux64/lib/libz.so.1.back
ln -s /lib64/libz.so.1 /eda/synopsys/2018-19/RHELx86/SENTAURUS_2018.06-SP2/tcad/O-2018.06-SP2/linux64/lib/libz.so.1
This solved 2.

Lastly, the environmental variable to point at the license server is SNPSLMD_LICENSE_FILE instead of SNPS_LICENSE_FILE.