Results 1 to 2 of 2

Thread: Vulkan not working with NVIDIA GTX1050

  1. #1

    Default Vulkan not working with NVIDIA GTX1050

    Tried to install vulkan after installing the Nvidia Bumblebee drivers. First, I checked that the video card is detected using the following command:

    # lspci -nnk | grep -i vga -A3
    00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:591b] (rev 04)
    Subsystem: Acer Incorporated [ALI] Device [1025:118a]
    Kernel driver in use: i915
    Kernel modules: i915
    --
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] [10de:1c8d] (rev ff)
    Kernel modules: nouveau, nvidia_drm, nvidia
    02:00.0 Network controller [0280]: Intel Corporation Wireless 8265 / 8275 [8086:24fd] (rev 78)
    Subsystem: Intel Corporation Dual Band Wireless-AC 8265 [8086:0010]

    I followed the instructions from the following link to install Vulkan: https://linuxconfig.org/install-and-...ulkan-on-linux

    To verify the installation, I execute the command "vulkaninfo | less" and my video card seems not to be detected. The output is as follows:

    ===========
    VULKAN INFO
    ===========

    Vulkan API Version: 1.0.65

    ERROR: [loader] Code 0 : libVkICD_mock_icd.so: cannot open shared object file: No such file or directory
    ERROR: [loader] Code 0 : /usr/lib/nvidia/libGL.so.1: wrong ELF class: ELFCLASS32
    Instance Extensions:
    ====================
    Instance Extensions count = 13
    VK_KHR_display : extension revision 21
    VK_KHR_external_fence_capabilities : extension revision 1
    VK_KHR_external_memory_capabilities : extension revision 1
    VK_ank KHR_external_semaphore_capabilities: extension revision 1
    VK_KHR_get_physical_device_properties2: extension revision 1
    VK_KHR_get_surface_capabilities2 : extension revision 1
    VK_KHR_surface : extension revision 25
    VK_KHR_xcb_surface : extension revision 6
    VK_KHR_xlib_surface : extension revision 6
    VK_EXT_acquire_xlib_display : extension revision 1
    VK_EXT_debug_report : extension revision 9
    VK_EXT_direct_mode_display : extension revision 1
    VK_EXT_display_surface_counter : extension revision 1
    /home/abuild/rpmbuild/BUILD/Vulkan-LoaderAndValidationLayers-1.0.65.0/demos/vulkaninfo.c:2337: failed with VK_ERROR_INITIALIZATION_FAILED

    Any ideas on how to fix this problem? Thank you in advance for your assistance on this issue.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,114
    Blog Entries
    15

    Default Re: Vulkan not working with NVIDIA GTX1050

    Hi
    I would image you need to use optirun so it will use the nvidia gpu...

    Code:
    optirun vulkaninfo | less
    Suggest you also test with the other checks here https://en.opensuse.org/SDB:NVIDIA_Bumblebee
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •