Results 1 to 8 of 8

Thread: Problem with Firefox translations

  1. #1
    Join Date
    Oct 2014
    Location
    Montpezat (France)
    Posts
    26

    Default Problem with Firefox translations

    Hi,

    I just did a few fresh installations of Leap 15.1. Our systems here in France are in french. KDE and applications all show up in french as they should. Only Firefox seems to have a problem and displays its interface in english.

    Quick check:

    Code:
    [kikinovak@alphamule:~] $ rpm -qa | grep -i firefox
    MozillaFirefox-60.6.3-lp151.2.3.6.x86_64
    MozillaFirefox-branding-openSUSE-60-lp151.2.1.x86_64
    MozillaFirefox-translations-common-60.6.3-lp151.2.3.6.x86_64
    Translations are installed, so that's not the problem.

    Now let's have a peek in the plugins menu.



    Uh oh. Something seems to be very wrong here.

    Any suggestions ?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,504
    Blog Entries
    3

    Default Re: Problem with Firefox translations

    Apparently, something was broken in the most recent firefox update. There are open bug reports. I'm guessing that fixing this will be high priority.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Oct 2014
    Location
    Montpezat (France)
    Posts
    26

    Default Re: Problem with Firefox translations

    OK thanks for the heads up.

  4. #4
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,217

    Default Re: Problem with Firefox translations

    It's been fixed in 67.0.2 https://www.mozilla.org/en-US/firefo.../releasenotes/

    So I expect it will make it's way into the ESR release quite soon too.
    Regards, Paul

    Tumbleweed (Snapshot: 20190918) KDE Plasma 5
    Non-Tumbling Tumblweed (20150508) KDE 4 - Resurrected
    2x Leap 15.1 KDE Plasma 5

  5. #5
    Join Date
    Jun 2008
    Posts
    10

    Default Re: Problem with Firefox translations

    I have the same problem with English instead of Danish national language in the menubar with MozillaFirefox-60.6.3-lp151.2.3.6 installed .

    A fallback to MozillaFirefox-60.6.2-lp151.1.1 solved the problem.

    Mozilla explains the history and the new Language section here: https://blog.mozilla.org/l10n/2019/0...m-the-browser/

    Another option is to add Version Leap 15.1 Mozilla repository in YAST : http://download.opensuse.org/reposit...USE_Leap_15.1/

    and install version 67.0.2-lp151.2.1 . This will give you the new Language section and make life simpler in the future.

  6. #6

    Default Re: Problem with Firefox translations

    Same problem with italian ...

  7. #7
    Join Date
    Jun 2008
    Posts
    10

    Default Re: Problem with Firefox translations

    Today I applied the update to Firefox version 60.7.2-lp151.2.7.1 , and the problem with English only in menubar has disappeared.

  8. #8

    Unhappy Re: Problem with Firefox translations

    I don't know what is happening, but i'm facing the same error with Italian language packs. The same error is showing up with the Italian packs. Updating and even downgrading won't help me. On Windows, it won't show me any errors tho.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •