Results 1 to 8 of 8

Thread: Mouse lagging occasionally

  1. #1

    Default Mouse lagging occasionally

    Hi,
    I have this issue since 15.0, didn't dissappear after upgrade to 15.1. Occasionally, the mouse cursor starts to slow down, eventually even stops with no reasonable way to reproduce the behaviour (it happens with no system load but on 100% CPU and memory load mouse works perfectly).
    It is an USB wireless mouse.
    Thanks for help

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,922
    Blog Entries
    1

    Default Re: Mouse lagging occasionally

    This is likely a graphics-related issue rather than a problem with the mouse. As such some system and graphics details might help others advise further here...
    Code:
    inxi -SMGxx
    openSUSE Leap 15.0; KDE Plasma 5

  3. #3

    Default Re: Mouse lagging occasionally

    Quote Originally Posted by deano_ferrari View Post
    This is likely a graphics-related issue rather than a problem with the mouse. As such some system and graphics details might help others advise further here...
    Code:
    inxi -SMGxx
    Code:
    linux-051o:~ # inxi -SMGxx
    Resuming in non X mode: glxinfo not found. For package install advice run: inxi --recommends
    System:    Host: linux-051o Kernel: 4.12.14-lp151.28.4-default x86_64
               bits: 64 gcc: 7.4.0
               Console: tty 0 dm: sddm,sddm Distro: openSUSE Leap 15.1
    Machine:   Device: desktop Mobo: ASRock model: J4105-ITX serial: M80-BB002600908
               UEFI: American Megatrends v: P1.40 date: 08/06/2018
    Graphics:  Card: Intel Device 3185 bus-ID: 00:02.0 chip-ID: 8086:3185
               Display Server: X.org 1.20.3 drivers: modesetting (unloaded: fbdev,vesa)
               tty size: 88x32 Advanced Data: N/A for root

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,922
    Blog Entries
    1

    Default Re: Mouse lagging occasionally

    1) Something to check - are your mouse batteries ok?

    2) The posted output shows Intel graphics and the desktop is KDE? If so, try changing the compositor type...

    System Settings > Display and Monitor > Compositor > Rendering backend

    Once applied, check if this changes behaviour.
    openSUSE Leap 15.0; KDE Plasma 5

  5. #5

    Default Re: Mouse lagging occasionally

    Quote Originally Posted by deano_ferrari View Post
    1) Something to check - are your mouse batteries ok?

    2) The posted output shows Intel graphics and the desktop is KDE? If so, try changing the compositor type...

    System Settings > Display and Monitor > Compositor > Rendering backend

    Once applied, check if this changes behaviour.
    Thanks a lot, batteries were fine, changing compositor to XRender helped (btw is it still faster to use XRender than openGL as it was back in Qt4 times? ) so after a little bit of fiddling it was the Scale Method settings set to Accurate.
    Weird enough, on https://userbase.kde.org/Desktop_Effects_Performance it says that on Intel, Accurate should be disabled by default, all other options work just fine with all the Compositor backends. Should I file a bug for that?

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,922
    Blog Entries
    1

    Default Re: Mouse lagging occasionally

    Quote Originally Posted by samik4184 View Post
    Thanks a lot, batteries were fine, changing compositor to XRender helped (btw is it still faster to use XRender than openGL as it was back in Qt4 times? ) so after a little bit of fiddling it was the Scale Method settings set to Accurate.
    Glad to read of your progress here.
    Weird enough, on https://userbase.kde.org/Desktop_Effects_Performance it says that on Intel, Accurate should be disabled by default, all other options work just fine with all the Compositor backends. Should I file a bug for that?
    Yes, I guess there might be merit in doing that.
    openSUSE Leap 15.0; KDE Plasma 5

  7. #7
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,426

    Default Re: Mouse lagging occasionally

    Quote Originally Posted by samik4184 View Post
    Code:
    linux-051o:~ # inxi -SMGxx...
    Resuming in non X mode: glxinfo not found. For package install advice run: inxi --recommends...
    tty size: 88x32 Advanced Data: N/A for root
    When not run inxi after installing what it recommends, and not run from within X, the whole story isn't reported.

    8086:3185 is absent from http://pci-ids.ucw.cz. You might consider sharing there what it is you have (Gemini Lake?).
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  8. #8

    Default Re: Mouse lagging occasionally

    Quote Originally Posted by mrmazda View Post
    When not run inxi after installing what it recommends, and not run from within X, the whole story isn't reported.

    8086:3185 is absent from http://pci-ids.ucw.cz. You might consider sharing there what it is you have (Gemini Lake?).
    Guess it was the glxinfo missing. Now it looks more neat
    Code:
    linux-051o:~> inxi -SMGxx
    System:    Host: linux-051o Kernel: 4.12.14-lp151.28.4-default x86_64
               bits: 64 gcc: 7.4.0
               Desktop: KDE Plasma 5.12.8 (Qt 5.9.7) dm: sddm,sddm
               Distro: openSUSE Leap 15.1
    Machine:   Device: desktop Mobo: ASRock model: J4105-ITX serial: N/A
               UEFI: American Megatrends v: P1.40 date: 08/06/2018
    Graphics:  Card: Intel Device 3185 bus-ID: 00:02.0 chip-ID: 8086:3185
               Display Server: x11 (X.Org 1.20.3 )
               drivers: modesetting (unloaded: fbdev,vesa)
               Resolution: 1920x1080@60.00hz
               OpenGL: renderer: Mesa DRI Intel UHD Graphics 600 (Geminilake 2x6)
               version: 4.5 Mesa 18.3.2 (compat-v: 3.0) Direct Render: Yes

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •