Results 1 to 5 of 5

Thread: Makefile failed - Help Needed

  1. #1

    Default Makefile failed - Help Needed

    I am trying to install a program from an extracted tar.gz file running 42.3 on KDE desktop. I don't do this very often as you can tell.

    I am getting an error message and the build fails but I have no idea why. It might be I do not have the necessary devel files but am stuck.

    This is the message I get when the make fails:-

    Code:
    compilation terminated.
    Makefile:1028: recipe for target '../tmp/release/meshview.o' failed
    make[1]: *** [../tmp/release/meshview.o] Error 1
    make[1]: Leaving directory '/home/alastair/Downloads/fraqtive-0.4.8/fraqtive-0.4.8/src'
    Makefile:39: recipe for target 'sub-src-make_default' failed
    make: *** [sub-src-make_default] Error 2
    Grateful for some help please.
    Budge

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,519
    Blog Entries
    15

    Default Re: Makefile failed - Help Needed

    Quote Originally Posted by Budgie2 View Post
    I am trying to install a program from an extracted tar.gz file running 42.3 on KDE desktop. I don't do this very often as you can tell.

    I am getting an error message and the build fails but I have no idea why. It might be I do not have the necessary devel files but am stuck.

    This is the message I get when the make fails:-

    Code:
    compilation terminated.
    Makefile:1028: recipe for target '../tmp/release/meshview.o' failed
    make[1]: *** [../tmp/release/meshview.o] Error 1
    make[1]: Leaving directory '/home/alastair/Downloads/fraqtive-0.4.8/fraqtive-0.4.8/src'
    Makefile:39: recipe for target 'sub-src-make_default' failed
    make: *** [sub-src-make_default] Error 2
    Grateful for some help please.
    Budge
    Hi
    You need to really upload the whole make file log to say SUSE Paste as it doesn't show where the error is...

    It is available from the Education repository?
    https://build.opensuse.org/package/s...ation/fraqtive

    You do know even if it doesn't exist for a particular release of openSUSE, download the src rpm and use rpmbuild to rebuild it for your system also works

    You might also want to try mandelbalber?
    https://build.opensuse.org/package/s...l/mandelbulber
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Makefile failed - Help Needed

    Quote Originally Posted by malcolmlewis View Post
    Hi
    You need to really upload the whole make file log to say SUSE Paste as it doesn't show where the error is...

    It is available from the Education repository?
    https://build.opensuse.org/package/s...ation/fraqtive

    You do know even if it doesn't exist for a particular release of openSUSE, download the src rpm and use rpmbuild to rebuild it for your system also works

    You might also want to try mandelbalber?
    https://build.opensuse.org/package/s...l/mandelbulber
    Hi Malcolm,
    Many thanks. I took the easy option this time from the Education repo as you suggested.
    Will be looking at mandelbulber too. Do you have an interest in fractals?
    Just revisiting what I did 20 years ago. Modern graphics make it all so much better.
    Thanks again,
    Budge

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,519
    Blog Entries
    15

    Default Re: Makefile failed - Help Needed

    Quote Originally Posted by Budgie2 View Post
    Hi Malcolm,
    Many thanks. I took the easy option this time from the Education repo as you suggested.
    Will be looking at mandelbulber too. Do you have an interest in fractals?
    Just revisiting what I did 20 years ago. Modern graphics make it all so much better.
    Thanks again,
    Budge
    Hi
    Not really, from memory someone asked about it (back in 2011), so I packaged it up... oh and it is updated to the latest version 2.18-1
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,519
    Blog Entries
    15

    Default Re: Makefile failed - Help Needed

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Not really, from memory someone asked about it (back in 2011), so I packaged it up... oh and it is updated to the latest version 2.18-1
    Hi
    Ahh 2.11-1 is still there for Leap 42.3, the latest version won't build for that release...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •