Results 1 to 8 of 8

Thread: problem of Bumblebee

  1. #1

    Angry problem of Bumblebee

    Hello,

    I have installed my Nvidia driver following the suse online instructions. I installed the resource from the following link

    with the following steps:

    Code:
    > add the line "blacklist nouveau" to /etc/modprobe.d/50-blacklist.conf
    
    > mkinitrd
    
    > reboot system
    
    > zypper in powertop
    
    > zypper in bbswitch bumblebee dkms nvidia-bumblebee nvidia-bumblebee-32bit primus VirtualGL-devel  VirtualGL-32bit 
      > systemctl enable dkms
       > systemctl enable bumblebeed
    
     > usermod -A video your_user_name
        > usermod -A bumblebee your_user_name
    
    reboot system
    However, when Bumblebee appears to be active

    Code:
    /home/albert>  systemctl status bumblebeed
     bumblebeed.service - Bumblebee C Daemon
       Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor preset: disabled)
       Active: active (running) since Fri 2019-06-07 17:07:30 CEST; 15min ago
     Main PID: 1933 (bumblebeed)
        Tasks: 1 (limit: 4915)
       Memory: 440.0K
       CGroup: /system.slice/bumblebeed.service
               └─1933 /usr/sbin/bumblebeed
    



    but it always failed with the following messages for all related programs.

    Code:
    
    /home/albert>  optirun /home/alert/install/pymol/sch-1.8.6.2/pymol
    [  948.240823] [ERROR]Cannot access secondary GPU - error: Could not enable discrete graphics ca
    rd
    
    [  948.240931] [ERROR]Aborting because fallback start is disabled.
    
    
    here are more information

    Code:
    
    /home/albert> sudo systemctl status bumblebeed
     bumblebeed.service - Bumblebee C Daemon
       Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor preset: disabled)
       Active: active (running) since Fri 2019-06-07 17:07:30 CEST; 22min ago
     Main PID: 1933 (bumblebeed)
        Tasks: 1 (limit: 4915)
       Memory: 444.0K
       CGroup: /system.slice/bumblebeed.service
               └─1933 /usr/sbin/bumblebeed
    
    Jun 07 17:07:30 alpha systemd[1]: Started Bumblebee C Daemon.
    Jun 07 17:07:30 alpha bumblebeed[1933]: [    9.092217] [INFO]/usr/sbin/bumblebeed 3.2.1 started
    Jun 07 17:23:09 alpha bumblebeed[1933]: [  948.240704] [ERROR]Could not enable discrete graphic>
    
    /home/albert> sudo systemctl status dkms
     dkms.service - Dynamic Kernel Modules System
       Loaded: loaded (/usr/lib/systemd/system/dkms.service; enabled; vendor preset: disabled)
       Active: active (exited) since Fri 2019-06-07 17:07:30 CEST; 23min ago
     Main PID: 1083 (code=exited, status=0/SUCCESS)
        Tasks: 0 (limit: 4915)
       Memory: 0B
       CGroup: /system.slice/dkms.service
    
    Jun 07 17:07:28 alpha systemd[1]: Starting Dynamic Kernel Modules System...
    Jun 07 17:07:29 alpha dkms.systemd[1083]: modprobe: ERROR: could not insert 'nvidia_drm': No su>
    Jun 07 17:07:29 alpha dkms.systemd[1083]: modprobe: ERROR: could not insert 'nvidia': No such d>
    Jun 07 17:07:29 alpha dkms.systemd[1083]: modprobe: ERROR: could not insert 'nvidia_modeset': N>
    Jun 07 17:07:29 alpha dkms.systemd[1083]: modprobe: ERROR: could not insert 'nvidia_uvm': No su>
    Jun 07 17:07:30 alpha systemd[1]: Started Dynamic Kernel Modules System.
    
    

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,047
    Blog Entries
    3

    Default Re: problem of Bumblebee

    I don't use Bumblebee (nor Nvidia). But I noticed the following bug report:

    Bug 1137649 - No bbswitch-kmp-default package for kernel 5.1.7
    That's possibly related to your problem.
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,659

    Default Re: problem of Bumblebee

    Please follow _carefully_ the instructions you find here https://en.opensuse.org/SDB:NVIDIA_Bumblebee
    I don't know where your steps come from, but at least these are apparently wrong (unless there are copy/paste mistakes) since the "-A" option doesn't exist:
    Code:
    usermod -A video your_user_name
    usermod -A bumblebee your_user_name
    Please check if your username is actually in the "video" and "bumblebee" groups, maybe that is the problem.
    Also make sure that you have installed make gcc kernel-devel kernel-default-devel kernel-macros
    If not so, you are unable to build the needed nvidia kernel modules.
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  4. #4
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,659

    Default Re: problem of Bumblebee

    Quote Originally Posted by nrickert View Post
    I don't use Bumblebee (nor Nvidia). But I noticed the following bug report:

    Bug 1137649 - No bbswitch-kmp-default package for kernel 5.1.7
    That's possibly related to your problem.
    Hi Neil, I see the correct package here http://download.opensuse.org/reposit...117.x86_64.rpm
    so this is not the problem apparently.
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  5. #5

    Default Re: problem of Bumblebee

    Quote Originally Posted by OrsoBruno View Post
    Please follow _carefully_ the instructions you find here https://en.opensuse.org/SDB:NVIDIA_Bumblebee
    I don't know where your steps come from, but at least these are apparently wrong (unless there are copy/paste mistakes) since the "-A" option doesn't exist:
    Code:
    usermod -A video your_user_name
    usermod -A bumblebee your_user_name
    Please check if your username is actually in the "video" and "bumblebee" groups, maybe that is the problem.
    Also make sure that you have installed make gcc kernel-devel kernel-default-devel kernel-macros
    If not so, you are unable to build the needed nvidia kernel modules.

    I confirmed that my current user is in the groups of both video and bumblebee. I also checked all you mentioned tools that they have already installed.
    The problem is always there. I am stacking now.
    Code:
    > /usr/bin/thunderbird
    ^C
    /home/alpha> sudo zypper in make gcc kernel-devel kernel-default-devel kernel-macros
    [sudo] password for root:  
    Retrieving repository 'openSUSE-Tumbleweed-Non-Oss' metadata .............................[done]
    Building repository 'openSUSE-Tumbleweed-Non-Oss' cache ..................................[done]
    Retrieving repository 'openSUSE-Tumbleweed-Oss' metadata .................................[done]
    Building repository 'openSUSE-Tumbleweed-Oss' cache ......................................[done]
    Loading repository data...
    Reading installed packages...
    'gcc' is already installed.
    No update candidate for 'gcc-9-1.2.x86_64'. The highest available version is already installed.
    'make' is already installed.
    No update candidate for 'make-4.2.1-7.6.x86_64'. The highest available version is already instal
    led.
    'kernel-default-devel' is already installed.
    No update candidate for 'kernel-default-devel-5.1.7-1.1.x86_64'. The highest available version i
    s already installed.
    'kernel-devel' is already installed.
    No update candidate for 'kernel-devel-5.1.7-1.1.noarch'. The highest available version is alread
    y installed.
    'kernel-macros' is already installed.
    No update candidate for 'kernel-macros-5.1.7-1.1.noarch'. The highest available version is alrea
    dy installed.
    
    

  6. #6
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,659

    Default Re: problem of Bumblebee

    Sorry, I cannot help with instructions not coming from the openSUSE SDB and am not able to reproduce and debug a Tumbleweed / Bumblebee installation right now.
    Maybe dkms is not building the nvidia modules for whatever reason.
    I also notice that you installed powertop and the SDB reads:
    Optirun return "Cannot access secondary GPU"

    If when you run "optirun --status" or "optirun glxgears", it's returned an error like
    [ERROR]Cannot access secondary GPU - error: Could not enable discrete graphics card

    It could be due to the presence of one or more power management application (e.g. TLP, powertop). After you disable them, optirun should work.
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  7. #7

    Arrow Re: problem of Bumblebee

    Finally, I gave up Bumblee and turned to SUSE-Prime.

    Now it works perfectly by command line:

    prime-select nvidia



  8. #8

    Default Re: problem of Bumblebee

    Finally, I gave up Bumblee and turned to SUSE-Prime. The protocol is very easy as indicated in the official website.

    Now it works perfectly by command line:

    prime-select nvidia


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •