Results 1 to 2 of 2

Thread: Problem installing rpm because of uppercase vs lowercase

  1. #1

    Default Problem installing rpm because of uppercase vs lowercase

    I'm trying to install: remarkable a markdown editor that I prefer over the ReText available in the opensuse repository.

    https://remarkableapp.github.io/linux.html

    I downloaded the rpm but:
    Code:
    > sudo zypper in downloads/rpms/remarkable-1.87-1.rpm 
    [sudo] password for root: 
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: nothing provides python3-markdown needed by remarkable-1.87-1.noarch
     Solution 1: do not install remarkable-1.87-1.noarch
     Solution 2: break remarkable-1.87-1.noarch by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/c] (c): c
    
    
    > sudo zypper in python3-markdown
    Loading repository data...
    Reading installed packages...
    Package 'python3-markdown' not found.
    
    
    > sudo zypper se python3-markdown
    Loading repository data...
    Reading installed packages...
    
    S  | Name                  | Summary                             | Type   
    ---+-----------------------+-------------------------------------+--------
    i+ | python3-Markdown      | Python implementation of Markdown   | package
    i+ | python3-markdown-math | Math extension for Python-Markdown  | package
       | python3-markdown2     | A Python implementation of Markdown | package
    Is there a way of making the dependency: python3-markdown point to python3-Markdown, or make the rpm non-case sensitive?

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,796
    Blog Entries
    15

    Default Re: Problem installing rpm because of uppercase vs lowercase

    Quote Originally Posted by elfroggio View Post
    I'm trying to install: remarkable a markdown editor that I prefer over the ReText available in the opensuse repository.

    https://remarkableapp.github.io/linux.html

    I downloaded the rpm but:
    Code:
    > sudo zypper in downloads/rpms/remarkable-1.87-1.rpm 
    [sudo] password for root: 
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: nothing provides python3-markdown needed by remarkable-1.87-1.noarch
     Solution 1: do not install remarkable-1.87-1.noarch
     Solution 2: break remarkable-1.87-1.noarch by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/c] (c): c
    
    
    > sudo zypper in python3-markdown
    Loading repository data...
    Reading installed packages...
    Package 'python3-markdown' not found.
    
    
    > sudo zypper se python3-markdown
    Loading repository data...
    Reading installed packages...
    
    S  | Name                  | Summary                             | Type   
    ---+-----------------------+-------------------------------------+--------
    i+ | python3-Markdown      | Python implementation of Markdown   | package
    i+ | python3-markdown-math | Math extension for Python-Markdown  | package
       | python3-markdown2     | A Python implementation of Markdown | package
    Is there a way of making the dependency: python3-markdown point to python3-Markdown, or make the rpm non-case sensitive?

    Thanks
    Hi
    Not really, but since the files are installed in a lowercase directory (markdown), you should just ignore (select option 2) and install, the application should work fine.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •