Results 1 to 2 of 2

Thread: Can't login after updating leap 15.1

  1. #1

    Default Can't login after updating leap 15.1

    Hi Guys... So first off, I'm just a beginner here. If you can help me out then please explain to me what needs to be done.

    Anyhow, I installed Leap 15.1 just fine yesterday. After the install, I ran the command 'sudo zypper update.' I rebooted my machine and got the error 'fb: switching to nouveaufb from vesa vga.' I'm like what does this mean.

    Me being me, I decided okay perhaps bad install, lets wipe and try it again, so I did... only to know that after running update again, I run into the same issue.

    I did some research, and I think it has something to do with my graphics card.

    I have a NVIDIA Corporation GP107 [GeForce GTX 1050 Ti]

    I would like to be able to update the system in case there are any security patches or whatever. I have no clue what to do, but your support would be great.

    Thank you in advance.

  2. #2
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,766

    Default Re: Can't login after updating leap 15.1

    There have been filed at least three bugs about this, e.g. bug 1136978. 4.12.14-lp151.27-default prior kernel is OK for all NVidia card users, but latest update kernel 4.12.14-lp151.28.4-default is apparently broken for all NVidia users using either competent FOSS DDX (nouveau or modesetting) instead of proprietary NVidia drivers (and possibly Optimus configurations).

    Install either the 151.27 kernel or a proprietary NVidia driver and your problem should be solved. If the motherboard has onboard video, temporarily (until a newer update kernel is available) removing the NVidia card would also be a workaround. ETA for a newer update kernel has yet to be offered.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •