Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: opensuse leap 15.1 crashes on bootup

  1. #1

    Default opensuse leap 15.1 crashes on bootup

    OPENSUSE 15,1 DVD
    Checksum sha256 matches
    PGP key matches

    Motherboard: Gigabyte 970A-D3SP
    Hard drive 1tb

    set to clear all partitions
    Install DVD -- > settings --> boot to MBR - completes install. Boot freezes, will not continue.
    boot to partition - settings --> 'invalid boot partion'.

    All other boot options fail with one error or another type of error


    I did an update install to my laptop system. installer finished with error: read only system failed to write log file. I held down the power button to force a system shutdown, then I rebooted successfully to opensuse leap 15.1

    This will be the 4 reinstall of 'opensuse 15.1'. The only solution might be is do a full install of opensuse leap 15. Then do an update install of 'opensuse leap 15.1'

    Need help. If you need more info, ask me. Any solutions or other options welcome.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,001
    Blog Entries
    3

    Default Re: opensuse leap 15.1 crashes on bootup

    Quote Originally Posted by lord_valarian View Post
    boot to partition - settings --> 'invalid boot partion'.
    I have never seen that.

    By default, the openSUSE installer uses GPT partitioning. Is it possible that your BIOS is very fussy and does not like GPT partitioning?

    I guess I should also ask whether your BIOS is UEFI capable.
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3

    Default Re: opensuse leap 15.1 crashes on bootup

    Quote Originally Posted by nrickert View Post
    I have never seen that.

    By default, the openSUSE installer uses GPT partitioning. Is it possible that your BIOS is very fussy and does not like GPT partitioning?

    I guess I should also ask whether your BIOS is UEFI capable.

    opensuse 15 installed fine with no problems. It's not the hardware. There must be an installer bug.

    EFI motherboard works fine with windows 10.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,001
    Blog Entries
    3

    Default Re: opensuse leap 15.1 crashes on bootup

    I wonder whether it is related to the pmbr_boot flag.
    openSUSE Leap 15.1; KDE Plasma 5;

  5. #5

    Default Re: opensuse leap 15.1 crashes on bootup

    Hi there. I had also a lot of trouble installing Leap 15.1 this time (never had issues on the same System from 42 - 15.0).
    I was faced with an issue seems to be the same as the described in this thread.
    First i did a clean install keeping the home partition. Installation run threw successful. After that I tried to boot. -> After GRUB: Black screen (not even a Prompt).
    After that I tried the Installation again overwriting all partitions. -> Same Issue.
    Next step was changing the answer in the final dialogue about the nouveau grafik drivers and issues with that. -> Same Issue.
    I really was confused. Booting in UEFI had this issue, booting legacy had the 'invalid/no boot partition' issue.

    Finally I changed the default graphics adapter in the bios to the mainboard build in and changed and plugged the monitor there. Leap was booting now fine (i don't know if it did all the time, but i did not notice).
    Then I installed the NVIDIA driver. Switched back in BIOS and plugged the monitor to the NVIDIA card. Now everything works.

    I think this is not intended to have to be done.

    About the System: INTEL i7-7700k
    NVIDIA GTX 1070
    GYGABYTE Z270 Mainboard (need to check that again)

  6. #6

    Default Re: opensuse leap 15.1 crashes on bootup

    Quote Originally Posted by fridlmue View Post
    Hi there. I had also a lot of trouble installing Leap 15.1 this time (never had issues on the same System from 42 - 15.0).
    I was faced with an issue seems to be the same as the described in this thread.
    First i did a clean install keeping the home partition. Installation run threw successful. After that I tried to boot. -> After GRUB: Black screen (not even a Prompt).
    After that I tried the Installation again overwriting all partitions. -> Same Issue.
    Next step was changing the answer in the final dialogue about the nouveau grafik drivers and issues with that. -> Same Issue.
    I really was confused. Booting in UEFI had this issue, booting legacy had the 'invalid/no boot partition' issue.

    Finally I changed the default graphics adapter in the bios to the mainboard build in and changed and plugged the monitor there. Leap was booting now fine (i don't know if it did all the time, but i did not notice).
    Then I installed the NVIDIA driver. Switched back in BIOS and plugged the monitor to the NVIDIA card. Now everything works.

    I think this is not intended to have to be done.

    About the System: INTEL i7-7700k
    NVIDIA GTX 1070
    GYGABYTE Z270 Mainboard (need to check that again)
    This motherboard has a builtin sound card, but no builtin video card. I have an nvidia video pci-express card. So, I plug in the nvidia 210 I have? Then attempt a reinstall.

  7. #7

    Default Re: opensuse leap 15.1 crashes on bootup

    Quote Originally Posted by lord_valarian View Post
    This motherboard has a builtin sound card, but no builtin video card. I have an nvidia video pci-express card. So, I plug in the nvidia 210 I have? Then attempt a reinstall.
    Is the GRUB displayed before you end up with a black screen? If not, it could be a totally different issue and all my ideas are not worth reading.

    TBH i really struggled on this issue the last two days myself. So I'm really not an exert... I think in my case it was a issue with the GPU driver, perhaps it is an issue with the GIGABYTE boards in combination with current NVIDIA GPUs. But those are all guesses.

    The NVIDIA 210 is not the GPU that is currently installed? So it could be worth to try to change the GPU for one boot cycle. I think there should be no need to reinstall Leap. Possibly it is sufficient to change the card until you installed the NVIDIA driver.
    But for sure there is a parameter to boot leap from grub in a text only mode that should work anyhow and install the NVIDIA driver by using the terminal. But, sorry for that, I can't guide you there because i never did.

  8. #8
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,409

    Default Re: opensuse leap 15.1 crashes on bootup

    Quote Originally Posted by lord_valarian View Post
    So, I plug in the nvidia 210 I have? Then attempt a reinstall.
    Would that be a GeForce 210? I have one, works fine with 42.3, 15.0, 15.1 & TW - except with latest 15.1 kernel 4.12.14-lp151.28.4, which is broken for use with (apparently all) NVidia cards with both FOSS DDX (nouveau and modesetting). 4.12.14-lp151.27.3 works fine. There are at least 3 open bugs about broken lp151.28.4. The kernel devs seem to be on vacation since lp151.28.4 hit the mirrors.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  9. #9

    Default Re: opensuse leap 15.1 crashes on bootup

    Quote Originally Posted by fridlmue View Post
    Is the GRUB displayed before you end up with a black screen? If not, it could be a totally different issue and all my ideas are not worth reading.

    TBH i really struggled on this issue the last two days myself. So I'm really not an exert... I think in my case it was a issue with the GPU driver, perhaps it is an issue with the GIGABYTE boards in combination with current NVIDIA GPUs. But those are all guesses.

    The NVIDIA 210 is not the GPU that is currently installed? So it could be worth to try to change the GPU for one boot cycle. I think there should be no need to reinstall Leap. Possibly it is sufficient to change the card until you installed the NVIDIA driver.
    But for sure there is a parameter to boot leap from grub in a text only mode that should work anyhow and install the NVIDIA driver by using the terminal. But, sorry for that, I can't guide you there because i never did.
    No, high level nvidia card installed. I'll try the nvidia 210, doing a full opensuse leap 15.1 Then power down. Install the other nvidia hardware. Then boot. I'll try that.

  10. #10

    Default Re: opensuse leap 15.1 crashes on bootup

    Quote Originally Posted by nrickert View Post
    I wonder whether it is related to the pmbr_boot flag.
    You mean the partition boot flag? I used gparted to check for that.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •