Results 1 to 5 of 5

Thread: Plasma freezes, but Firefox doesn't

  1. #1

    Default Plasma freezes, but Firefox doesn't

    This is an ongoing problem. Plasma is locked up. I cannot change to other desktops or access applications that are active. Mouse and keyboard are fine. Firefox is still working. I can't change to another Firefox window using the application bar at the bottom of my display, but I can launch and use new Firefox windows. The application bar does not show the new Firefox window. This happens several times a day and only a hard reboot fixes it. Where would I begin looking for error messages?

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,293
    Blog Entries
    2

    Default Re: Plasma freezes, but Firefox doesn't

    Try running top, htop or some other top incarnation to view available system resources.
    Although embedded in top, you can run free separately, I wrote an article how to read the info and if your freezes co-incide with massively changing your workload, I describe a command which can come close to resetting your memory without actually rebooting.
    https://en.opensuse.org/User:Tsu2/free_tool

    Also,
    Look for things that can suggest "system busy" like file indexing.
    You can look at the disk activity indicator light on your machine to see if your hard drive is thrashing.
    If you determine your problems might be related to disk activity, then you can run iotop to view what is accessing your disks.
    You can leave open a terminal console on your machine that displays your system events in real time, just run the following command
    Code:
    journalctl -f
    Good luck,
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: Plasma freezes, but Firefox doesn't

    Quote Originally Posted by tsu2 View Post
    Try running top, htop or some other top incarnation to view available system resources.
    Although embedded in top, you can run free separately, I wrote an article how to read the info and if your freezes co-incide with massively changing your workload, I describe a command which can come close to resetting your memory without actually rebooting.
    https://en.opensuse.org/User:Tsu2/free_tool

    Also,
    Look for things that can suggest "system busy" like file indexing.
    You can look at the disk activity indicator light on your machine to see if your hard drive is thrashing.
    If you determine your problems might be related to disk activity, then you can run iotop to view what is accessing your disks.
    You can leave open a terminal console on your machine that displays your system events in real time, just run the following command
    Code:
    journalctl -f
    Good luck,
    TSU

    I've tried top/journalctl, got psensor running. There is no consistency. It's not workload dependent, memory dependent, disk access dependent. Every hang is different in journalctl. It's just crazy that Firefox continues working when everything else is locked up. I thought at one point it was chrome, as it is both a memory and cpu hog, but removing it made no difference.

  4. #4
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,265

    Default Re: Plasma freezes, but Firefox doesn't

    So... does Firefox cause the Plasma freeze, or is something else causing the freeze and it's just coincidental that Firefox keeps running.

    If Firefox is the cause, does it still happen if you start Firefox in "safe-mode" (Menu -> Help -> Restart Firefox with Add-ons Disabled)
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191016) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  5. #5

    Default Re: Plasma freezes, but Firefox doesn't

    Firefox wasn't the problem. Apparently the btrfs quota function is. I never saw high cpu utilization, which is considered the problem. But, it is easy to disable: btrfs quota disable / . The problem was supposed to be fixed in kernel 5.1, but maybe 5.2. I don't do kernel programming, so I'm happy to have a work-around. As far as I can tell, there is no reason to run quota on a single-user system.

    This can be closed.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •