Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: kontact / kmail very slow

  1. #1
    Join Date
    Aug 2008
    Location
    London, UK
    Posts
    168

    Question kontact / kmail very slow

    Over the past 6 months or so, kmail has become progressively more and more slow. It now takes 5 minutes to retrieve folder contents for the inbox, and a similar time to retrieve an email.

    Before I move to another mail client, can someone advise how I can:

    1. save the mail account configurations (I have 8)
    2. save the current emails downloaded (I use pop3)
    3. wipe kcontact, akonadi and all its files
    4. reinstall kontact and its dependencies
    5. restore from 1 & 2 to have a shiny new, fully populated install.

    I should add that I've been running opensuse for more than 10 years, and have upgraded to new releases rather than reinstall. I suspect there's a lot of cruft.

    ... or, is there a better way or other things I should check / fix before blasting the install?

    Thanks
    David

  2. #2
    Join Date
    Aug 2008
    Location
    London, UK
    Posts
    168

    Default Re: kontact / kmail very slow

    I've just checked, and .local/share/akonadi/search_db is 0.9GB and .local/share/akonadi/file_db_data is 7.2GB. Would this affect the speed?

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,662
    Blog Entries
    14

    Default Re: kontact / kmail very slow

    That is really huge for the akonadi database. Mine in total is ~3.1GB, this for ~200.000 emails. But, what you can do is switch to using postgresql instead of mysql. In my experience ( and that of others ) it's much faster. Instructions for doing so are easily found on docs.kde.org
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Aug 2008
    Location
    London, UK
    Posts
    168

    Default Re: kontact / kmail very slow

    Quote Originally Posted by Knurpht View Post
    Instructions for doing so are easily found on docs.kde.org
    Thanks. I think I've done this right ... it's certainly a lot faster on the initial startup (waiting for the database to populate).
    Unfortunately, I couldn't find the docs you mentioned, although I spent an hour searching.
    The best I found are https://vinzv.de/en/bringing-kmail-a...esql-together/ and https://wandrey-cht.blogspot.com/201...l-backend.html and https://www.enricozini.org/blog/2015/akonadi-install/ , which aren't consistent.

    I got a couple of crashes for akonadiserver during the startup ... but the server seems to restart and continue ...

    My .config/akonadi/akonadiserverrc is:
    Code:
    [Debug]
    Tracer=null
    
    [%General]
    Driver=QPSQL
    
    [QPSQL]
    Host=/tmp/akonadi-david.hash
    InitDbPath=/usr/bin/initdb
    Name=akonadi
    Options=
    ServerPath=/usr/bin/pg_ctl
    StartServer=true
    User=david
    Can you tell me if this is correct or do I need to change something to avoid the akonadiserver crashes?

    Thanks
    David

  5. #5
    Join Date
    Aug 2008
    Location
    London, UK
    Posts
    168

    Default Re: kontact / kmail very slow

    Hmmm ... I've added a password to the postgres user and akonadiserverc, as I was getting 'Pass a valid window to KWallet::Wallet:penWallet().' as part of the output from akonadictl start ... and I'm still getting the same output.

    akonadiserver seems to be running. Safe to ignore?

  6. #6
    Join Date
    Aug 2008
    Location
    London, UK
    Posts
    168

    Default Re: kontact / kmail very slow

    Quote Originally Posted by jetojedno View Post
    I've added a password to the postgres user and akonadiserverc,
    for anyone finding this later ... postgres requires single quotes when setting the password, and aknoadiserverc no quotes.

  7. #7
    Join Date
    Aug 2008
    Location
    London, UK
    Posts
    168

    Default Re: kontact / kmail very slow

    and here's the best doc I can find for the akonadiserverrc for postgres: http://metadata.ftp-master.debian.or..._README.Debian

  8. #8
    Join Date
    Aug 2008
    Location
    London, UK
    Posts
    168

    Thumbs up Re: kontact / kmail very slow

    For others' reference, the akonadiserverrc which seems to be working best for me is:
    Code:
    [Debug]
    Tracer=null
    
    [%General]
    Driver=QPSQL
    
    [QPSQL]
    Host=
    InitDbPath=/usr/bin/initdb
    Name=akonadi-david
    Options=
    Password=****
    ServerPath=/usr/bin/pg_ctl
    StartServer=false
    User=david

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,478

    Smile Re: kontact / kmail very slow

    Quote Originally Posted by jetojedno View Post
    Unfortunately, I couldn't find the docs you mentioned, although I spent an hour searching.
    It's here: <https://userbase.kde.org/Akonadi/Postgres_update> – last update: 15 March 2019, at 11:44.


    • Found it in about 2 s with DuckDuckGo and the following search string: “KDE akonadi postgresql”.

  10. #10
    Join Date
    Aug 2008
    Location
    London, UK
    Posts
    168

    Default Re: kontact / kmail very slow

    Quote Originally Posted by dcurtisfra View Post
    It's here: <https://userbase.kde.org/Akonadi/Postgres_update> – last update: 15 March 2019, at 11:44.
    Thanks. I found that. It looks, to me, to be instructions about how to upgrade the postgres database from one version to the next, rather than to transfer from mysql to postgres, but I could be wrong.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •