Results 1 to 10 of 10

Thread: Issue with flatpak

  1. #1

    Exclamation Issue with flatpak

    After update of packages from flathub, I received an issue with follow text :


    Warning: Failed to get revokefs-fuse socket from system-helper: User flatpak does not exist in password file entry

    How can I fix it?

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,300
    Blog Entries
    2

    Default Re: Issue with flatpak

    Did you only update available packages or did you update flatpak itself?

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Exclamation Re: Issue with flatpak

    I am running this command :

    $ flatpak update

    and the result is :

    Warning: Failed to get revokefs-fuse socket from system-helper: User flatpak does not exist in password file entry

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,639
    Blog Entries
    3

    Default Re: Issue with flatpak

    Quote Originally Posted by john_neo View Post
    I am running this command :

    $ flatpak update

    and the result is :

    Warning: Failed to get revokefs-fuse socket from system-helper: User flatpak does not exist in password file entry
    This probably needs a bug report.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5

    Exclamation Re: Issue with flatpak

    Should I make this bug report and how should I do it?

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,639
    Blog Entries
    3

    Default Re: Issue with flatpak

    Quote Originally Posted by john_neo View Post
    Should I make this bug report and how should I do it?
    That's how the message gets back to the developer team. It looks as if they missed a dependency.

    You can post a bug report here: openSUSE:Submitting bug reports.

    If it asks you to login, then the same login/password that you use for the forums should work. But you might already be logged into the bugzilla by virtue of being logged into the forums.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  7. #7

    Exclamation Re: Issue with flatpak

    I made a ticket in the OpenSuse BugZilla site with follow url :



    https://bugzilla.opensuse.org/show_bug.cgi?id=1137537

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,639
    Blog Entries
    3

    Default Re: Issue with flatpak

    Thanks for posting that bug report link.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  9. #9

    Default Re: Issue with flatpak

    Just wanted to mention that the solution posted at the bottom of the ticket by Fabian worked for me. Pasting it below to save someone else the time of hunting it down.

    Not a flatpak dev, so cant provide clarification on why it happens.
    However the error occurs when using flatpak with the --system flag.
    Check that by "flatpak remotes" and see if the option says "system".
    To fix it delete the flathub remote "flatpak remote-delete flathub" and add it with the --user flag "flatpak remote-add --user --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo".
    I assume you previously also had to provide a root password when using flatpak. That'll be gone too.
    I don't know how to reinstall all apps as --user though. It would be awesome if anyone could clarify that!

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,160

    Default Re: Issue with flatpak

    Thanks for reporting back!
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •