Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: After upgrade from Leap 15.0 to 15.1, Autohiding Panel now oscillates/flashes

  1. #1

    Default After upgrade from Leap 15.0 to 15.1, Autohiding Panel now oscillates/flashes

    I have my panel configured to autohide. After the upgrade, it now seems to oscillate or "flash" randomly. By this I mean it unhides and rehides repeatedly, without stopping. In autohide mode, it should normally stay hidden unless the cursor approaches it. If I go to the panel and fiddle with it, it will stop oscillating, but then it soon starts oscillating again in a short time.

    I'm using KDE:

    KDE Plasma Version 5.12.8
    KDE Frameworks Version 5.55.0
    Qt Version: 5.9.7
    Kernel Version: 4.12.14
    OS Type: 64 bit

    Is this some kind of new "feature" that I can disable, or a bug? Has anyone else seen it?

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,746

    Default Re: After upgrade from Leap 15.0 to 15.1, Autohiding Panel now oscillates/flashes

    Try with a different user

  3. #3
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,265

    Default Re: After upgrade from Leap 15.0 to 15.1, Autohiding Panel now oscillates/flashes

    Quote Originally Posted by CountBakula View Post
    Is this some kind of new "feature" that I can disable, or a bug? Has anyone else seen it?
    There was a bug a while back where that occurred...

    https://bugs.kde.org/show_bug.cgi?id=376065

    ... although that report is still open I thought it had been fixed.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191016) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,629
    Blog Entries
    3

    Default Re: After upgrade from Leap 15.0 to 15.1, Autohiding Panel now oscillates/flashes

    Quote Originally Posted by CountBakula View Post
    Is this some kind of new "feature" that I can disable, or a bug? Has anyone else seen it?
    I think I remember seeing that in a virtual machine where I upgraded. I'm not sure what I did to fix it, and I have since deleted that virtual machine.

    My vague recollection was that I turned off auto-hide, logged out and logged in again, then turned on auto-hide.

    My practice for a long time has been to use auto-hide for the panel, and to switch the menu to the launcher based on cascading popup menus.

    I'm finding that I can no longer do that. I have to switch the menu first before I turn on auto-hide. The system where I had the problem that you describe, was one where I had turned on auto-hide first and switched the menu style later. And I'm guessing that's why it happened.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5

    Default Re: After upgrade from Leap 15.0 to 15.1, Autohiding Panel now oscillates/flashes

    Quote Originally Posted by gogalthorp View Post
    Try with a different user
    I don't immediately see the problem with a new user I add, but how does that solve my problem? I don't want to throw away all my configuration.

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,746

    Default Re: After upgrade from Leap 15.0 to 15.1, Autohiding Panel now oscillates/flashes

    If it works for a different user then something is amiss in you normal user's configuration.

    Maybe try nrickert's suggestion. ie turn it off log out back in then turn on again. That might reset the misbehaving config

  7. #7

    Default Re: After upgrade from Leap 15.0 to 15.1, Autohiding Panel now oscillates/flashes

    Quote Originally Posted by gogalthorp View Post
    If it works for a different user then something is amiss in you normal user's configuration.

    Maybe try nrickert's suggestion. ie turn it off log out back in then turn on again. That might reset the misbehaving config
    Already tried that. No Joy.

    As far as something being "amiss," it worked fine in all previous OpenSUSE versions, most recently in 15.0, so they've broken backcompat somehow here in a very nasty way.

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,746

    Default Re: After upgrade from Leap 15.0 to 15.1, Autohiding Panel now oscillates/flashes

    Well config file structures can change so sometimes it is best to just wipe them and recreate the desktop. You will find the plasma*rc files in the ~/.config directory. If you have done upgrades over multiple versions these things can pile up eventually something breaks. Since it works for different user it is most definitely a problem in your home.

    Not probably best to cleanout ~/.cache also

  9. #9
    Join Date
    Jan 2017
    Location
    Nürnberg, Germany
    Posts
    179

    Default Re: After upgrade from Leap 15.0 to 15.1, Autohiding Panel now oscillates/flashes

    Quote Originally Posted by CountBakula View Post
    Is this some kind of new "feature" that I can disable, or a bug? Has anyone else seen it?
    I remember testing some industrial Siemens touch-panel PCs in a lab once; the effect was with Windows NT, though, and the Windows task bar on auto-hide. (Officially, WinNT didn’t have USB drivers, but Siemens had some developed specifically for those PCs. The driver sometimes generated activity at the bottom-left screen edge which made the task bar oscillate.)

    Are you using some kind of touch-sensitive screen or Wacom-style tablet? KDE comes with support for those (see KDE System Settings → Workspace → Desktop Behavior → Touch Screen, also under Personalisation → Accessibility → Activation Gestures, also Hardware → Input Devices → Touchpad, and finally in Startup and Shutdown → Background Services → Startup Services → Touchpad). You may try disabling some of those options; I have done so. My panel is on auto-hide on the top of the screen.

    My reasoning is that your KDE may think there’s a device other than your mouse spuriously triggering an action at (0,0) on the screen. Maybe there’s also something going on with triggering on screen edges (Workspace → Desktop Behavior → Screen Edges). Are you able to move the panel from its current location to another screen edge?

  10. #10

    Default Re: After upgrade from Leap 15.0 to 15.1, Autohiding Panel now oscillates/flashes

    I said above that when I add a new user, I don't see the issue. So the assumption was it was KDE-config-related. However, today I tried moving ~/.config away, which I believe contains all of my user KDE config. After I restart plasmashell, the desktop appearance reverts to Leap 15.1 default, the same as the new user, but the problem still happens!

    So apparently, the reason it doesn't happen with a new user is related to the apps being run. I suppose certain apps have to be open for it to reproduce. I'm not running anything exotic - X apps konsole, xterm, emacs, KDE System Monitor. As far as processes with no window, some tomcat servers and openvpn.

    This leads back to my unanswered question. Is there some sort of a "attention getting" feature of certain apps like konsole that is expected to unhide the panel and hilite the affected panel button? Like on Windows, an app can cause your task bar to show itself and the related button to flash.

    If this feature exists, how do I disable it globally for the panel? I don't see anything obvious in the panel "more settings" GUI.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •