Results 1 to 5 of 5

Thread: LAN not working since last kernel (Tumbleweesd)

  1. #1
    Join Date
    May 2017
    Location
    Reunion Island
    Posts
    34

    Question LAN not working since last kernel (Tumbleweesd)

    Hi everybody,

    Yesterday I ran an update which installed 5.1.4-1-default kernel. Since then I have no ethernet connection any longer.

    I use Packman drivers for Realtek ethernet controller : r8169 never worked that well, so I installed r8168 and blacklisted r8169 (long ago, and it was working). Unfortunately, r8168 won't load any more, because it is not found in kernel modules. I see that my version of this module is designed for previous kernel 5.0.13-1. I did'nt found any version for 5.1.4-1 kernel.

    Any idea of what I could do ? I would of course greatly appreciate your help or any advice. Has anyone encountered the same issue ?

    Thanks for reading.

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,929

    Default AW: LAN not working since last kernel (Tumbleweesd)


  3. #3
    Join Date
    May 2017
    Location
    Reunion Island
    Posts
    34

    Default Re: LAN not working since last kernel (Tumbleweesd)

    It seems to be working sometimes after all, even with r8169 which is the default driver. I have to exclude a possible problem not related to the driver. (I moved to another box and restarted, and the problem is not very old, so I have'nt much hindsight). I'll be back in a couple of days or so.

    @Sauerland
    Thanks for your hints, I'll give a look anyway to both links.

  4. #4
    Join Date
    May 2017
    Location
    Reunion Island
    Posts
    34

    Default Re: LAN not working since last kernel (Tumbleweesd)

    I think I can confirm that the issue is solved.

    r8169 is now doing its job and there is no need any longer to blacklist it in order to favor r8168.

    Maybe due to recent updates ?

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,929

    Default AW: LAN not working since last kernel (Tumbleweesd)

    Now r8168 is updatet to Version 8.0.47, which builds fine on Tumbleweed.
    Version 8.0.45 does not as you have seen.
    Last edited by Sauerland; 07-Jun-2019 at 12:21.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •