I added the Chrome repo following instructions on this site https://www.linuxbabe.com/desktop-li...suse-leap-42-1

I know it says leap 42.1, but it should work for Leap 15.1 right? It did for leap 15.
It is after the
Code:
zypper ref
instruction that the error first occurs.
The repo is added to the YaST list.

Then subsequently in YaST, the following error messages popup.

I get this error
Code:
File repomd.xml from repository Google-Chrome
http://dl.google.com/linux/chrome/rpm/stable/x86_64
is signed with the following GnuPG key, but the integrity check failed: 

ID: 7721F63BD38B4796
Fingerprint: EB4C 1BFD 4F04 2F6D DDCC EC91 7721 F63B D38B 4796
Name: Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>
Created: 04/12/2016
Expires: Never

The file has been changed, either by accident or by an attacker,
since the repository creator signed it. Using it is a big risk
for the integrity and security of your system.

Use it anyway?
Right or wrong, I answered Yes to that question.

And this
Code:
Cannot access installation media 
http://dl.google.com/linux/chrome/rpm/stable/x86_64
 (Medium 1).
Check whether the server is accessible.
??