Als iemand na het updaten de melding krijgt
"you've launched an older version firefox" en je een nieuw profiel moet aanmaken...

Hier staat de oplossing:
https://techdows.com/2019/05/switch-...irefox-67.html

Gaat de laatste tijd niet zo goed met Firefox geloof ik.